1 2 3 4 Previous Next 48 Replies Latest reply on Dec 10, 2009 8:24 PM by 740425 Go to original post
      • 45. Re: Oracle 10g R2 Enterprise Manager Web Interface doesn't see the database

        Check this note in metalink

        Getting 'IO exception: Unknown host specified' while clicking on Administration link from DBConsole
        Doc ID: Note:351322.1
        • 46. Re: Oracle 10g R2 Enterprise Manager Web Interface doesn't see the database
          Hi people!,
          I tried to change my Time Zone but when i try to reset the agent i got the following message
          C:\ORACLE_HOME\oracle>emctl resetTZ agent
          Oracle Enterprise Manager 10g Database Control Release
          Copyright (c) 1996, 2005 Oracle Corporation. All rights reserved.
          Updating C:\oracle\product\10.2.0\db_1/HOSTNAME_orcl/sysman/config/em
          resetTZ failed.
          The agentTZRegion in:
          is not in agreement with what the agent thinks it should be.
          Fix your environment.
          Pick a TZ value that corresponds to time zone settings listed in:

          On supportedtzs.lst i have..
          # -06:00 Offset from GMT

          So I modified emd.properties as follows
          # Timeout value for reading http body, default is 60 seconds.

          i don't know what is happening?

          any comment about that!?
          • 47. Re: Oracle 10g R2 Enterprise Manager Web Interface doesn't see the database
            all I can say is this is interesting about the time zone which doesn't seem to be my problem.

            here is our setup:

            running three instances with three seperate installs of EM on the same server, windows 2003 and ALL the latest patches with the exception of the windows TIMEZONE article mentioned above...

            I did the deinstall of em
            reinstall of em a

            and ALL seperate instances look identical with the exception of the ports, and instance name. Time zones etc.
            when I invoke the EM for one, particular instance I cannot see the db, and I get the same java error.

            I know the db is ok I can sqlplus to it, and all is well, I know the em is running and I can stop, and start the service and get in with correct logins without problem except for what is mentioned above.

            very, very, strange
            • 48. Re: Oracle 10g R2 Enterprise Manager Web Interface doesn't see the database
              I was installing a second instance on Oracle on Windows XP SP3. The dbconsole for the first instance worked fine. For the second instance I was getting the error described in this thread. I tried several of the recommendations described here with recreating the dbconsole using emca.bat and updating the timezone. In the end, the solution for me was to update c:\winnt\system32\drivers\etc\hosts.

              When the dbconsole was not working, my hosts file only contained the following entry:

              After I added this entry to the hosts file:
              <hostname> localhost

              and restarted the dbconsole service, Enterprise Manager finally started working for me.

              The above hostname in the hosts file should match the hostname that is used in the directory name <ORACLE_HOME>\<hostname>_<SID> (which contains the sysman directory).
              1 2 3 4 Previous Next