1 2 3 Previous Next 40 Replies Latest reply on Jan 27, 2006 6:05 PM by 475982 Go to original post
      • 30. Re: Connection refused when attempting to contact 127.0.0.1:8080
        370659
        Once I get Oracle running again I am sure this information will be crucial. Thanks.
        • 31. Re: Connection refused when attempting to contact 127.0.0.1:8080
          428025
          Hi,

          This is slightly different from the other suggestions but happened to me yesterday when I installed XE on my laptop. I had a version of the Instant Client on there which seemed to cause problems like those you are describing. The install appeared to work but I couldn't connect, start the DB or do anything even though the services were listed as running.

          Removing XE, removing the Instant Client (or disabling by renaming the directory / removing from the PATH statement) and then re-installing XE worked like a dream.

          I guess if you have XE installed there's no real benefit in keeping Instant Client on the machine anyway so may be best off removing altogether...

          Good luck,
          Steve
          • 32. Re: Connection refused when attempting to contact 127.0.0.1:8080
            Earl Lewis
            Steve, I actually had the exact same problem, which resulted in me doing some long-procrastinated house cleaning.

            However, I was wondering about keeping the instant client on the same machine where XE is installed. Afterall, XE is a good way to take Oracle with you when you're off the network but it's no substitute for your production systems, which are on the network and ergo, require the IC or some other Oracle client. So I'd like to know if the IC and XE can coexist?

            Earl
            • 33. Re: Connection refused when attempting to contact 127.0.0.1:8080
              Hans Forbrich
              Your point "... which are on the network and ergo, require the IC or some other Oracle client." confuses me.

              Oracle XE provides the entire client substrate.

              The client portion of the XE install provides Oracle Networking as well as SQLPlus and can be used in conjunction with ODBC. It works on or off the network and works against the same servers as Instant Client. The XE services can all be turned off and this is still true.

              I have verified this several times by accessing all the Oracle servers in my network using the XE-installed client. (It has required tnsnames.ora maintenance, although that is simply my laziness for not using ldap.) I have also accessed other XE installations across the net, both at SQLPlus and HTMLDB levels.

              I see no advantage, other than testing the capacity of a disk drive, in keeping Instant Client on a machine where XE is installed.

              Perhaps you could expand on your comment, or others could add reasons for Instant Client in this environment that I do not recognize.
              • 34. Re: Connection refused when attempting to contact 127.0.0.1:8080
                Earl Lewis
                Apologies, my ignorance of XE showing. I didn't realize that XE also installed all the "entire client substrate." I just installed it yesterday and had not tried any of my network based Oracle access since.

                Thanks for the clarification. This will save me a bunch of time and headaches - looking for something that doesn't need to happen.

                Earl
                • 35. Re: Connection refused when attempting to contact 127.0.0.1:8080
                  475982
                  I'm also having the problem getting to the Database Home Page on my system.

                  - I'm running XP Pro.

                  - I also have Oracle 10g Personal Edition installed on this system. (I'm trying to test if Express will work for my needs, as it uses many fewer resources).

                  - For the Express Edition, I set it up to use port 8088 (as 8080 was already taken by the Personal Edition).

                  - To test the connection, I've been using telnet. I can connect with "telnet 127.0.0.1 8080" for the Personal Edition, but "telnet 127.0.0.1 8088" gets no connection.

                  - I cannot start the listener - it exits immediately. Here's the output from running "Start Database":
                  D:\oraclexe\app\oracle\product\10.2.0\server\BIN>net start OracleXETNSListener
                  The OracleXETNSListener service is starting.
                  The OracleXETNSListener service could not be started.

                  The service did not report an error.

                  More help is available by typing NET HELPMSG 3534.


                  - I can connect to the database using sqlplus with system as my userid. (I'm using the sqlplus in the Express BIN directory, not the one for the Personal Edition and on startup of sqlplus it clearly stays it's connected to the Express Edition).

                  What next?

                  Thanks.
                  • 36. Re: Connection refused when attempting to contact 127.0.0.1:8080
                    241066
                    Re:
                    What next ?
                    A stiff drink ?

                    Seriously though, check the following

                    Are the following services started (check via Control Panel)
                    OracleXETNSListener
                    OracleServiceXE

                    If not, try starting them via the Control Panel. Start the OracleXETNSListener service first, and if it starts OK, then OracleServiceXE.

                    If they start,proceed to step 2
                    Otherwise report any error messages. Also check for Oracle related messages in the Event Viewer (typically Application Log, but also look at the other logs as well)
                    Report any such errors here

                    Step 2
                    Check that the listener and database are both actually started
                    From the DOS command line, type
                    lsnrctl status.
                    If you get an error message report it here. Otherwise
                    from the DOS command line, type
                    sqlplus /nolog
                    connect / as sysdba;

                    If you get an error message, report it here.
                    If you get "Connected to an idle instance", type
                    startup
                    If you get an error message, report it here.
                    Otherwise go to Step 3

                    Step 3
                    Check that the Home Page is still not available. If it isn't then
                    Check that everything is listening as it should.
                    From the DOS command line, type
                    lsnrctl status
                    Paste the output here
                    From the DOS command line, type
                    netstat -a
                    Paste the output here

                    From the dos command line type
                    sqlplus /nolog
                    connect / as sysdba;
                    select dbms_xdb.gethttpport() from dual;
                    Paste the output here

                    Last but not least, paste the full URL you are trying to connect to the database with (note that the URL provided on the desktop will be wrong, as it will have defaulted to port 8080)

                    I'm not sure what you are doing with telnet, but the database is not opening a telnet port, just and HTTP port. So I would be surprised if telnet worked at all.
                    • 37. Re: Connection refused when attempting to contact 127.0.0.1:8080
                      Hans Forbrich
                      Ultimately you only want one listener monitoring on behalf of all the services on the machine. Having two listeners usually means manual configuration.

                      By default, I would use the highest versioned listener as the newest version usually can cover all the previous versions [that are supported by Oracle Support at the time of release].

                      Your message might be an indication of port conflict. In each %ORACLE_HOME% you have a LISTENER.ORA (in %ORACLE_HOME%\network\admin) .... please open these and check whether you see lines like
                      LISTENER =
                        (DESCRIPTION_LIST =
                          (DESCRIPTION =
                            (ADDRESS = (PROTOCOL = TCP)(HOST = fuzzy)(PORT = 1521))
                          )
                        )
                      and let us know whether they both want PORT = 1521 ...

                      If yes, you have a few choices:
                      - use one listener for all?
                      - use both listeners and manually config?

                      If no, please post both listener.ora files (feel free to mask out the host name or other critical identification)
                      • 38. Re: Connection refused when attempting to contact 127.0.0.1:8080
                        475982
                        First regarding the XE services:
                        The OracleXEClrAgent and OracleXE services start up automatically and continue running. The OracleXETNSListener service is supposed to start up automatically, but does not, and after starting it manually it exit immediately.

                        My installation of 10g Personal Edition and XE use different listening ports.

                        This is listener.ora for 10g Personal Edition

                        # listener.ora Network Configuration File: D:\oracle\product\10.2.0\db_1\network\admin\listener.ora
                        # Generated by Oracle configuration tools.

                        SID_LIST_LISTENER =
                        (SID_LIST =
                        (SID_DESC =
                        (SID_NAME = PLSExtProc)
                        (ORACLE_HOME = D:\oracle\product\10.2.0\db_1)
                        (PROGRAM = extproc)
                        )
                        )

                        LISTENER =
                        (DESCRIPTION_LIST =
                        (DESCRIPTION =
                        (ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC1))
                        (ADDRESS = (PROTOCOL = TCP)(HOST = xxx.xxx.com)(PORT = 1521))
                        )
                        )


                        For Oracle XE:

                        SID_LIST_LISTENER =
                        (SID_LIST =
                        (SID_DESC =
                        (SID_NAME = PLSExtProc)
                        (ORACLE_HOME = D:\oraclexe\app\oracle\product\10.2.0\server)
                        (PROGRAM = extproc)
                        )
                        (SID_DESC =
                        (SID_NAME = CLRExtProc)
                        (ORACLE_HOME = D:\oraclexe\app\oracle\product\10.2.0\server)
                        (PROGRAM = extproc)
                        )
                        )

                        LISTENER =
                        (DESCRIPTION_LIST =
                        (DESCRIPTION =
                        (ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC1))
                        (ADDRESS = (PROTOCOL = TCP)(HOST = xxx.xxx.com)(PORT = 1522))
                        )
                        )

                        DEFAULT_SERVICE_LISTENER = (XE)
                        • 39. Re: Connection refused when attempting to contact 127.0.0.1:8080
                          Hans Forbrich
                          (Interim message - I'll continue when I get back)

                          Then we need to check whether the database knows which port to use for auto-registration.

                          In sqlplus you could use
                          pop2@fuzzy:~> sqlplus / as sysdba

                          SQL*Plus: Release 10.2.0.1.0 - Beta on Thu Jan 26 11:09:30 2006

                          Copyright (c) 1982, 2005, Oracle.  All rights reserved


                          Connected to:
                          Oracle Database 10g Express Edition Release 10.2.0.1.0 - Beta

                          SQL> show parameters listener

                          NAME                                 TYPE
                          ------------------------------------ ---------------------------------
                          VALUE
                          ------------------------------
                          local_listener                       string
                          (ADDRESS = (PROTOCOL=TCP) (HOST=fuzzy) (PORT=1521))
                          remote_listener                      string
                          but the data should also be in the parameter file.
                          • 40. Re: Connection refused when attempting to contact 127.0.0.1:8080
                            475982
                            I also discovered I was having problems with the Personal Edition.

                            I decided that having both 10g Personal and XE installed on the same system does not work well, unless some major tweaking is done.

                            I uninstalled XE, and the Personal Edition is working as before.

                            I'll have to explore the use of XE for my needs later. Thanks for your time.
                            1 2 3 Previous Next