4 Replies Latest reply: Feb 14, 2014 9:37 AM by CraigB RSS

    tab canvas

    ab*424391*iy

      Hello

      I have two issue in developer forms 10g (tab canvas)

      the first one is when i try to back to object navigator after i design form using tab canvas

      i found some of items of tab canvas are invisible but the prompt of them are visible

      when i try to make any change in properties of these items its appear, when i run the

      form and back again to object navigator to open the canvas i found again items are hidden

      i did not know the reason of that and i did not found any properties to solve this problem.

      the second one is when i design form from three tab i didn't know how to make the

      every click on each tab to display the information of that tab(execute query) without click on any

      item of that tab,where every tab is built on data block.

      thanks in advance for help me 

        • 1. Re: tab canvas
          ab*424391*iy

          hello

          may be bugs in the software causes the first issue..?

          • 2. Re: tab canvas
            CraigB

            What is your exact Forms version (eg: 10.1.2.0.2, etc).  This could be a bug in the Forms Builder, but it actually sounds more like you have inherited (subclassed) objects in your form and the Forms Builder can't find the source of the subclassed objects.  Do you get an error when you open the form that indicates the Forms Builder can't find files?

             

            Craig...

            • 3. Re: tab canvas
              ab*424391*iy

              Thanks for answer me

              the version of the form builder is 10.1.2.0.2 , and i did not get any error when i open the form..

              what should be do please.

              • 4. Re: tab canvas
                CraigB

                Are you subclassing these objects?  If so, double-check the source object file to ensure it is OK.  If your item is not subclassed, it could be that the property value is having problems.  Try restoring the property to its default value (open the property pallet on the item, select the Height/Width properties, click the "Inherit" button in the Property Pallet toolbar).  Once you have reset the affected property to its default value - save - exit - and reopen your form to see if that corrects the problem.  If it does, change the properties back to their desired value.

                 

                If this still doesn't correct the problem, the only other thing I can think to try is to convert your form to a text file (.fmt) or to xml and then re-import from either of these formats.  To export your form to a Forms Text File (.fmt) follow these steps:

                1. From the Forms Builder Menu click on the File menu and select the Convert option.
                2. From the Convert dialog box, choose:
                  1. Type = Form (default property)
                  2. Direction = Binary-to-Text
                  3. Click Browse... button to select the file to convert.
                3. Click Convert.

                 

                This will convert your form to a .fmt format.  I recommend closing the Forms Builder and restarting before converting the .fmt back to a .fmb.  To convert the .fmt back to a .fmb follow the same steps listed above and change item 2.2 from "Binary-to-Text" to "Text-to-Binary".

                 

                To convert your Form to xml and back, follow these steps:

                1. Open a command (cmd.exe) window.  This step is done manually.
                2. Navigate to your Developer Suite Home directory (typically: C:\DevSuiteHome_1)
                3. Navigate to the \BIN directory
                4. Run a directory listing of all Windows Batch Files (dir *.bat).
                  1. Among the many batch files listed, you should see "frmf2xml.bat" and "frmxml2f.bat"
                  2. This step simply confirms the batch files you need are available.
                5. Navigate to the directory where your Forms Binary file (.fmb) exists
                6. Run the following command:
                  1. frmf2xml FORM_NAME.fmb
                  2. For example, if your form name is MAIN_MENU.fmb and this file resides in the TEMP directory on your C-drive the command would be:
                  3. C:\TEMP> frmf2xml MAIN_MENU.fmb
                  4. This process takes a couple of minutes.  If you receive an error this is most likely due to your environment variables not being setup correctly.  Make sure your Oracle Home directory is listed in your PATH variable.

                 

                If you were able to successfully convert your file to xml, now convert it back to a Forms Binary as follows:

                1. While in the same directory, first make a back up copy of your original .fmb.
                  1. type:  rename FORM_NAME.fmb FORM_NAME.fmb.orig
                2. Now type: frmxml2f FORM_NAME.xml and press Enter.
                3. Again, you will see the Forms to XML Tool converting your .xml file

                 

                Once complete, try opening your newly converted Forms Binary in the Forms Builder to see if you still have the same problem.

                 

                If the problem persists after this, I recommend you open two instances of the Forms Builder (one with the problem form and one with a new Forms module) and copy all of the objects from the problem form to a new form and save this new form.

                 

                Hope this helps.


                Craig...