10 Replies Latest reply: Feb 5, 2014 9:41 AM by DGS RSS

    Data Modeler>File>Open


      When I run the newest data modeler ( without using SQL Developer, I do not have the ability to open a DMD file from a previous 3.x modeler session.

      Does this new version REQUIRE the usage of SQL Developer?  I like using this modeler as a stand alone tool.

        • 1. Re: Data Modeler>File>Open
          Philip Stoyanov-Oracle

          I believe you can open even design created with Data Modeler 2.x.

          Can you explain the problem?



          • 2. Re: Data Modeler>File>Open

            When I start the Modeler (v4.00833) as a standalone and go to File on the menu bar, I do not see a menu option for Open.  In previous versions of the data modeler (v3.30747), I could open DMD files from the FILE>OPEN menu.


            When I execute datamodeler64.exe, The only items on the File menu are:

            Save as

            Compare with

            Replace with



            What happened to Open?

            • 3. Re: Data Modeler>File>Open
              David Last-Oracle

              It seems there's something wrong with your installation of Data Modeler.

              Are you running on Windows?

              Did you unzip it into a new folder?

              Did you have any problems when you first started it up?


              You could try downloading a fresh version (perhaps the "with jre" version) and seeing if that resolves the problem.



              • 4. Re: Data Modeler>File>Open

                I've downloaded this several times, with and without jre.

                So, to be clear, this CAN still be run as a stand alone system, correct?  (stand alone=without running SQL Developer)

                I grabbed the 64 version, maybe I'll try to take the 86 version.

                Everyone else has a FILE>OPEN option on the menu?

                • 5. Re: Data Modeler>File>Open

                  Ok, I've downloaded the x86 version without the jdk.  When I tried to start this, it wanted to know where my JDK was.  I tried two places (I didn't really know where it was).  Neither was correct, so I downloaded another JDK from Oracle.  Now the modeler won't ask me where it is, its still trying to use the directory I supplied the last time.  Which file needs to be edited to fix this?

                  • 6. Re: Data Modeler>File>Open
                    David Last-Oracle

                    Assuming you're on Windows 7,the file is product.conf file in folder C:\Users\<your user>\AppData\Roaming\Oracle SQL Developer Data Modeler\

                    You can either edit it, or you can delete/rename it, in which case it will prompt you again for the JDK next time you start Data Modeler.



                    • 7. Re: Data Modeler>File>Open

                      Excellent David!

                      That brought the prompt back and the Modeler started after I gave it the path for the jdk.


                      I'm back to my original problem.  My File menu option does not have an entry for OPEN.  In fact, it is missing a lot of things v3.x had.

                      I see:



                          Save As

                          Compare With

                          Replace With



                      No option to open an existing DMD file.

                      I'm not using SQL Developer, I'm just running the Modeler alone.


                      I feel like I'm doing something stupid (wouldn't be the first time).


                      Earlier versions of the data modeler (v3.x) would have




                         Close All


                         Save As


                      • 8. Re: Data Modeler>File>Open

                        I see a directory for SQL Developer within the data modeler structure,   Perhaps that is the portion that contributes the OPEN, SAVE, SAVE AS??

                        • 9. Re: Data Modeler>File>Open
                          David Last-Oracle



                          I have just found this message about a similar problem with Data Modeler 3.0: 30EA2 problem: Menu items not available


                          I suggest you try deleting or renaming the folder C:\Users\<your user>\AppData\Roaming\Oracle SQL Developer Data Modeler\system4.0.0.833 (and when it asks if you want to migrate settings from a previous version, I suggest you say No).

                          If this fails to resolve the problem, you could also try renaming its parent folder C:\Users\<your user>\AppData\Roaming\Oracle SQL Developer Data Modeler (but this will also affect the settings for any earlier Data Modeler versions you have).



                          • 10. Re: Data Modeler>File>Open




                            This worked GREAT!! There were several files that needed to be removed, but they were all identified by the version number.


                            Folder: system4.0.0.833


                            File: home_4.0.0.833


                            Thank you so much you your assistance.  I really appreciate persistent people like you.