3 Replies Latest reply: Feb 27, 2014 2:15 PM by Gary Graham-Oracle RSS

    Connection button not working

    lindzylu

      Hello all,

      I recently installed 12_1 client so I have 11.1 and 12_1, although I am not sure if this would cause this problem.

      When I click the connection button on sql developer which worked fine the last time I have various connections that are

      still working now however if I try to add another it just times out without the GUI where you can put in the user/port/pw/ etc.

      Its really strange. Like I said its been awhile since I have set up a connection but it's only two steps am I missing something?

      Thanks in advance,

      Confused...

        • 1. Re: Connection button not working
          Gary Graham-Oracle

          You don't say which version of SQL Developer is installed.  Since you have multiple Oracle clients installed, I recommend reading the following blog post by one of the SQL Developer PMs, Jeff Smith:

           

          http://www.thatjeffsmith.com/archive/2014/01/oracle-sql-developer-4-and-the-oracle-client/

           

          Hope that helps,

          Gary

          SQL Developer Team

          • 2. Re: Connection button not working
            lindzylu

            I did install SQL dev 4 and 3.2 I tried multiple dev's with the same result... however I did find out why thought I should post it here as it seems an uncommon problem I am sure due to the fact that I have 2 clients installed.

            The way I set them up is in the tnsnames.ora file by using

            IFILE = "D:\location"

            so that both clients could use the same tnsnames file and that works great for the clients.

            But for some reason SQL developer gets confused even though you do not need client it still attempts to grab that tnsnames file;

            I assume because its in the environments and SQL developer automatically looks for that, thus sending a bug into the GUI so that no new connections can be established. As soon as I delete or comment out the IFILE in tnsnames.ora Viola! it's back online.

             

            I will need to look into another way to set up 2 clients in order to fix the issue or just go back to one

            Anyone input on how to set up 2 clients without IFILE is appreciated. Thanks!

            • 3. Re: Connection button not working
              Gary Graham-Oracle

              SQL Developer added support for IFILE way back in it's initial release, and fixed a bug concerning trimming off any blank spaces around the equal sign for the 2.1 release.  So, in theory, your original approach should work.  But I believe there is one "gotcha"...

              The way I set them up is in the tnsnames.ora file by using

              IFILE = "D:\location"

              It seems the file specification in the IFILE=<filespec> entry is appended as a relative path to the parent directory of the current "tnsnames.ora"-like file. Since your approach uses an absolute path, that is the most likely cause of the problem. Trying using relative path references. This is the way SQL Developer handles IFILE even if not consistent with the way other clients work.

               

              Also make sure to set the value of

              Tools > Preferences > Database > Advanced > Tnsnames Directory

              to the directory containing the tnsnames.ora file with the top-level IFILE (since such references can be nested) entries. Or, alternatively, set it to a directory containing a dummy tnsnames.ora file without any IFILE entries so the disturbance to connecting with connection type =  basic does not occur.

               

              Regards,
              Gary

               

              Message was edited by: Gary Graham