0 Replies Latest reply: Feb 12, 2014 2:51 AM by jhkn RSS

    Global Theme Creation Bug -> No Display Points

    jhkn

      Hi,

       

      I Have discovered a bug. When creating a public theme not all theme components are copied.
      Follow the following steps to reproduce the error.

       

      Step 1 - Create new application

      • Create new Database application
      • Select the "Blue Responsive (Theme 25)" Theme
      • (In my case this is app_id 270)

       

      Step 2 - View the template source

      • Go to the templates section.
      • Open the source of a Page Template. For example "Two Level Tabs - No Sidebar"
        Go to the "Display Points" region. There are some records here.
      • Open the source of a Region Template. For example "Standard Region"
        Go to the "Display Points" region. There are some records here.
      • Query's:
        select * from wwv_flow_page_tmpl_disp_points where flow_id = 270; --> Records Found
        select * from wwv_flow_plug_tmpl_disp_points where flow_id = 270; --> Records Found

       

      Step 3 - Create a Public Theme

      • Go to the "internal" workspace
      • Open the "Manage Instance" Tab
      • Open the "Public Themes"
      • Choose "Create Public Theme"
      • Use the previously created application and copy the "25. Blue Responsive" theme.
      • Query's
        select * from wwv_flow_page_tmpl_disp_points where security_group_id = 10  and trunc(created_on) = trunc(sysdate); --> Records Found
        select * from wwv_flow_plug_tmpl_disp_points where security_group_id = 10  and trunc(created_on) = trunc(sysdate); --> Records Found

       

      Step 4 - Create a new application with this public theme

      • Create new Database application
      • In the theme step select "Custom Themes in the Lisbox"
      • Select the previously created public theme. (with the wrong icon)
      • (In my case this is app_id 272)

       

      Step 5 - View the template source

      • Go to the templates section.
      • Open the source of a Page Template. For example "Two Level Tabs - No Sidebar"
        Go to the "Display Points" region.
        BUG: All display point records are missing
      • Open the source of a Region Template. For example "Standard Region"
        Go to the "Display Points" region.
        BUG: All display points records are missing
      • Query's:
        select * from wwv_flow_page_tmpl_disp_points where flow_id = 272; --> No Data
        select * from wwv_flow_plug_tmpl_disp_points where flow_id = 272; --> No Data

       

      Thanks!

       

      Joost