2 Replies Latest reply: Apr 2, 2014 6:33 PM by PhilBolte RSS

    Integrated SOA Gateway Test After Upgrade - Testing ISG installation using operation TESTUSERNAME in FND_USER_PACKAGE

    Amit-123

      Hi,

       

      I have EBS R12.1.3 instance upgraded from R12.1.1 I have also installed Integrated SOA Gateway folllowing (Doc ID 556540.1)

      All mentioned patches applied successfully and configuration completed.

      Now I am trying to Perform basic testing of Integrated SOA Gateway Installation after following the Installing Oracle E-Business Suite Integrated SOA Gateway, Release 12 https://support.oracle.com/epmos/faces/DocumentDisplay?id=556540.1Document 556540.1 as per (Doc ID 1506065.1)

      All the steps as mentioned in (Doc ID 1506065.1) are complete i.e.

      1. Generate the WSDL

      2. Deploying the Web Service

      3. Create Grant

      4. Test Service Invocation

      Select -> "View WSDL" link under  Web Service - SOA Provider

      The browser opens with the URL of the WSDL e.g.  http://<myserver>:8000/webservices/SOAProvider/plsql/fnd_user_pkg/?wsdl

      Remove the "?wsdl" from the WSDL URL so that what remains is only http://<myserver>:8000/webservices/SOAProvider/plsql/fnd_user_pkg/'  and press Enter key

      The service endpoint is now displayed and one can proceed to test with following steps:

      Select the Operation - TESTUSERNAME from the drop down list
      Expand the WS-Security  and check include in Header flag
      Provide the Username you created the grant for e.g. SYSADMIN and Password for the User

       

      In the Header enter:

      Responsibility - SYSTEM_ADMINISTRATOR
      RespApplication - SYSADMIN
      SecurityGroup - STANDARD
      NLSLanguage - AMERICAN

       

       

      In the Body enter:

      X_USER_NAME : <username to test>

       

       

      Press the Invoke button

       

      After following above steps I am getting error "java.security.PrivilegedActionException: javax.xml.soap.SOAPException: Message send failed: For input string: """

       

      I am not sure what is the cause of this error and how to debug and resolve the problem. I also followed another note to store security values in FND vault using script$FND_TOP/sql/afvltput.sql.

      where

      module = SYSADMIN

      key = welcome

      password = sysadmin

       

      select fnd_vault.get ( 'FND', 'welcome' ) from dual, returns the password for SYSADMIN.

       

      Please help as I am stucked and unable to proceed.

       

      Thanks,

      Amit