4 Replies Latest reply on Feb 19, 2014 4:21 PM by Cedric

    Launch Sqldeveloper 4 on a network share/mapped drive

    Cedric

      Hi everybody,

       

      I'll know if it is possible to launch Sqldeveloper 4 on a network share or on mapped drive?

       

      Configuration is :

       

      Windows 2008 R2

      Sqldeveloper 4

      JDK 7 32bit or JDK 7 64bit

       

      Purpose : To simplify deployment and upgrade of this tool on several VMs

       

      I've tried both method without success with JDK 7 32 or 64 bit.

       

      In both case, the process start and seem to freeze after a few seconds.

       

      I've tried to launch application in debug mode but nothing appear in console or after press "Ctrl+break".

       

      Thanks in advance,

       

      Cédric

        • 2. Re: Launch Sqldeveloper 4 on a network share/mapped drive
          Cedric

          Thanks Jeff,

           

           

          But this link is for share a setup on any machine.

           

           

          The option "-Duser.home" seem to do the same think that an environment variable named "IDE_USER_DIR". This point is okay.

           

           

          The problem is that I can't start Sqldevolper on a network share or on mapped drive.

           

           

          I've unzip the last version on a mapped drive and when I try to start it, it doesn't work. The matter is the same on a network share.

           

           

          To avoid to do 5, 10, ... update for a new release, I would like only one installation. It will be easier to update the tool.

           

           

          Must I to install sqldeveloper on each machine? The documentation don't say if that is possible or not.

           

           

          Thanks for your next answer(s),

           

          Cédric

          • 3. Re: Launch Sqldeveloper 4 on a network share/mapped drive
            thatJeffSmith-Oracle

            You can install it anywhere you want. When it runs, it's going to want to write to the User, Application Data directory. If it can't, I imagine it will hang - which is what you might be seeing. You can tell it exactly where to write those settings to using the directive that Kris mentions in his blog.

             

            So is the problem starting it FROM the network drive? Have you confirmed it's working locally before you try to start it remotely?

            • 4. Re: Launch Sqldeveloper 4 on a network share/mapped drive
              Cedric

              Yes, I tried and it's works fine. And user's preferences are set on a network share.

               

              Network Share :

               

              When I start Sqldeveloper nothing appears on the screen. I've waited several minutes, but nothing change.

              In task manager, I can see a process sqldeveloper.exe for a few seconds.

               

              So I start Sqldeveloper64 in debug mode, the DOSprompt print "Java asserts are enables!" and after few second it disappear.

               

              Mapped Drive :

               

              Sorry, I must miss something... Yesterday it didn't work, but today it's works fine...

               

              I've still tested it on twice another server :

               

              - On the first : It didn't work the first time and it's working after

              - On the second : It has worked directly

               

              It's a bit strange... But I think I've do something differently or I've do a mistake. If I found a process (step by step) that don't work, I'll to publish it on a new thread.

               

              I have a solution that will please to IT.

               

              But if you have any ideas the reason that doesn't work on Network share. I hope you share your investigation.

               

              Thanks for all,

               

              Cedric