6 Replies Latest reply: Feb 26, 2014 2:31 AM by Christian Neumueller RSS

Strange behavior from the APEX Plattform, corrupt applications

pinnom Newbie
Currently Being Moderated

Hi,

the problems are hard to explain.

A few weeks ago I changed a PL/SQL-Process in a application. But if I ran the page I couldnt see my changes. The process runs as before. Then I changed the proces again and put some "insert into test"-statements in the process to ensure that the changes are executing. But still the process works without any changes. Then I export the application, drop it and import it again. After that the process was running fine.

 

Later I dropped a item, but after dropping I could still see the item in the Application Builder. Then I tried to edit the item, but I got the message "No data found". I checked all items with

select *

from  apex_application_page_items

where application_id=118

  and page_id=1;

and I saw that the item was dropped of course, but the Application Builder still showed it. Closing the browser, clearing the browser cache didnt help. Then I export the application, dropped it again and import it. After that the item was not in the Applictation Builder.

 

Today I run the application and I get the failure

Error during rendering of region "Vorbereitete Prüfungen".

ORA-22922: nonexistent LOB value

 

is_internal_error: true

apex_error_code: APEX.REGION.UNHANDLED_ERROR

ora_sqlcode: -22922

ora_sqlerrm: ORA-22922: nonexistent LOB value

component.type: APEX_APPLICATION_PAGE_REGIONS

component.id: 10155924221954343

component.name: Vorbereitete Prüfungen

error_backtrace:

 

ORA-06512: in "APEX_040200.WWV_FLOW_DISP_PAGE_PLUGS", Zeile 4613

ORA-06512: in "APEX_040200.WWV_FLOW_DISP_PAGE_PLUGS", Zeile 3220

 

After this failure I export the application and import it in a other application-id. The "new" application is now running fine (at least in this moment!).

 

What is my problem?

 

We are using APEX 4.2.2.00.11.

 

Kind Regards,

Mark

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points