3 Replies Latest reply on Feb 28, 2014 8:20 PM by nudo

    SQL Developer 4.0.1 - Snippets Missing

    nudo

      I don't see snippets in SQL Developer 4.0.1.  The window is missing and View --> Snippets is missing from the menu.  I have disabled all features, restarted, re-enabled all features, and restarted.  I have even checked the shortcut dialog for a shortcut key, but there's nothing there.  I cross checked with 4.0.0 and they are available in the last version.

        • 1. Re: SQL Developer 4.0.1 - Snippets Missing
          Jeff Smith Sqldev Pm-Oracle

          Try Window > Reset Windows To Factory Settings

           

          It's in my working copy of 4.0.1 on Windows.

          1 person found this helpful
          • 2. Re: SQL Developer 4.0.1 - Snippets Missing
            Aleksander Stopar

            I got similar problems 2 months ago. Probably a bad installation - either a corrupted download or a bad extractor. See my post Re: 4.0EA3 Can not view Snippets

             

            Hope this helps

            Alex

            1 person found this helpful
            • 3. Re: SQL Developer 4.0.1 - Snippets Missing
              nudo

              It looks like there's a bug re-enabling the snippets feature after first disabling it.  I tried the Reset Windows to Factory Settings option, which worked, but it was not apparent right away.  It wasn't until I re-loaded SQL Developer, after resetting windows, that I was able to see snippets again.  I ran through a few test scenarios to see what was causing the issue, and came up with these results.

               

              1. After resetting windows the first time, I had to re-start SQL Developer to view snippets.
              2. Once the first reset and reload was done, each time I disabled and re-enables snippets, I still had to reset my windows, but it would show up immediately after reset.

               

              I think that there may have been something carried forward from my previous preferences that was cleared the first time I reset windows and just required a restart to take affect.  Now I can consistently reproduce the bug just by disabling snippets and re-enabling them. 

               

              Thanks for the reset windows tip