4 Replies Latest reply: Mar 3, 2014 8:41 AM by Pieter VN RSS

    SQL Developer 4.0.1 update can't connect (ORA-12705 error)

    Pieter VN

      Hi all


      I'm using Oracle SQL Developer for quite some time now, both on Windows 7 (upgraded from XP) and Mac OS X (10.6 Snow Leopard up to 10.9 Mavericks). I was using version 4.0.0 (build MAIN-13.80) on Windows and Mac just fine, but an annoying bug was present on the Mac client. This is why I updated to version 4.0.1 (build MAIN-14.48) in the hope that this issue was fixed.


      Unfortunately, after opening the newer client on Mac I am not able to connect to any database anymore, this error pops up (please note the 4.0.1 update works just fine on Windows):


      ORA-00604: error occurred at recursive SQL level 1

      ORA-12705: Cannot access NLS data files or invalid environment specified

      00604. 00000 -  "error occurred at recursive SQL level %s"

      *Cause:    An error occurred while processing a recursive SQL statement

                 (a statement applying to internal dictionary tables).

      *Action:   If the situation described in the next error on the stack

                 can be corrected, do so; otherwise contact Oracle Support.

      Vendor code 604


      I've searched both this forum and used google for the exact reason and various methods to fix this.

      There is no NLS(_LANG) environment variable present on my system, I didn't set exotic regional/language settings. I tried to ignore the NLS settings from the SQL Developer configuration, I also tried removing the .sqldeveloper config folder from my home directory (to simulate a fresh install) but nothing seems to help.

      The oracle database output for "select userenv('LANGUAGE') from dual;" is AMERICAN_AMERICA.AL32UTF8, my Mac is configured with English as the system language but the region is set to Belgium. I'm not willing to change my region config to English/USA since the date and hour notation would then be different.

      I'm running the Oracle provided java jdk version 1.7.0_45. (I know this is not the latest version, but I would be surprised if this is the cause of my issues.)


      I can run version 4.0.0 and 4.0.1 side by side: The older version can connect properly while the 4.0.1 update gives this error. This makes me think a regression is present, or the updated version could be more strict with regards to these NLS settings?


      For the moment I keep using version 4.0.0 on Mac, but this is very annoying since a showstopper bug is present in that version. (I can't even test if this bug is fixed in 4.0.1 since I can't make any connection.)


      I was wondering if anybody had mac-specific workarounds. Or perhaps if this is actually a regression this information might be useful for the developers.

      (If more detailed information is needed, I'll gladly provide it.)


      Kind regards