1 Reply Latest reply on Mar 17, 2014 12:48 PM by thatJeffSmith-Oracle

    Debugger Not Stepping through the steps correctly in v


      When attempting to debug some code I was writing Friday I used the debugger in this newest version of SQL Developer ( for the first time. As I stepped through the code the debugger seemed to be stepping in between steps (white space) in the code rather than on actual lines. I recompiled and tried again only to get the same result. I'm not sure what is causing this, but I also somehow lost a large amount of my work doing this. It is almost like the debugger code wasn't up to date with the current compiled code and somehow this over wrote the up to date code.


      I tried this again later in the weekend and got the same issue when trying to debug. (Stepping into whitespace rather than on to actual code lines.) This time I was careful not to recompile from the same code I had the issue with and I didn't lose my work. Is there something I should do to make the debugger work or is this a known issue of some kind and I should go back to 3 that was working fine?