4 Replies Latest reply: Mar 17, 2014 8:30 PM by r_g_financials_dba RSS

    crsctl does not show correct info

    r_g_financials_dba

      Here is what happened.

      This is a test system at home for learning. of Oracle RAC 11.2

      It was working fine.

      I had a data group called DATA in ASM

      I added a new data group to asm called DATA1 and then I dropped the DATA1

       

      Now when I reboot the machine...the database does not start automatically ... when I go to sqlplus and use the command startup...the database starts up

      However after startup if I go  and use the command

      crsctl  stat res -t

      I expect to see the status of ora.rac.db as ONLINE

      I am seeing the status of ora.rac.db as OFFLINE

       

      I heard  that after dropping a data group we need to do some maintenance using SRVCTL command

      I checked at Metalink but was unable to find any document.

       

      Please assist.

        • 1. Re: crsctl does not show correct info
          r_g_financials_dba

          ./srvctl config database -d rac -a

          Database unique name rac

          Database name rac

          oracle home :/u01/app/oracle/product/11.2.0/db_1

          oracle user : oracle

          spfile : +DATA/rac/spfilerac.ora

          Domain :

          Start options : open

          Stop options : immediate

          Database role : primary

          Management Policy : AUTOMATIC

          server pool : rac

          Database instances : rac1, rac2

          Disk Groups : DATA

          Services

          Database is enabled

          Database is administrator managed

          • 2. Re: crsctl does not show correct info
            r_g_financials_dba

            crsd starts oraagent and

            oraagent starts database instance

             

            where are the logs for

            a) crsd

            b) oraagent

            • 3. Re: crsctl does not show correct info
              r_g_financials_dba

              I did the following

              srvctl getenv database -d rac

              I found that the Oracle_base was not set ...so I fired the next command

              ./srvctl setenv database -d rac -t "ORACLE_BASE=/u01/app/oracle"

              It broke out with a comment

              crs-2510 resource used in dependency 'hard' does not exist or is not registered

              so I gave the next command

              ./crsctl stat res ora.rac.db -p|grep DATA1

              HMMM...Here is the mistake

              The DATA1 group which I dropped is still registered

              now I have to give the next command

               

              crsctl modify resource ora.dbm.db -attr 

               

              I have to modify the start dependencies and the stop dependencies

              which I will do when I reach home

              • 4. Re: crsctl does not show correct info
                r_g_financials_dba

                Here is what I did to fix the problem

                 

                 

                ./crsctl stat res ora.rac.db -p|grep DEPEND

                START_DEPENDENCIES=hard(ora.DATA.dg,ora.DATA1.dg) weak(type:ora.listener.type,global:type:ora.scan_listener.type,uniform:ora.ons,uniform:ora.eons)

                pullup(ora.DATA.dg)

                STOP_DEPENDENCIES=hard(intermediate:ora.asm,shutdown:ora.DATA.dg,shutdown:ora.DATA1.dg)

                 

                 

                 

                 

                The above were incorrect because the DATA1 disk group was dropped however the crsctl registry was not updated.

                 

                 

                I tried the command below however it did not work

                 

                 

                ./crsctl modify res ora.rac.db -attr "START_DEPENDENCIES='hard(ora.DATA.dg)

                weak(type:ora.listener.type,global:type:ora.scan_listener.type,uniform:ora.ons,uniform:ora.eons)

                pullup(ora.DATA.dg)'"

                 

                 

                so I tried the above command with the -f flag and it worked

                 

                 

                Now I gave the next command

                ./crsctl modify res ora.rac.db -attr "STOP_DEPENDENCIES='hard(intermediate:ora.asm,shutdown:ora.DATA.dg)'" -f

                 

                 

                next I stopped the cluster and rebooted the machine

                but the database did not come up...

                so I researched a bit and gave the next command

                 

                 

                ./crsctl modify resource ora.rac.db -attr AUTO_START=always

                 

                 

                Next...stop cluster and reboot

                 

                 

                BinGO...the issue is now resolved