1 Reply Latest reply: Mar 20, 2014 2:23 PM by L-MachineGun RSS

    DBCA silent mode ignoring SCAN IPs

    Guess2

      Grid Install: 11.2.0.4

      Oracle Homes: 11.2.0.2 and 11.2.0.4 (both homes same servers and use the 11.2.0.4 RAC Grid). So DBCA is needed for either home.

       

      Having issues with my SCAN IPs. SAs are looking into it. I still need to create dbs with the DBCA. So I need to get the DBCA to ignore the remote_listener parameter. I can set it later. I tried passing the remote_listener parameter with a blank and it didn't work. I error out on the remote_listener because oracle can't get it to work. I tried putting the parameter with a blank space into the template.

       

      I am able to do an rman restore with out a remote listener by just removing the parameter from the init.ora. How do I get oracle to ignore the SCAN IP during DB creation? I shouldn't need one to just create a RAC db, since you can change it or get rid of the SCAN IP any time. Not sure what to pass to the parameter.

       

      Note: DB Names, server names, passwords are just made up for the post.

       

      -initParams "remote_listener=''

       

      $ORACLE_HOME/bin/dbca -silent -createDatabase -templateName /data01/mytemplatedir/General_Purpose.dbc -initParams "remote_listener=''" -gdbName MYRACDB -sid MYRACDB1 -sysPassword Larry1 -systemPassword Larry1 -sysmanPassword Larry1 -dbsnmpPassword Larry1 -emConfiguration NONE -storageType ASM -diskGroupName DATA01 -datafileJarLocation $ORACLE_HOME/assistants/dbca/templates -nodeinfo "MYSERVER01","MYSERVER02" -characterset WE8ISO8859P15 -obfuscatedPasswords false -sampleSchema false -asmSysPassword Larry1