2 Replies Latest reply on Mar 23, 2014 10:29 PM by tcharles

    Trouble Deploying Apex (Ords) with Tomcat6 using Linux.

    tcharles

      Hi,

       

      I am having trouble serving apex_4.2.3 using apex_listener ords_2.0.6 under tomcat6.  My operating system is Linux with the Oracle_Linux_Server_6.4 distro,  which is similar to RHEL_6.4. The database I am using is XE_11.2g.

       

      I believe I am following instructions in the ords installation manual (E25066-10). I am able to run successfully using ords in standalone mode, but I can't get it to work with tomcat6.  After copying ords.war and the apex images directory into tomcat's webapps directory, I get errors when I try to start ords under tomcat.  Ords is listed as an application using tomcat's manager/html but the "Running" column marks ords as false, and tomcat will not "start" it.

       


      An abbreviated version of what I find post mortem in the /var/log/tomcat6/catalina.out file follows:

       

      ------
         SEVERE: Error occurred while injecting:
                 private oracle.dbtools.rt.oauth.bdb.Approvals oracle.dbtools.rt.oauth.builtin.BuiltIns.approvals
         ...
         oracle.dbtools.common.service.ServiceLocatorException:
         Error occurred while injecting:
         private oracle.dbtools.rt.oauth.bdb.Approvals oracle.dbtools.rt.oauth.builtin.BuiltIns.approvals
         ...
         Caused by: oracle.dbtools.common.service.ServiceLocatorException:
         Error occurred while injecting:
         protected oracle.dbtools.rt.home.DataStore oracle.dbtools.rt.home.tenants.TenantEntityStorageProviderBase.store
         ...
         Caused by: oracle.dbtools.common.service.ServiceLocatorException:
         Exception occurred in activate() method
         ...
         Caused by: java.lang.IllegalArgumentException:
         Environment home
         /u01/app/oracle/product/ords.2.0.6/wfk_config_storage/ords/bdb/ael-qRGtpktqSSPzcIJ7PofYqQ
         doesn't exist
         ...
         SEVERE: Error listenerStart  
      ------

       

      The error message is correct in that I DO NOT have a file named:

       

         /u01/app/oracle/product/ords.2.0.6/wfk_config_storage/ords/bdb/ael-qRGtpktqSSPzcIJ7PofYqQ

       

      I DO have a file named:

       

         /u01/app/oracle/product/ords.2.0.6/wfk_config_storage/ords/bdb/ael-Ac3xda2cHprITOaBN0BV6w

       

      Can anyone tell what I am doing wrong or suggest something else for me to try?

       

      Thanks very much.