1 Reply Latest reply: Apr 22, 2014 2:17 AM by Davin Fifield RSS

    OPA 10.4.4 on Windows 8 / Office 2013

    c019aac9-7c81-4417-ae11-c044dba046ed

      A small number of customers has reported problems running OPM 10.4.4 with Windows 8 and / or Office 2013.

       

      Examples of problems reported include problems creating new rule documents in Word and Excel, and problems with the OPM and BI Publisher Toolbars in Word.

       

      At the present time we are unable to reproduce these problems in our test environment.

       

      In order to help us to help you, if you are experiencing a problems running OPM 10.4.4 with Windows 8 and / or Office 2013, we want to hear from you. If you are an existing customer, please lodge a formal Service Request.

       

      In your Service Request (or other communication about the issue) please try to provide us with as much information as possible about your machine and your environment. Examples of the kinds of things we need to know are:

      • Your operating system (e.g. Windows 7, Windows 8)
      • 32 bit or 64 bit ?
      • What precise version of Word are you using?
      • What precise version of Office are you using ?
      • Have you installed any other Office products with a later version on your machine ?
      • Are you experiencing the same issue with other file types? e.g. Excel, screens file, properties file, etc.
      • Are you getting any errors appearing inside OPM when you open the document? If so what precise error messages are you getting ?
      • Are you getting any errors outside OPM (for example, an Excel error like "SystemInvalidCastException: unable to cast COM object of type") ?
      • (if your problem is with Microsoft Word / Excel 2013), from which version of Word/Excel did you upgrade to Word / Excel 2013?
        ------------------
        Once we have enough information available to reproduce the problem, we will have a better chance of fixing it.

       

      In the meantime, below we have provided some things to try if you are experiencing problems. Please let us know if you have tried any or all of these and what the results were.

       

      As a first step, you can try reinstalling Office 2013 followed by OPA 10.4.4. If problems persist, read on.
      ---------------------

      Problem A: Cannot create new MS Word or Excel rule document:


      Workaround A1: Create new Word or Excel document outside OPM, then add to project

      1. Create a new word document in Word or Windows explorer.
      2. Open the document, click 'Save As' and then select 'Word 97-2003 Document' to convert your new file from the '.docx' to the '.doc' format .
      3. Open OPM
      4. Add your new word document to the project by following the steps under 'Add existing files to a project' in the following OPM user Guide Topic: http://docs.oracle.com/html/E48373_01/toc.htm#Projects%20and%20files/Create_modify_or_delete_a_project.htm#Add3
      5. Open the new file in OPM. The OPM toolbar should automatically be attached.


      Workaround A2: Run OPM as Administrator

      1. Close OPM and any Microsoft applications
        2. Find OPM in the Start menu, RIGHT-click and select 'Run as Administrator'
        3. Open OPM and attempt to create a new rule document.


      Workaround A3: create new rules in one of your existing rule documents

      --------------------------------------------

      Problem B: OPM Toolbar and / or BI Publisher toolbar in MS word will not stay put


      Check B1: OPM is open at the relevant project when your rule document is open

      First check that OPM has the corresponding project active when your rule document is opened. (The OPM toolbar will not appear unless this document is part of the project currently open in OPM - otherwise it is not possible to compile the document). If you are opening the document independently of running OPM (for example, via Windows Explorer), then the OPM toolbar is disabled and that document is treated as a plain Word 2013 document.


      Check B2: Ensure you have 'Updated Templates' in OPM to ensure the correct template is attached

      (See OPM 10.4.4 User Guide article Update Oracle Policy Modeling Templates: http://docs.oracle.com/html/E48373_01/toc.htm#Projects%20and%20files/Update_OPM_templates.htm)

      1. Open the project in OPM, but leave all the rule documents closed.
        2. From within OPM 10.4.4, go to Tools > Update Oracle Policy Modeling Templates.
        3. The field "Folder containing documents to update" will usually already display the folder path for the Development folder of the project. If it doesn't, browse to it. If your OPA project is in the regular default location, it will be something like this: C:\projects\<your project name>\Development. If you have saved your OPA project in a different location on your machine, then browse to the Development folder in that location.
        4. Leave 'Include sub-folders' and 'Update document styles from template' checked.
        5. Click Next, Next, etc. until it's done, then 'Finish'.


      Check B3: Use the MS Word Add-ins option to add in the template

      1. Open Microsoft Word
        2. On the Office Menu, select Word options, then 'Add-Ins'
        <for BI Publisher>
        3. In the 'manage' drop-down list, select 'COM Add-ins'.
        4. If the BI Publisher template Builder for Word is not in the Active Application Add-ins list, select it from the Inactive Application Add-ins list.

      <for OPM toolbar>
      3. In the 'manage' drop-down list, select 'Word Add-ins'.
      4. On the Templates tab, select the Policy Modeling template and click 'Add'

      --------------------------

      Problem C: Word rule documents will open from within OPM but they contain no text.

      Conduct checks as for Problem B and report results to Oracle.

      ---------------------------------------------------------------------

      We hope this post has been of some assistance. Again, the best path to a solution that works for you in your environment is to lodge a formal service request, and we encourage you to do so if the problem persists.

      regards

      the OPA Team

        • 1. Re: OPA 10.4.4 on Windows 8 / Office 2013
          Davin Fifield

          A brief note with two other things to try that have worked for some other users experiencing problems.

          IMPORTANT: Make sure you have saved all your work in all open applications before trying these options! (Particularly the one where you terminate the winword.exe process)

           

          Problem: Oracle Policy Modeling shows this error: "Oracle Policy Modeling was unable to check the version of the template attached to this document. To ensure the template is updated, close any Word dialog boxes that may be open, and try again."

           

          Solution 1: Make sure you are running Microsoft Word as administrator (see below), then disable the Send to Bluetooth Add-in (see, for example Living and breathing the world of Microsoft: Send to Bluetooth Add-In causes Office 2010 Apps to crash)

           

          Solution 2: Open the task manager, and find and terminate the Winword process that was launched with the command line "....\winword.exe /automation -embedding". Only do this if the problem persists after trying the first suggested solution, or that solution is not applicable to your machine.

           

          If you are unable to disable the Send to Bluetooth Add-in, you may need to 'Run as administrator' for Microsoft Word. To do this, you need to navigate to your Program Files folder (e.g. C:\Program Files (x86)\Microsoft Office\Office12\ and right-click directly on WINWORD.EXE), and choose Run As administrator.