1 Reply Latest reply on Apr 7, 2014 8:11 AM by 1025398

    P6 professional cannot connect to EPPM database

    f3f35932-1cd3-43fe-88e5-ce2d61fe41bd

      I have installed on Windows7 64 bit:

      +Oracle Database 11g Release 2 Client (11.2.0.1.0) for Microsoft Windows x64 (64-bit)

      +Oracle JRockit JDK R28.2.5 for Java SE 6 for Microsoft Windows x64 (64-bit)

      +Oracle WebLogic Server 11gR1 (10.3.6) Generic and Coherence

      +Primavera P6 Enterprise Project Portfolio Management R8.3 for Microsoft Windows

      +Oracle Database 11g Release 2 (11.2.0.1.0) for Microsoft Windows x64 (64-bit)

      +Primavera P6 Professional for EPPM R8.3

      (P6 eppm, P6 professiona and weblogic have been downloaded from windows 7 x64 media pack on edelivery)

      along with other things setups install by themselves (.net etc...)

       

      For now, it needs to work just on one pc.

      but when i run p6 professional's database configuration it always ends to

       

      Bad public user name or password. Cannot load OCI DLL: oci.dll;

       

      for user: i used system or admuser with their password.

      The two do connect from browser and from sqlplus

       

      For the conncetion string i tried various option:

      //hostname:port/sid.hostname

      sid.hostname

      sid

       

      Anybody knows why it does not connect?

        • 1. Re: P6 professional cannot connect to EPPM database
          1025398

          SYMPTOMS


          Oracle Error: "Bad public user name or password.  Unable to Load OCI.DLL;"


          CAUSE


          Oracle 64 bit Client is installed.  The OCI.dll file is required to communicate with the Oracle server and resolve the database connection.




          SOLUTION


          Uninstall the Oracle 64 bit client and install the 32 bit Oracle Client.


          The Oracle 64-bit client is not supported.


          1. Check if the Oracle Client is installed on the machine.
          2. A.) If Oracle Client is NOT installed yet, please ask the administrator to do so.

            B.) If Oracle Client is installed, please check the System Environment Variables to verify the path contains an entry for the Oracle 'bin' folder.
          3. Try the database validation again, which formerly resulted in the error above.