1 Reply Latest reply: Apr 7, 2014 2:36 PM by Puneeth-Oracle RSS

    apache weblogic WLIOTimeoutSecs configuration working intermittently

    user10977370

      Hi have a weblogic apache configuration like this.

      apachetest/home.jsp is configured to respond after a delay of 310 seconds

       

      <IfModule mod_weblogic.c>

          Debug               OFF

          WLLogFile           /ry/apache/https-esb-liveA/logs/global_proxy.log

          ConnectTimeoutSecs 4

          ConnectRetrySecs 1

          WLIOTimeoutSecs 90

          Idempotent OFF

          FileCaching ON

          DynamicServerList OFF

          WLLocalIP 191.112.233.24

          MatchExpression /apachetest WebLogicCluster=c10.sct.com:7001,c20.sct.com:7001,c30.sct.com:7001|WLIOTimeoutSecs=330

          MatchExpression /* WebLogicCluster=c10.sct.com:7001,c20.sct.com:7001,c30.sct.com:7001

      </IfModule>

       

      I have overriden WLIOTimeoutSecs=330 for all request "/apachetest". This configuration works intermittently.

      Below is the debug logs..

      ================New Request: [GET /apachetest/home.jsp HTTP/1.0] =================

      Mon Apr  7 11:33:32 2014 <3012413968668123530> Using Uri /apachetest/home.jsp

      Mon Apr  7 11:33:32 2014 <3012413968668123530> After trimming path: '/apachetest/home.jsp'

      Mon Apr  7 11:33:32 2014 <3012413968668123530> The final request string is '/apachetest/home.jsp'

      Mon Apr  7 11:33:32 2014 <3012413968668123530> got a pooled connection to server '112.233.124.29/7001/7001' from general list for '/apachetest/home.jsp', Local port:59619

      ================New Request: [GET /apachetest/home.jsp HTTP/1.0] =================

      Mon Apr  7 11:33:33 2014 <3015713968668133538> Using Uri /apachetest/home.jsp

      Mon Apr  7 11:33:33 2014 <3015713968668133538> After trimming path: '/apachetest/home.jsp'

      Mon Apr  7 11:33:33 2014 <3015713968668133538> The final request string is '/apachetest/home.jsp'

      Mon Apr  7 11:33:33 2014 <3015713968668133538> got a pooled connection to server '112.233.124.29/7001/7001' from general list for '/apachetest/home.jsp', Local port:42292

      ================New Request: [GET /apachetest/home.jsp HTTP/1.0] =================

      Mon Apr  7 11:33:33 2014 <3015713968668133541> Using Uri /apachetest/home.jsp

      Mon Apr  7 11:33:33 2014 <3015713968668133541> After trimming path: '/apachetest/home.jsp'

      Mon Apr  7 11:33:33 2014 <3015713968668133541> The final request string is '/apachetest/home.jsp'

      Mon Apr  7 11:33:33 2014 <3015713968668133541> general list: trying connect to '112.233.24.29'/7001/7001 at line 2658 for '/apachetest/home.jsp'

      Mon Apr  7 11:33:33 2014 <3015713968668133541> general list: created a new connection to '161.12.133.29'/7001 for '/apachetest/home.jsp', Local port:31684

      ================New Request: [GET /apachetest/home.jsp HTTP/1.0] =================

      Mon Apr  7 11:33:33 2014 <3012413968668133538> Using Uri /apachetest/home.jsp

      Mon Apr  7 11:33:33 2014 <3012413968668133538> After trimming path: '/apachetest/home.jsp'

      Mon Apr  7 11:33:33 2014 <3012413968668133538> The final request string is '/apachetest/home.jsp'

      Mon Apr  7 11:33:33 2014 <3012413968668133538> got a pooled connection to server '112.233.24.137/7001/7001' from general list for '/apachetest/home.jsp', Local port:31488

       

      if you notice logs for the same request http://www.dddd.com/apachetest/home.jsp

      1 got a pooled connection to server

      It returns 200 OK after waiting for 310 seconds which is correct.

      2 general list: trying connect to

      This returns 503 after 90 seconds itself. So this means WLIOTimeoutSecs=330 is not overwriting default 90 seconds.

      Is this a bug or there is a workaround by configuring the plug in correctly.