8 Replies Latest reply: Apr 8, 2014 8:28 PM by user12199372 RSS

    CVS extension not working in SQL Developer 64-bit




      I am trying to add the CVS extension for  SQL Developer.  I used the update function to get the files, and can see that the files downloaded from Oracle.  I can see the extension files loaded in the proper directory.  I have also restarted SQL Developer.  I check the loaded extensions after restarting, and the CVS extension is now loading.  Needless to say, it doesn't show up in the Versions window.


      Is there a further step to get this installed/configured? 


      I am using SQL Developer 64-bit, Build MAIN-14.48, Java 1.7.0_51.




        • 1. Re: CVS extension not working in SQL Developer 64-bit
          Gary Graham-Oracle

          Hi Brent,


          Looking in Help > About > Extensions tab, if you put vcs in the search widget, does it list

          Versioning Support  |  oracle.ide.vcscore     |  |  Fully Loaded  | etc...

          Versioning Support  |  oracle.jdeveloper.vcs  |  |  Fully Loaded  |  etc...

          and if you put cvs in the search widget, does it list

          Versioning Support for CVS  |  oracle.jdeveloper.cvs  |  |  Fully Loaded

          Oracle CVS Client               |  oracle.ojcvs               |  |  Fully Loaded

          If those are not showing up correctly, look in Tools > Features... > Features tab and make sure Version Control > CVS is enabled.

          Also look in Tools > Features... > Installed Updates tab Other node to verify CVS support and pre-requisites are listed.  In the directory


          it should have the cvs jar files plus two sub-directories, one with jsch.jar and the other with jsch-LICENSE.txt.  If all these are in place, then you should see a CVS menu item on the Team menu under the Versions item.



          SQL Developer Team

          • 2. Re: CVS extension not working in SQL Developer 64-bit

            Thank you very much for the quick reply Gary.  I found some new information in your reply.  Unfortunately, I still can't see the CVS extension under the menus.


            I will take the items one at a time:

            • The VCS items are present, loaded, and the same version that you list.
            • The CVS items are not listed under in the search under the Help > About > Extensions tab.
            • Under Tools > Features... > Features tab, I expanded the Version Control item.  It lists Git and Subversion, but CVS does not show up in the list at all.
            • Under Tools > Features... > Installed Updates tab, nothing is listed.
            • The files you list are present in the directories that you mentioned.


            When I install the extension from the Check for Updates dialog, I can see it download the files, they go into the directory, then it forces SQL Developer to restart, as I expect.  But after the restart, the extension isn't loaded for some reason.




            • 3. Re: CVS extension not working in SQL Developer 64-bit
              Gary Graham-Oracle


              Possibly you may find some files with an extension of installinfo in directory


              as in



              These, if they exist, may contain some indication of why the install did not complete successfully.  As an additional reference, here are the sizes of the installed cvs jars in my extensions directory...

              oracle.jdeveloper.cvs.jar  1,576,803 bytes

              oracle.ojcvs.jar                149,869 bytes

              If your jar file sizes match these and the installinfo files are missing or contain nothing useful, then perhaps retrying with a clean SQL Developer install, or download + install, would be worth doing.


              Hope this helps,


              • 4. Re: CVS extension not working in SQL Developer 64-bit



                I checked the files, and they are the sizes that you list in your response.


                The installinfo files are present.  I don't see anything startling in them.  Here are the contents, in case that helps.
















                Everything in this looks correct to me.  I can remove and re-install if you think that will help.  As this is the 64-bit version, last time I just downloaded the latest version, placed it in a directory, and ran it.  Best install experience ever (no sarcasm intended, it is wonderful to install that simply.)




                • 5. Re: CVS extension not working in SQL Developer 64-bit
                  Gary Graham-Oracle


                  As you say, everything looks absolutely correct, and if E: is a local drive and you use Windows 7, then our x 64 environments are quite similar.


                  Before doing a remove and re-install, I would recommend just installing into an alternate directory (say E:\AltApps) in conjunction with adding the following line to...\sqldeveloper\sqldeveloper\bin\sqldeveloper.conf:

                  AddVMOption -Dide.user.dir=E:/AltApps/.sqldeveloper

                  This overrides the default location for the user settings and results in a clean install without having to delete or rename the old settings under

                  Windows XP:     C:\Documents and Settings\<user-name>\Application Data\SQL Developer\system4.

                  Windows 7:       C:\Users\<user-name>\AppData\Roaming\SQL Developer\system4.

                  or possibly some other location the sys admins may be forcing.

                  You will not have any old settings to migrate when you start up the product, so just go immediately to Help > Check for Updates and see if the CVS pre-req and support extensions work this time.



                  • 6. Re: CVS extension not working in SQL Developer 64-bit

                    Thanks Gary:


                    Copying the installation to a different directly and adding the entry to the config file seems to have worked.  The copy shows CVS now under the Team menu.  I am guessing that this means that something in my config is causing the problem which doesn't allow the CVS extension to load.  This is strange, but understandable.


                    I will work to get my configuration fixed.  Thanks, this was a big help.




                    • 7. Re: CVS extension not working in SQL Developer 64-bit
                      Gary Graham-Oracle


                      One more thing...   I do not know what possessed me, but I was able to replicate your issue by...

                      1. Using the sqldeveloper- rather my usual sqldeveloper-

                      2. Following the ide.user.dir method noted in my earlier post

                      3. And making sure sqldeveloper\\product.conf under my C: drive user settings reference no other installed JDK

                      In this way, the CVS is actually installed but gets hidden due to the presence of these two extra files ...



                      in directory ...\.sqldeveloper\system4.\system_cache\config\Modules.  Just delete them and restart SQL Developer and all seems well.



                      • 8. Re: CVS extension not working in SQL Developer 64-bit

                        Hi Gary:


                        Wow!  That was a great catch.  I don't see how you noticed that one.  That is definitely the best solution.  Strange that it setup to hide the CVS function in the profile; I didn't do that, so it must have been some default setting.  Great easy and quick fix.