1 Reply Latest reply: Apr 19, 2014 7:32 PM by Vuvarov-Oracle RSS

    SQL Developer 4.0.0.13 and Oracle Cloud DB. Cart Access Issue (Unable to deploy in cloud).

    gustavo-parada

      Hello,

       

      I asked for a trial account on 04/02 (this year) of the Oracle Cloud. I've been able to create a Cloud Connection in SQL Developer (I'm able to login with my oracle email with the "Service Instance URL"). I am able to see the 11 example tables (DEPT, EMP, and 9 DEMO_X tables).

       

      My data:

      SQL Developer 4.0.0.13

      DataCenter: US Commercial 2 (US Commercial - Chicago). I'm settled in México, at this moment I don't remember to have selected some DataCenter, but I got that one.

      Domain SFTP Host & Port: sftp.us2.cloud.oracle.com:22

      Domain SFTP User Name: USdddddd (changed here for example reasons)

      Service SFTP Host & Port: sftp.us2.cloud.oracle.com:22

      Service SFTP User Name: USssssss (changed here for example reasons)

       

      My problem. I cannot deploy on the cloud (via the Cart tool on SQL Developer).

       

      In chat support, I was told to check this site (1) Data Loading and the Oracle Database Cloud Service. It seems the steps are the same of this site (2) that I was following before Creating and Deploying JSF/JPA Applications to Oracle Cloud.

       

      My scenario is not according the tutorial. According to (1), the tutorial highlights the use of the user detailed as "Service SFTP User Name" (USssssss). The site says that if I click on that user, I should be able to reset its password on SFTP users. BUT, this user (USssssss, Service SFTP User Name) is NOT shown as it is explained, the user that is shown there is the one under "Domain SFTP information" (USdddddd, that is, the user that I should NOT use, according to that webpage).

       

      My user Service SFTP User is not shown in Security-SFTP Users. When I click the user name (USssssss), the site takes you to the Security tab, and SFTP Users sub tab. I notice that my Service SFTP User Name (USssssss) appears in Security tab, but it appears under "Users" sub tab, NOT on "SFTP Users" sub tab. Also, if I try to reset the Service SFTP User password (in Users sub tab), the site says "Oracle Cloud will send an email with a temporary password to USssssss USssssss." It does not ask me to write the new password (SFTP Users sub tab works fine, asking me a password for USdddddd).

       

      Anyway, in SQL Developer, I made several tests in the Cart, testing either the Service and also the Domain users, port 22 and 2222. None of them worked. The message I get is:

      Unable to connect to sftp server with provided details.

       

      I've also tried to access the sftp url with Putty, PSFTP, and Filezilla. From those three apps, the sftp url gives me timeout (either on port 22, or 2222). But if ping that url, I got a response back.

      So I'm not sure where is the problem. Is it the url? Is it the port? Is it the Service SFTP User? All of them?

       

      Any comment, is very welcome.

       

      P.S. It will be nice to have a "posted date" for each tutorial and perhaps identify the Cloud version that is being explained (the Oracle cloud is growing fast, perhaps the tutorials will be deprecated soon).