14 Replies Latest reply: May 14, 2014 4:01 AM by 2651728 RSS

    JSP Ref Error after successfull baseline

    2651728

      After the successfull installation and deployment . I get the below error.

       

      com.endeca.navigation.ENEException:
      Navigation Engine not able to process request
      'http://localhost:15000/graph?node=0&offset=0&nbins=10&irversion=620'

       

      Even I copied jar files from   "C:\endeca\ToolsAndFrameworks\3.1.2\reference\endeca_jspref\WEB-INF\lib"    to "C:\endeca\PlatformServices\6.1.4\lib\java"  still I get the same error. Please help me on this.

      Thanks in Advance.

       

      Shreyas

        • 1. Re: JSP Ref Error after successfull baseline
          TimK

          Couple of things -

          You can run that URL directly,  http://localhost:15000/graph?node=0&offset=0&nbins=10&format=xml where localhost is the hostname of your dgraph server.

          Second, you don't want to overwrite the PlatformServices jars with the endeca_jspref jars.  That may cause PS to stop working.

          The jars in the jspref lib directory need to match your MDEX engine.  The 620 indicates that you are running a Navigation API of 6.2.x.  If your MDEX is something else then you need to do one of two things:

          add the back_compat flag to your app config so that it will recognize older APIs

          update your jars in your jspref lib directory to match your mdex.

          • 2. Re: JSP Ref Error after successfull baseline
            2651728

            Hey thanks for the reply.... how do you add back_compat flag?? i tried the below way but its giving exceptiong when i run load_baseline-test_data.

            "

            <args>

            ......

            < arg>--back_compat</arg>

            < arg>614</arg>

            < /args>

            "... If i have to update jspref jars from where should i copy jars to which folder. Sorryit might seem a stupid question but this is the first time im installing endeca on my machine.

            • 3. Re: JSP Ref Error after successfull baseline
              TimK

              For the jars, get them from Oracle Edelivery - they are in the zip file that contains the Oracle Endeca MDEX Engine that you downloaded.  It should contain two files - the PresAPI and the MDEX engine installer.

               

              Can't tell if you have spaces in your arg tags above in this forum because of formatting or they are a mistake.

               

              Anyway, you should have something like the following - which is an example, don't take this as what you should implement but just a guide:

               

                <dgraph-defaults>

                  <properties>

                    <property name="srcIndexDir" value="./data/dgidx_output" />

                    <property name="srcIndexHostId" value="ITLHost" />

                    <property name="srcPartialsDir" value="./data/partials/forge_output" />

                    <property name="srcPartialsHostId" value="ITLHost" />

                    <property name="srcCumulativePartialsDir" value="./data/partials/cumulative_partials" />

                    <property name="srcCumulativePartialsHostId" value="ITLHost" />

                    <property name="srcDgraphConfigDir" value="./data/workbench/dgraph_config" />

                    <property name="srcDgraphConfigHostId" value="ITLHost" />

                    <property name="numLogBackups" value="${endeca.dgraph.logbkcount}" />

                    <property name="shutdownTimeout" value="30" />

                    <property name="numIdleSecondsAfterStop" value="0" />

                  </properties>

                  <directories>

                    <directory name="localIndexDir">./data/dgraphs/local_dgraph_input</directory>

                    <directory name="localCumulativePartialsDir">./data/dgraphs/local_cumulative_partials</directory>

                    <directory name="localDgraphConfigDir">./data/dgraphs/local_dgraph_config</directory>

                  </directories>

                  <args>

                    <arg>--back_compat</arg>

                    <arg>614</arg>

                    <arg>--back_compat</arg>

                    <arg>620</arg>

                    <arg>--threads</arg>

                    <arg>4</arg>

                    <arg>--spl</arg>

                    <arg>--dym</arg>

              ...

                  </args>

                  <startup-timeout>120</startup-timeout>

                </dgraph-defaults>

              • 4. Re: JSP Ref Error after successfull baseline
                2651728

                Thanks a lot TimK..... Appreciate your help. It worked.

                 

                Just one more thing.... not with same topic can you guide me abt any available docs to refer to write baseline update and scripts related to endeca... would be veryhelpfull...

                 

                Thanks again

                • 5. Re: JSP Ref Error after successfull baseline
                  TimK

                  Oh sure, it's all documented in the Deployment Template guide. Here's the 3.2.2 link, or go to the oracle documentation area to find the version that matches your installed versions (although these haven't changed much over the past few years)

                  http://docs.oracle.com/cd/E29586_01/DeploymentTemplateUsageGuide.pdf

                   

                  Since this is all wrapped in BeanShell, knowing BeanShell is helpful.

                  BeanShell - Lightweight Scripting for Java

                  • 6. Re: JSP Ref Error after successfull baseline
                    2651728

                    Thanks a lot TimK . It was helpful. 

                     

                    One last thing....

                    Can I connect to two database from single endeca app, if so how? and also how we caonfigure DB on endeca.

                     

                     

                    Thanks in advance.

                    • 7. Re: JSP Ref Error after successfull baseline
                      TimK

                      I am assuming you mean connecting to two different databases to build the index during baseline update?

                       

                      Sure, that's just a matter of setting up multiple input adapters in your pipeline editor in Dev Studio.

                      http://docs.oracle.com/cd/E51276_01/DeveloperStudio.11/pdf/DevStudioHelp.pdf

                      Page 43 has a sample on how to setup an input adapter to connect to a sql database.

                       

                      You may need to add client access jars to your application's config/lib/java directory (ie. oracle ojdbc6.jar, sql server sqljdbc.jar - where these jars match the database you are accessing)

                       

                      You may also need to amend the classpath - the most expedient is to add it to the input adapter itself.  Longer term it's easier to maintain if you append it in the app config environment.

                      • 8. Re: JSP Ref Error after successfull baseline
                        2651728

                        HI Timk thanks for your response.

                         

                        If you ever worked on  older version endeca tehn please do let me know how can we deploy new app.

                        The endeca componets version are as below.

                        MDEX  6.2.1

                        PlatformServices  6.1.1

                        Workbench  2.1.1

                         

                        In the existing versions we go bin folder in toolandframworks and do deploy but i dont see those folders in the above mentioned versions.

                         

                        Thanks in advance

                        • 9. Re: JSP Ref Error after successfull baseline
                          TimK

                          Yes, for the older versions you had to download and unzip the Deployment Template as a separate package.  You will need to get the Deployment Package 3.2 [edited] from EDelivery (actually, they probably don't have it anymore - might need to ask Support for it) if you don't have it.  You should check for it in a folder called endeca/solutions on your server (if someone else did all the installs) because that's where Endeca recommended that it be placed.  From there it should be very similar to the new ToolsAndFrameworks deploy.

                          • 10. Re: JSP Ref Error after successfull baseline
                            2651728

                            Does deployment package 3.2.2 works for the above mentioned versions?

                             

                            Thanks in advance,

                            Shreyas

                            • 12. Re: JSP Ref Error after successfull baseline
                              2651728

                              HI,

                              When i run load_baseline_test_data.sh on linux machine im getting the following exception.. platformservices and workbench both running.

                               

                              Caused by java.lang.reflect.InvocationTargetException

                              sun.reflect.NativeMethodAccessorImpl invoke0 - null

                              Caused by com.endeca.soleng.eac.toolkit.exception.EacCommunicationException

                              com.endeca.soleng.eac.toolkit.base.Synchronizable setFlag - Caught exception while attempting to set flag 'baseline_data_ready'.

                              Caused by com.endeca.eac.client.EACFault

                              sun.reflect.NativeConstructorAccessorImpl newInstance0 - null

                               

                              Thanks,

                              Shreyas

                              • 13. Re: JSP Ref Error after successfull baseline
                                TimK

                                To me this reads that your platform services controller is not running or available.  Did you resolve this yet?  You say it's running, can you validate that?

                                You can point your browser at it and should receive a blank page.  http://PSHost:8888

                                I assume you can successfully do an initialize services just before trying this load baseline test data and init works fine?

                                • 14. Re: JSP Ref Error after successfull baseline
                                  2651728

                                  thanks and its resolved.. there was a prob with platform services.

                                   

                                  And i have one out of topic question here....

                                  Assume you got a set of records in record adapter and basis on the one key i need to concat the fields into one single property and remove otehr records.. how do you do it?

                                   

                                  Ex

                                  sku|storeId

                                  1|10101

                                  2|10203

                                  1|10203

                                   

                                  finally i want records int he below way

                                  1|10101_10203

                                  2|10203

                                   

                                  any idea?? thanks in advance