1 Reply Latest reply: Apr 14, 2014 6:46 PM by Bob T. RSS

    Trying to upgrad to Apex 4.2. Having problems with listener as standalone or glassfish 4


      I have a windows server 2003 that I have updated the java ee to 1.8. Then I tried to install RDS


      My database is a linux server and I can connect fine to this server from the windows server I am having trouble with. I was able to sqlplus and tnsping the database server.


      I was trying to install into glassfish 4 and followed every step in the instructions and it didn't work. So I am trying to see if I can just get it to work in standalone.


      Here is the output when I type: java -jar ords.war


      E:\oracle\products\apex\ords.>java -jar ords.war
      Apr 11, 2014 10:55:13 AM oracle.dbtools.standalone.Standalone execute
      INFO: NOTE:

      Standalone mode is designed for use in development and test environments. It is

      not supported for use in production environments.


      Apr 11, 2014 10:55:13 AM oracle.dbtools.standalone.Standalone execute
      INFO: Starting standalone Web Container in: e:\oracle\products\apex\listener\ords
      Apr 11, 2014 10:55:13 AM oracle.dbtools.standalone.Deployer deploy
      INFO: Will deploy application path = e:\oracle\products\apex\listener\ords\ords\WEB-INF\web.xml
      Apr 11, 2014 10:55:14 AM oracle.dbtools.standalone.Deployer deploy
      INFO: Deployed application path = e:\oracle\products\apex\listener\ords\ords\WEB-INF\web.xml
      Apr 11, 2014 10:55:14 AM com.sun.grizzly.http.servlet.ServletContextImpl initListeners
      WARNING: GRIZZLY0052: Exception invoking contextInitialized() on ServletContextListener: oracle.dbtools.rt.web.SCListener.java.lang.NullPointerException
              at oracle.dbtools.common.config.GlobalConfiguration.conf(GlobalConfiguration.java:69)
              at oracle.dbtools.common.config.GlobalConfiguration.get(GlobalConfiguration.java:48)
              at oracle.dbtools.common.config.db.PerThreadConnectionCache.setup(PerThreadConnectionCache.java:70)
              at oracle.dbtools.rt.web.SCListener.contextInitialized(SCListener.java:75)
              at com.sun.grizzly.http.servlet.ServletContextImpl.initListeners(ServletContextImpl.java:173)
              at oracle.dbtools.standalone.MimeTypesServletContext.initListeners(MimeTypesServletContext.java:20)
              at com.sun.grizzly.http.servlet.ServletAdapter.configureServletEnv(ServletAdapter.java:527)
              at oracle.dbtools.standalone.SecureServletAdapter.configureServletEnv(SecureServletAdapter.java:160)
              at com.sun.grizzly.http.servlet.ServletAdapter.start(ServletAdapter.java:336)
              at com.sun.grizzly.tcp.http11.GrizzlyAdapterChain.start(GrizzlyAdapterChain.java:135)
              at com.sun.grizzly.http.SelectorThread.initEndpoint(SelectorThread.java:1175)
              at com.sun.grizzly.http.SelectorThread.listen(SelectorThread.java:1228)
              at com.sun.grizzly.http.embed.GrizzlyWebServer.start(GrizzlyWebServer.java:678)
              at oracle.dbtools.standalone.Deployer.start(Deployer.java:284)
              at oracle.dbtools.standalone.Standalone.execute(Standalone.java:131)
              at oracle.dbtools.common.cmds.DefaultCommand.execute(DefaultCommand.java:108)
              at oracle.dbtools.common.cmds.Commands.main(Commands.java:91)
              at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
              at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
              at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
              at java.lang.reflect.Method.invoke(Unknown Source)
              at oracle.dbtools.jarcl.Entrypoint.main(Entrypoint.java:58)


      Apr 11, 2014 10:55:14 AM com.sun.grizzly.Controller logVersion
      INFO: GRIZZLY0001: Starting Grizzly Framework 1.9.49 - 4/11/14 10:55 AM
      Apr 11, 2014 10:55:14 AM oracle.dbtools.standalone.Standalone execute
      INFO: http://localhost:8001/ords/ started.


      As you can see there are a lot of java errors.

      Any ideas on what have I done wrong?

        • 1. Re: Trying to upgrad to Apex 4.2. Having problems with listener as standalone or glassfish 4
          Bob T.



          Where to begin.......


          1.  Windows 2003 - change this out to at least 2008 R2

          2. Java 1.8 -- you seem to like the sharp cutting edge....back down to 7.51 JDK

          3.  You seem to have configuration in place for ords.war .  Start over with fresh war file.  Delete your configuration directory data.

          4.  Glassfish 4.1 -- again leading on the cutting edge.  Move to 3.2.7 or current version of Tomcat.  -- 3.2.7 is last commercial version of Glassfish......

          5.  Get latest version of apex and rest listener.....new version came out in the last few days.....


          Begin with mature tested configurations.....Pay attention to certified environments....