4 Replies Latest reply on Apr 28, 2014 10:30 AM by User10656774-Oracle

    Configure Apache server plugin for weblogic 10.3

    sandeepjn

      i have been trying to integrate apache server plugin with weblogic server 10.3.

      My weblogic server is running on windows 7 and apache server 2.4.9 is running on RHEL 6.5.

       

      I was following Installing and Configuring the Apache HTTP Server Plug-In document to configure.

      I couldnot find the mod_wl.so plugin for weblogic 10.3 as the link mentioned every where is invalid. so i used mod_wl_24.so, from weblogic 12c server plugin.

       

      i have configured apache for the proxy.

       

      when i try to access weblogicserver/console page using apache proxy as http://apacheserver:port/weblogc/console, it gives me,

      "Failure of Web Server bridge:

       


      No backend server available for connection: timed out after 10 seconds or idempotent set to OFF or method not idempotent."


      is there any thing which i am missing in the configuration, i need to do the proxy for https also.


      i have enable WebLogic Plug-In Enabled

      Domain structure - > environments -> servers -> admin server -. general tab - >advanced-> WebLogic Plug-In Enabled

       

      following error is shown in apache server log:

      [Sat Apr 12 12:35:24.145341 2014] [weblogic:error] [pid 18112:tid 140206378313472] [client <weblogic server ip>:51431] Trying GET /weblogic/console at backend host '<weblogic server ip>/7001; got exception 'NO_RESOURCES: [os error=115,  line 1682 of URL.cpp]: apr_socket_connect call failed with error=70007, host=1<weblogic server ip>, port=7001 '

      [Sat Apr 12 12:35:26.145485 2014] [weblogic:error] [pid 18112:tid 140206378313472] [client <weblogic server ip>:51431] request [/console] did NOT process successfully..................

        • 1. Re: Configure Apache server plugin for weblogic 10.3
          User10656774-Oracle

          Hello,

           

          are you the route is open between apache and WebLogic ?

          Can you post the plugin configuration from the httpd.conf file.

          Emmanuel

          • 2. Re: Configure Apache server plugin for weblogic 10.3
            sandeepjn

            httpd.conf file snippet ;

             

            <IfModule mod_weblogic.c>

               WebLogicHost myservrerurl

               WeblogicPort 80

               Debug                ON

               WLLogFile             /home/idcadmin/logs/mod_log.log

            #   WLTempDir             "c:/myTemp"

               DebugConfigInfo       On

               KeepAliveEnabled ON

            ConnectTimeoutSecs 300

               KeepAliveSecs  15

            </IfModule>

            <Location /web>

               SetHandler weblogic-handler

              WeblogicHost myservrerurl

              WeblogicPort 80

               PathTrim             /web

               Debug                OFF

               WLLogFile            /home/logs/web_log.log

            </Location>

            # <Location /foo>

            #   SetHandler weblogic-handler

            #   PathTrim            /foo

            #   Debug               ERR

            #   WLLogFile           /home/logs/foo_proxy.log

            # </Location>

             

            I have one more requirement, currently i am trying to get this done for http , but my main aim to enable this proxy for https.

             

            now both apache server and weblogic are running on same machine <myservrerurl>

             

            with this configuration i am getting

            "

            [Wed Apr 23 05:13:13.852667 2014] [weblogic:error] [pid 12356:tid 1121028416] [client <client-ip>:52433] *******Exception type [READ_TIMEOUT] (no read after 300 seconds) raised at line 275 of Reader.cpp

            [Wed Apr 23 05:13:13.853053 2014] [weblogic:error] [pid 12356:tid 1121028416] [client <client-ip>:52433] ap_proxy: trying GET /web/console/ at backend host 127.0.0.1/80; got exception 'Backend Server not responding'; state: reading status line or response headers from WLS (wrote? Y read? N); failing over

             

            "

             

            i have modified apache server to run on port 81 and weblogic to run on port 80.

             

            thanks,

            • 3. Re: Configure Apache server plugin for weblogic 10.3
              sandeepjn

              Currently i am able to access my weblogic server through apache server on http request, however when i make https request to weblogic server through apache server, i am getting following error in weblogic.

               

              <Apr 24, 2014 3:45:35 AM GMT+05:30> <Warning> <Security> <BEA-090475> <Plaintext data for protocol HTTP was received from peer <servername> - 127.0.0.1 instead of an SSL handshake.>

              <Apr 24, 2014 3:45:35 AM GMT+05:30> <Warning> <Security> <BEA-090475> <Plaintext data for protocol HTTP was received from peer <servername> - 127.0.0.1 instead of an SSL handshake.>

              <Apr 24, 2014 3:45:35 AM GMT+05:30> <Warning> <Security> <BEA-090475> <Plaintext data for protocol HTTP was received from peer <servername> - 127.0.0.1 instead of an SSL handshake.>

               

              in the httpd-ssl.conf i have added following entry:

               

              <Location /secureapp>

                Sethandler weblogic-handler

                WeblogicHost myservrerurl

                WeblogicPort 443

              WLSSLWallet /home/WLSPlugin12c-64bit-Apache2.2-Apache2.4-linux64-x86_64/bin/my-wallet/

                SecureProxy ON

                Debug ON

              </Location>

               

              Again, apache server is running on port 81 and 444 and weblogic server is running on 80 and 443.

               

              i have generate the my-wallet using following command as mentioned in README.txt for weblogic plugin:-

               

              Configuring SSL with WebLogic Server demo trust CA

              ===================================================

              NOTE that this is for demo purposes only. When used in production, ensure that

              trusted CAs are properly configured on the plug-in as well as on WebLogic

              Server side.

               

               

              The following steps will enable SSL between the plug-in and WLS:

               

               

              1. Create an Oracle Wallet with orapki utility:

                 (run this command on the system where the plug-in is being configured)

                 $ ${PLUGIN_HOME}/bin/orapki wallet create -wallet my-wallet -auto_login_only

               

               

              2. If the user who runs the Apache plug-in is not the same user who created the

                 wallet (or has ROOT account access), the wallet creator would needs to grant

                 access to the wallet by running the command chmod after creating the wallet.

               

               

                 For example:

               

               

                 $ chmod a+r <wallet_path>\cwallet.sso

               

               

              3. Import the CA into the Oracle Wallet:

                 Locate the Demo CA in WLS installation at ${WL_HOME}/sever/lib/CertGenCA.der

                 $ ${PLUGIN_HOME}/bin/orapki wallet add -wallet my-wallet -trusted_cert

                   -cert CertGenCA.der -auto_login_only

               

               

              4. Enable SSL on the plug-in:

                 Edit/Add the plug-in configuration in ${APACHE_HOME}/conf/httpd.conf as follows:

               

               

                 ...

                 WebLogicHost my-wls-ip

                 WebLogicPort secure-port

                 SecureProxy ON

                 WLSSLWallet /home/myhome/mywallet

                 ...

               

              When i try to access https://myserverlurl:444/secureapp/ from browser i get

              Failure of Web Server bridge:

               

               

              No backend server available for connection: timed out after 300 seconds or idempotent set to OFF or method not idempotent.

               

              but when i access the app directly using https://myserverurl:443/secureapp, i am able to access.

               

              Thanks,

              • 4. Re: Configure Apache server plugin for weblogic 10.3
                User10656774-Oracle

                Hi,

                 

                did you setup SSL on your weblogic server ? Your weblogic server is listening ssl requests on which port ?