6 Replies Latest reply: Apr 24, 2014 5:08 AM by Huron RSS

    Error Running Forms 11g (FRM-18127 Failed to Start One-Button-Run HTTP Server)

    Huron

      Hello.

       

      I have installed recently in my Pc (Windows Vista Home Premium 64 bits), this softare:

       

      - Weblogic 11g R1

      - Oracle Forms and Reports 11G

       

      I had folllowed this guide: (Oracle WebLogic & Forms 11g Release 2 Install Guide)

       

      My steps for try test my fisrt aplication:

       

      - Look like i start successfullly the server using WebLogic (if i am not wrong). I write the User and Password on the Cmd interface when i start etc.

      - I create my Canvas, my block and my Unit program etc, i compile without errors but when i try running it, i see this message (FRM-18127 Failed to Start One-Button-Run HTTP Server).

       

      I have saw in forums (about Forms 10G) that this error for CLASSPATH, or PATH problems and about a file that i dont find on my pc.. i dont know if this solutions works in 11G too.

       

      Must i configure something?.

       

      If helps:

       

      I have tested in my Laptop with Windows 7, using the same software and guide, and dont get the Error, however, when i try running my Module from Forms, i see the the page of Internet Explorar like loading all the time (and no results).

       

      If anyone could help me.

       

      Thanks.

        • 1. Re: Error Running Forms 11g (FRM-18127 Failed to Start One-Button-Run HTTP Server)
          Michael Ferrante-Oracle

          Just so you are aware, the use of any "Home" edition of the Windows OS is not supported for use with any Oracle Forms version and most other Oracle products.  If you are just trying to learn the product, you are probably fine using it.  However, if you are using this with a company, understand that you may not be entitled to support on this configuration.

          Regarding, the error you mentioned, this means exactly what it says.  You are trying to use the Builder's "Run form" button and the Builder is not getting a response from the listener configured in the Runtime Preferences (Application Server URL).  This means that either it truely is not running or the value you have set (or not set) in the Preferences is incorrect.

           

          Do the following:

           

          1.  Open the Forms Builder and from the menu, select Edit > Preferences > Runtime

          2.  Ensure that Application Server URL and Web Browser Location both have valid values.  If you make any changes, click on OK and retest.

           

          3.  If the above does not fix the problem, likely the Forms Servlet is not accessible (server not running).  If you installed using the "Development" installation type, then your port number will be 7001.  If you chose the "Deployment" installation type, your port number will be 9001

           

          If you chose the "Development" install type, the Forms Servlet is deployed into the WLS Admin Server.  So, in order to use Forms, you need to ensure that the WLS Admin Server is running.  The admin server listens on port 7001, so the URL to access it would look something like this:

           

          http://yourHost:7001/console

           

          To access Forms, the URL would look like this:

          http://youHost:7001/forms/frmservlet?form=C:\someDirectory\myForm.fmx

           

          If you used the "Deployment" installation type, the Forms Servlet is deployed into its own managed server named "WLS_FORMS".  This must be started either from the command line or from within the Admin Server.  So if you use the Admin Server, it must be started first.  Then from within the Admin Server you can choose to start WLS_FORMS.  The URL to run a form from WLS_FORMS would look like this:

           

          http://youHost:9001/forms/frmservlet?form=C:\someDirectory\myForm.fmx

           

           

          Also, regardless of which installation type you used, you will need a Java Plugin (JRE) installed on the machine where your browser will be running.  The latest supported version for use with Forms 11.1.2.2 is Java 7U55 and it can be downloaded from here:

           

          http://www.oracle.com/technetwork/java/javase/downloads/index-jsp-138363.html#JDK7

           

          .

          • 2. Re: Error Running Forms 11g (FRM-18127 Failed to Start One-Button-Run HTTP Server)
            Huron

            Hello, thanks for the help. I solved that error but i have now a new problem.

             

            When i run my forms, my FireFox is opened with the propertly port etc in the url, but laters i see a mesage that i need a pluggin for see that content, and i click in download, but when my webbrower try downloading it i see a new message saying my web dont find the necesary pluging and i see a list of plugins (and i dont know what to choose).

             

            I am not sure what pluging i need, i have download the last versions of JRE and  look like Weblogic  server is running propertly  (i choosed Development option when i installed it). i instaled the last versions of Java (if i am not wrong, i will check it again).

             

            I worked long time ago with Forms 10g , and i have installed in my home the version 11g, for refresh knowledge, i only have Windows Vista and Windows 7 64 bits in my Pc and laptop (home premium both).

             

             

             

            Any new help

            • 3. Re: Error Running Forms 11g (FRM-18127 Failed to Start One-Button-Run HTTP Server)
              Michael Ferrante-Oracle

              In formsweb.cfg set the jpi_mimetype as follows:

               

              jpi_mimetype=application/x-java-applet

              • 4. Re: Error Running Forms 11g (FRM-18127 Failed to Start One-Button-Run HTTP Server)
                Huron

                Hello again.

                 

                I think i am near of the final solution but i have problems yet.

                 

                I have got to run successfully my Url but using a diferent Web brower (Internet Explorer).

                 

                My url: http://myhost:7001/forms/frmservlet

                 

                Now i see a second window  saying  of install a Java Pluggin and when i choose, is see a message saying all is Ok (i could not with FireFox).

                 

                I have wrote in the Menu Option of my Forms; Edit - Preferences - my Url server aplication http://myhost:7001/forms/frmservlet

                trying the final url be:

                http://youHost:7001/forms/frmservlet?form=C:\someDirectory\myForm.fmx when i Run my Forms.

                 

                But when i run it, i see a message saying "ORA 12.154 TNS: Have not been posible to connect...(in bad traduction). then i see the same interface or window that you use to connect to Oracle Data Base from Forms Aplication (and i did prev to run my Form), i mean, my Forms 11 G was connected to Oracle.

                 

                Maybe i am doing bad one step or is other configuration error. I think i have ok: My Server of WebLogic  is Up, and now i get to run my servlet correctly.

                 

                But i am failing again when i try run my Form..

                 

                Thanks for the patience, my english is not very good.

                • 5. Re: Error Running Forms 11g (FRM-18127 Failed to Start One-Button-Run HTTP Server)
                  CraigB

                  Well, your Forms Runtime needs to know where your tnsnames.ora file.  The easiest way to do this is to update the default.env and set the TNS_ADMIN setting to the directory where your sqlnet.ora and tnsnames.ora files are located. The default value for the TNS_ADMIN setting is: \Oracle\Middleware\asinst_1\config so you could also put a copy of these files here, but then you have to maintain multiple copies of the files.  The smarter choice would be to have one copy of these files and point all of the software that connects to Oracle to this one copy.

                   

                  Craig..

                  • 6. Re: Error Running Forms 11g (FRM-18127 Failed to Start One-Button-Run HTTP Server)
                    Huron

                    Look like now work propertly.

                     

                    Thanks all.