6 Replies Latest reply: Jun 1, 2014 1:47 PM by vivekvm RSS

    Forms 11g installation opmnctl error

    vivekvm

      Hi All,

      Weblogic 32 bit

      Forms 11g 32 bit

      JRE vER 1.6 32 BIT

      Windows 2008 sp2

       

      while installing Forms after the sucessful installation of welogic shows error in configuration section in instllation as

      opmnctl startproc ias-component = rptsvr_<name> stopped working. along with a popup window says ' Orale report stopped working' with some app carsh message

      Firewall is disabled. and tried severl times.

       

      What are the possibilites and how to solve this.

       

      thanks in advance.

        • 1. Re: Forms 11g installation opmnctl error
          Michael Ferrante-Oracle

          Because you didn't tell us exactly which version you installed, I won't be able to offer too much details.

           

          If you installed 11.1.2.2 (requires WLS 10.3.6), most configuration failures are the result of not properly configuring the machine's networking before starting the installation.  On Windows, you must either have a static IP address with the hostname configured in the hosts file OR have the Windows Loopback Adapter installed and configured.  It will also be important to have at least 4gig of RAM on the machine.

           

          For versions earlier than 11.1.2.2 and even 11.1.1.x, there are a variety of installation issues that might occur.  For example, if your system PATH includes entries with (x86) or blank spaces.  If the hostname is too long or contains characters other than alpha-numerics.

           

          You mentioned Windows 2008-R2.  I am going to assume this is a 64bit OS.  If so, why are you installing 32bit Oracle software on it?

          • 2. Re: Forms 11g installation opmnctl error
            CraigB

            Did you run the WebLogic Server (WLS) configuration step at the end of the installation?  If yes, I recommend you uninstall WLS and reinstall but do not perform the configuration step at the end of the WLS installation.  Then, install Fusion Middleware (FMw) 11g and run the configuration step at the end of the FMw installation.  It will configure WLS and FMw.

             

            Also, I agree with Michael, we need to know the software versions as they are interdepent.


            Craig...

            • 3. Re: Forms 11g installation opmnctl error
              vivekvm

              Hi

              Installed versions are as follows Form 11g Version 11.1.2.2 ,  WLS 10.3.6 both are 32 bit. And JDK 32 Bit latest. Windows 2008 SP2 64 bit. All these working fine in Windows 2008 SP1 64 bit Machines.

              the only difference i found is its SP2. I tired the method suggested by Mr. Craig.

              bu still the problem persist it shows the the opmnctl startproc ias- component = Rpt_ and installation failed.


              Any help ???

               

              Thanks alot for the suggestions.

               

              • 4. Re: Forms 11g installation opmnctl error
                Michael Ferrante-Oracle

                Please go back and review my comments.  Generally, the inability to start the Reports server is the result of a network configuration issue.  Often because the machine does not have a static address.  It may be necessary to enable the Reports Naming Service to overcome this problem if you are using DHCP to obtain your IP address.  This can be done post installation and configuration.  During the config part of the install simply ignore the error and continue.  However, using a static address is preferred, especially if the server is actually going to be used as a "server" and accessed by remote clients.

                 

                http://docs.oracle.com/cd/E48391_01/doc.11120/e24479/pbr_conf008.htm#CHEHAECB

                • 5. Re: Forms 11g installation opmnctl error
                  vivekvm

                  Hi All,

                  thanks to all  your valuable suggestions.

                   

                  finally installation completed by following the below step

                  1. Server formatted and installed windows OS 2008 SP1 ( All my previous installed server was SP1)

                  2. Copied the msvcr71.dll into c:\windows\system and system32  folder

                  3. Disabled the windows firewall (May be optional)

                  then installation completed successfully.

                  During installation got some error adrci.exe stopped working , But ignored and continued the installation.

                   

                  Thanks

                  • 6. Re: Forms 11g installation opmnctl error
                    vivekvm

                    During the installation in Windows OS 2012 go the same error as above.

                    Copied msvcr71.dll in c:\windows\system and system32 folder and continued the installation.

                    Successfully completed the instllation after that.

                     

                    Note:

                    Initially got OS compatibility issues. But after setting compatibility for windows 7 proceed the installation