2 Replies Latest reply on Apr 23, 2014 1:14 PM by user8714121

    Cannot get bat file triggered from FDM (web or workbench)

    user8714121

      I have created a bat file that simply 7zip to unzip an HFM extended analytics extract which will be loaded to Hyperion Planning.  This bat file works perfectly when manually run while on the FDM server (same credentials used for FDM application logon).  The bat file contents are below and it is currently placed in the FDM inbox next to the file it is intended to unzip.

       

      ________________________BAT FILE CONTENTS_________________

      for /R "D:\Oracle\Middleware\EPMSystem11R1\products\FinancialDataQuality\fdmdata\FDMPRD\Inbox\EAEXTRACT" %%I in ("*.gz") do (

        "%ProgramFiles%\7-Zip\7z.exe" x -y -o"%%~dpI" "%%~fI"

      )

      _____________________________________________________________

       

      Then, in a Custom (general) FDM script I have tried to trigger the bat file several 3 different ways but none of them work. 


      _____________________FDM SCRIPT CONTENTS___________________

      Sub EAExtract


      Dim BatPath

      BatPath = "D:\Oracle\Middleware\EPMSystem11R1\products\FinancialDataQuality\fdmdata\FDMPRD\Inbox\EAEXTRACT\unzip.bat"

       

      API.DataWindow.Utilities.mShellAndWait BatPath,60 'Attempt 1 to trigger bat file

       

      DW.Utilities.mShellAndWait BatPath,-1 'Attempt 2 to trigger bat file

       

      Set WshShell = CreateObject("WScript.Shell") 'Attempt 3 to trigger bat file

      WshShell.Run BatPath, 3, Run

       

      End Sub

      _____________________________________________________________

       

      Based on what I have read all three of these attempts above should worked.  Can someone please give me a little assist on this? The same behavior occurs on the FDM workbench and the web client.   FDM says the script runs successfully but nothing happens.

       

      Thank you