13 Replies Latest reply: May 8, 2014 8:31 AM by Lori Baysdon RSS

    Viewing PDF reports output has improper format

    Lori Baysdon

      Background:

      EBS11.5.10.2

      migrations of apps tier from solaris to linux --requires new install of tech stack.

       

      Problem:

      PDF reports generated from concurrent request are not presenting the correct format.  ie log is missing, boxes/column outlines aren't printing -- only a generic text output

       

      The printer selection is noprint

       

      On the source solaris system the noprint printer uses hpl driver with arguments directing to acroprint which in turn calls acroread -- i think this is a method they use to convert pdf to postscript ( i am new to this system so have no history with it)

       

      I am unsure what to do to get the correct viewing for PDF's with the new linux install.   I have tried various drivers for noprint, nothing has any effect.  I even tried to replicate the acroprint set up...same result.  No matter what I change behind the scenes, the report view is the exact same.  All same text and all formating missing.

       

      The report itself is set to use style PDF_PORTRAIT.  I had to create that style in the new system, it is apparently a custom style - its the one calling the acroprint/acroread scripts.  I tried to mimic the setup on the Linux side, but the old one has Acrobat 5.  Acrobat currently doesn't have acorprint script - maybe it was custom? Again not sure. 

       

      Bottom line, how can i get PDF's to view as correctly formatted?  I'm not printing, only viewing...therefore not sure if I need to set up pasta printing just to view?

       

      I appreciate any help you can give. I have another similar thread..but I think I took it in the wrong direction, so I'm going to close that one.

       

      Thanks,

      Lori