1 Reply Latest reply on Apr 25, 2014 6:27 PM by alwu-Oracle

    Question about the ORACLE_SEM_FS_NS prefix

    192c02bd-5ba3-4425-a11c-bb8b7b4444c6

      Hi All

      We have an Oracle 12 sparql endpoint setup using the standard Joseki installation.

      In order to get results back from the endpoint we have to use the PREFIX ORACLE_SEM_FS_NS in our queries.

      e.g.

      PREFIX ORACLE_SEM_FS_NS: http://oracle.com/semtech#timeout=100,qid=123,strict_default=f

       

      The important bit for us to get results back is the "strict_default=f" part of the prefix.

       

      Adding this prefix into a sparql query is OK if used directly but we wish to call the endpoint from other applications using a service clause.

      e.g.

      PREFIX ORACLE_SEM_FS_NS: http://oracle.com/semtech#timeout=100,qid=123,strict_default=f

      SELECT *

      WHERE {

           SERVICE <myendpoint> {

                SELECT *

                WHERE {

                     <myresource> ?p ?o .

                }

           }

      }

       

      However this does not work since the prefix is not passed into the service clause and sent along with the call.

      So we are unable to use the endpoint from TopBraidComposer or other clients using this method.

       

      My question: Is there a way to work around this?

      Perhaps setting the strict_default=f somewhere in the database configuration itself?

       

      Thanks in advance