2 Replies Latest reply: Apr 29, 2014 11:07 AM by 876213 RSS

    How to Sync with NTP Server?


      The timestamps on records captured by Oracle Audit Vault do not reflect actual time of session events on monitored database servers.  The Oracle Audit Vault server is an out of the box Oracle Linux installation on a virtual machine, installed by Oracle Premium Services.  How can we change their configuratoin to reflect the preferred time from our NTP server?  Our /etc/ntp.conf file on the Oracle Audit Vault currently shows:



      # Permit time synchronization with our time source, but do not


      # permit the source to query or modify the service on this system.


      restrict default kod nomodify notrap nopeer noquery


      # Permit all access over the loopback interface. This could


      # be tightened as well, but to do so would affect some of


      # the administrative functions.




      # NTP Servers.




      # Undisciplined Local Clock. This is a fake driver intended for backup


      # and when no outside source of synchronized time is available.


      server # local clock


      fudge stratum 10


      # Drift file. Put this in a directory which the daemon can write to.


      # No symbolic links allowed, either, since the daemon updates the file


      # by creating a temporary in the same directory and then rename()'ing


      # it to the file.


      driftfile /var/lib/ntp/drift


      # Key file containing the keys and key identifiers used when operating


      # with symmetric key cryptography.


      keys /etc/ntp/keys

        • 1. Re: How to Sync with NTP Server?

          Home> Settings> Manage> System Time> Use NTP radio button allows specification of a NTP server, but returns an incorrect timestamp of 5 hours in the future when testing server.  We wanted a little more accuracy from Oracle Audit Vault if possible.  Our monitored database servers are returning the correct timestamp from the NTP server.

          • 2. Re: How to Sync with NTP Server?

            Note, clock shows correct time from Linux command line, date does not.



            # date


            Tue Apr 29 16:06:39 UTC 2014


            # clock


            Tue 29 Apr 2014 11:07:50 AM UTC -0.868625 seconds