2 Replies Latest reply: May 9, 2014 10:58 AM by liaison1 RSS

    Issues on creating 10g RAC to RAC standby DB.

    liaison1

      We tried to create and setup a RAC to RAC standby DB.   3-node RAC primary and 3-node RAC standby DB, to setup identical environment.   This Solaris 10 Sparc 64 bits.   We tried to follow the oracle metalink doc note (380449.1 - MAA - Creating a RAC Physical Standby for a RAC Primary).  

       

      Got  the following issues after the setup:

       

      1.     The archive log did not send and apply

      There message from primary alert log: PING[ARC0]: Heartbeat failed to connect to standby 'PFSTD'. Error is 16058.

      the primary parameter setting:

      log_archive_dest_2                   string   SERVICE=PFSTD LGWR ASYNC=20480 MAX_CONNECTIONS=3 REOPEN=60

      And the PFSTD in tnsnames.ora

      $ tnsping PFSTD

       

      Used TNSNAMES adapter to resolve the alias

      Attempting to contact (DESCRIPTION = (ADDRESS = (PROTOCOL = TCP)(HOST = lsssdb35u)(PORT = 1528)) (ADDRESS = (PROTOCOL = TCP)(HOST = lsssdb36u)(PORT = 1528)) (ADDRESS = (PROTOCOL = TCP)(HOST = lsssdb37u)(PORT = 1528)) (CONNECT_DATA = (SERVER = DEDICATED) (SERVICE_NAME = PDAMLPF1.liaison.com)))

      OK (10 msec)

       

      2.      When trying to manual recover for apply, got the message: 

      ORA-00279: change 13183102244265 generated at 05/05/2014 00:30:48 needed for

      thread 1

      ORA-00289: suggestion : +DG3

      ORA-00280: change 13183102244265 for thread 1 is in sequence #6997

       

       

      ORA-00308: cannot open archived log '+DG3'

      ORA-17503: ksfdopn:2 Failed to open file +DG3

      ORA-15045: ASM file name '+DG3' is not in reference form

       

      =======================================================================

      What we did more than the doc note 380449.1 are:

       

      1.  Created local listener for port 1528 on each standby node

      2.  Start the instance 1 on node 1 as:

      startup nomount

      alter database mount standby database;

      alter database recover managed standby database disconnect from session;

       

      3.  Start the instance 2 and 3 on the other node as only:

      startup nomount

      alter database mount standby database;

       

       

      Please advice where is the fix?   BTW, we created another standby earlier on the same RAC with same procedure, it works fine.   Maybe I missed something for this setup.