2 Replies Latest reply: May 7, 2014 2:40 PM by 2665969 RSS

    failing at registering data services to existing clustering

    2665969

      Ok, I've been maintaining some small clustered systems, but now I have inherited a system at work and I have to add the Sun Cluster HA for Apache Tomcat data services to one and am having some trouble.

       

      1.  I've Installed the Sun Cluster HA for Apache Tomcat, indicated success.

      2.  I've created my parameter file in \bin.

      3.  I've created by sctomcat_config file, when I go to run the sctomcat_register instruction, it is reporting... (I've tried several variations)

       

      (C515685) SUNW.gds: Invalid resource

      Registration of resource tomcat-res failed, please correct the wrong parameters.

       

      Earlier in the Sun Cluster Data Service for Apache Tomcat Guide for Solaris OS it says that the dependencies are SUNW.gds and SUNW.HAStoragePlus.

       

      Can someone help me figure out any of the following:

       

      1. have I missed a step somewhere?

      2. what is the "HAS_RS" field in the sctomcat_config file supposed to be?

      3. what are the actual dependencies and what format it is supposed to be in?

       

      Thanks

        • 1. Re: failing at registering data services to existing clustering
          T.F.-Oracle

          Hi,

           

          It would help to mention which specific Solaris Cluster and Solaris version you are using.

          The error message you cite is only the tail - the complete message would help. And you should also look into messages in /var/adm/messages on all cluster nodes.

          It would also help to see the specific content of the sctomcat_config file that you used for registration.

           

          The error message sort of suggests that you tried to create a resource with name "SUNW.gds", which won't work.

          SUNW.gds is a resource type provided with Solaris Cluster. The HA Tomcat data service is implemented as a SUNW.gds resource.

          As such you typically register the SUNW.gds resource type with:

           

          clrt register SUNW.gds

           

          The sctomcat_register script does all the required step to then create the SUNW.gds based HA Tomcat resource.

           

          Typically you place the parameter file either on a global file system, or on a failover file system (ie. a file system managed by SUNW.HAStoragePlus) residing in the same resource group as your HA Tomcat resource.

          I am not sure if by "\bin" you really meant /bin - in which case that would not be a good place for the parameter dir.

           

          Within HAS_RS you specify the resource name for the SUNW.HAStoragePlus resource that manages the corresponding file systems you use with tomcat.

          The sctomcat_register script does then set the correct resource dependencies.

           

          Take a look at a specific deployment example (ie. http://docs.oracle.com/cd/E23623_01/html/E26824/gchqi.html#scrolltoc) to see the flow of a specific configuration.

           

          Regards

                       Thorsten

          • 2. Re: failing at registering data services to existing clustering
            2665969

            Thank you for your help.  Sorry, I was in a rush and felt a little frustrated since I was having trouble making it work.  I actually got it working.  I am running 3.2 and using the 3.2 deployment guide.

             

            I only had to remove the value in the HAS_RS field in the sctomcat_config file and it successfully registered the resource.

             

            It is working I just need to figure out the correct action for the probe to execute and the correct return string to look for so clustering doesn't ping pong