2 Replies Latest reply: May 9, 2014 4:15 AM by Pechane RSS

    Unable to install service/file-system/smb on my repository server

    Pechane

      Hi all,

       

      I am facing the following issue.

       

      I use a repository server to update Solaris and install package.

       

      I would like to install service/file-system/smb on my repository server.

       

      I used the following :

       

      # pkg publisher

      PUBLISHER                   TYPE     STATUS P LOCATION

      solaris        (syspub)     origin   online T <system-repository>

      root@sfhvrep10:/toolbox# pkg info -r service/file-system/smb

                Name: service/file-system/smb

             Summary: SMB/CIFS server libraries and commands

         Description: The SMB/CIFS server allows a system to serve files, by means of

                      SMB shares, to SMB enabled clients, such as Windows and Mac OS

                      systems.  A Windows client (or other SMB client) can

                      interoperate with the SMB server as it would with a Windows

                      server.

            Category: System/File System

               State: Not installed

           Publisher: solaris

             Version: 0.5.11

      Build Release: 5.11

              Branch: 0.175.1.0.0.24.2

      Packaging Date: Wed Sep 19 18:45:29 2012

                Size: 667.14 kB

                FMRI: pkg://solaris/service/file-system/smb@0.5.11,5.11-0.175.1.0.0.24.2:20120919T184529Z

       

      # pkg install service/file-system/smb

      Creating Plan (Solver setup): |

      pkg install: No matching version of service/file-system/smb can be installed:

        Reject:  pkg://solaris/service/file-system/smb@0.5.11,5.11-0.175.1.0.0.24.2:20120919T184529Z

        Reason:  Package is not installed in parent image: service/file-system/smb

       

      # pkg publisher

      PUBLISHER                   TYPE     STATUS P LOCATION

      solaris        (syspub)     origin   online T <system-repository>

       

      I don't understand why the installation does not work on the repository itself.

       

      On another Solaris Server which references my repository server as publisher, it works fine !!!

       

      any idea please ?