3 Replies Latest reply: May 14, 2014 10:40 AM by Alan.S-Oracle RSS

    X forwarding through ssh does not work

    983825

      Hi,

       

      I tried to forward an X application from a Solaris 11.11 Sparc machine to my Linux PC without success.

      Forwarding X apps from other machines like e.g. a Solaris 10 10/08  - yes, you are reading correctly: 10/08 is running like a charm - or a SLES 11 box to my PC works fine!

      So the problem needs to be resolved on the Solaris 11 machine.

       

      What I tried with the DISPLAY variable:

      export DISPLAY=localhost:10.0  #this works with the other remote machines mentioned above

      leads to the message

      Error: cannot open display: localhost:10.0

      on the console upon starting the X app.

      Also using the IP address of my PC

      export DISPLAY=xy.xyz.x.y:0.0

      or

      export DISPLAY=xy.xyz.x.y:0.1

      did not succeed, the app does not show up on my PC.

      Also unsetting  the DISPLAY variable does not lead to anything.

       

       

      Need to mention that X tunneling through ssh is enabled:

      root@puk:~# grep X11F /etc/ssh/sshd_config

      X11Forwarding yes

      root@puk:~#

       

      What else needs to be configured?

      Appreciate your help.

       

      Michael