2 Replies Latest reply: May 12, 2014 10:33 AM by Alan.S-Oracle RSS

    SRU18.5 update problem

    1353167

      Hi,

       

      I wanted to update T5-2 SPARC servers and LDOM's from SRU13.6 or SRU15.4 to SRU18.5. but I got the errors and i couldn't solved the problem.  can you help me?

       

       

      root@yskpj2m1 # pkg info entire

                Name: entire

             Summary: entire incorporation including Support Repository Update (Oracle Solaris 11.1.15.4.0).

         Description: This package constrains system package versions to the same

                      build.  WARNING: Proper system update and correct package

                      selection depend on the presence of this incorporation.

                      Removing this package will result in an unsupported system.  For

                      more information see https://support.oracle.com/CSP/main/article

                      ?cmd=show&type=NOT&doctype=REFERENCE&id=1501435.1.

            Category: Meta Packages/Incorporations

               State: Installed

           Publisher: solaris

             Version: 0.5.11 (Oracle Solaris 11.1.15.4.0)

      Build Release: 5.11

              Branch: 0.175.1.15.0.4.0

      Packaging Date: December 30, 2013 08:35:00 PM

                Size: 5.46 kB

                FMRI: pkg://solaris/entire@0.5.11,5.11-0.175.1.15.0.4.0:20131230T203500Z

       

       

       

      root@yskpj2m1 # mount -F hsfs /export/home/admin/pechs/sol-11_1_18_5_0-incr-repo.iso /mnt

       

       

       

      root@yskpj2m1 # pkg publisher

      PUBLISHER                   TYPE     STATUS P LOCATION

      solaris                     origin   online F file:///mnt/repo/

       

       

       

      root@yskpj2m1 # pkg update --accept

      Creating Plan (Running solver): \

      pkg update: No solution was found to satisfy constraints

      Plan Creation: Package solver has not found a solution to update to latest available versions.

      This may indicate an overly constrained set of packages are installed.

       

       

      latest incorporations:

       

       

        pkg://solaris/consolidation/sunpro/sunpro-incorporation@0.5.11,5.11-0.175.1.18.0.2.0:20140317T182207Z

        pkg://solaris/consolidation/ips/ips-incorporation@0.5.11,5.11-0.175.1.16.0.1.0:20140113T191500Z

        pkg://solaris/consolidation/userland/userland-incorporation@0.5.11,5.11-0.175.1.18.0.4.0:20140401T194439Z

        pkg://solaris/consolidation/l10n/l10n-incorporation@0.5.11,5.11-0.175.1.16.0.2.2:20140121T214357Z

        pkg://solaris/consolidation/X/X-incorporation@0.5.11,5.11-0.175.1.18.0.2.1355:20140317T180850Z

        pkg://solaris/consolidation/install/install-incorporation@0.5.11,5.11-0.175.1.18.0.5.1736:20140411T220750Z

        pkg://solaris/consolidation/ldoms/ldoms-incorporation@0.5.11,5.11-0.175.1.17.0.3.0:20140221T230401Z

        pkg://solaris/entire@0.5.11,5.11-0.175.1.18.0.5.0:20140411T221903Z

        pkg://solaris/consolidation/osnet/osnet-incorporation@0.5.11,5.11-0.175.1.18.0.4.2:20140401T163824Z

        pkg://solaris/consolidation/cacao/cacao-incorporation@0.5.11,5.11-0.175.1.16.0.2.0:20140121T213954Z

        pkg://solaris/consolidation/desktop/gnome-incorporation@0.5.11,5.11-0.175.1.16.0.2.0:20140121T214111Z

        pkg://solaris/consolidation/desktop/desktop-incorporation@0.5.11,5.11-0.175.1.18.0.4.0:20140401T170521Z

       

       

      The following indicates why the system cannot update to the latest version:

       

       

        No suitable version of required package pkg://solaris/web/server/apache-22/module/apache-php52@5.2.17,5.11-0.175.1.17.0.3.0:20140221T230250Z found:

          Reject:  pkg://solaris/web/server/apache-22/module/apache-php52@5.2.17,5.11-0.175.1.17.0.3.0:20140221T230250Z

          Reason:  A version for 'require' dependency on pkg:/web/php-52@5.2.17,5.11 cannot be found

        No suitable version of required package pkg://solaris/web/server/apache-22/module/apache-php53@5.3.27,5.11-0.175.1.17.0.3.0:20140221T230256Z found:

          Reject:  pkg://solaris/web/server/apache-22/module/apache-php53@5.3.27,5.11-0.175.1.17.0.3.0:20140221T230256Z

          Reason:  A version for 'require' dependency on pkg:/web/php-53@5.3.27,5.11 cannot be found