9 Replies Latest reply on May 27, 2014 9:26 AM by bd3ad179-1f8c-4dc0-986e-7add44a0a967

    Oracle 11g XE on Open Suse 13.1

    bd3ad179-1f8c-4dc0-986e-7add44a0a967

      Hello everyone,

       

      I am currently installing an Oracle 11g Express on Open Suse 13.1 within a VM.

      I used the following document as reference for my installation: Oracle Database Express Edition

       

      Comments:

      I have a vanilla Open Suse 13.1 installation except these changes:

      • I adjusted /etc/HOSTNAME to OpenSuse, to avoid special characters in the host name
      • I increase the SWAP partition from 2045 to 2049 MB to ensure the minimum configuration

       

      I downloaded the RPM and extracted it. Afterwards i triggered the installation

       

      suse@OpenSuse:~/Downloads/Disk1> sudo rpm -ivh oracle-xe-11.2.0-1.0.x86_64.rpm

      root's password:

      Preparing...                          ################################# [100%]

      /var/tmp/rpm-tmp.jL4h0F: line 257: [: 18446744073709551615: integer expression expected

      Updating / installing...

         1:oracle-xe-11.2.0-1.0             ################################# [100%]

      Executing post-install steps...

      You must run '/etc/init.d/oracle-xe configure' as the root user to configure the database.

       

      Afterwards I ran the configuration script using the default values:

       

      suse@OpenSuse:~/Downloads/Disk1> sudo /etc/init.d/oracle-xe configure

       

      Oracle Database 11g Express Edition Configuration

      -------------------------------------------------

      This will configure on-boot properties of Oracle Database 11g Express

      Edition.  The following questions will determine whether the database should

      be starting upon system boot, the ports it will use, and the passwords that

      will be used for database accounts.  Press <Enter> to accept the defaults.

      Ctrl-C will abort.

       

      Specify the HTTP port that will be used for Oracle Application Express [8080]:

       

      Specify a port that will be used for the database listener [1521]:

       

      Specify a password to be used for database accounts.  Note that the same

      password will be used for SYS and SYSTEM.  Oracle recommends the use of

      different passwords for each database account.  This can be done after

      initial configuration:

      Confirm the password:

       

      Do you want Oracle Database 11g Express Edition to be started on boot (y/n) [y]:

       

      Starting Oracle Net Listener...Done

      Configuring database...

      Database Configuration failed.  Look into /u01/app/oracle/product/11.2.0/xe/config/log for details

       

       

      Do you have any idea, what's going on here? I attached the logs and some additional information. Maybe you can help me out?

      Thanks a lot in advance!

       

       

      cloneDBCreation.log

      Create controlfile reuse set database "XE"

      *

      ERROR at line 1:

      ORA-01034: ORACLE not available

      Process ID: 0

      Session ID: 0 Serial number: 0

       

       

      BEGIN dbms_backup_restore.zerodbid(0); END;

       

      *

      ERROR at line 1:

      ORA-01034: ORACLE not available

      Process ID: 0

      Session ID: 0 Serial number: 0

       

       

      ORA-01034: ORACLE not available

      ORA-27101: shared memory realm does not exist

      Linux-x86_64 Error: 2: No such file or directory

      ORA-00119: invalid specification for system parameter LOCAL_LISTENER

      ORA-00130: invalid listener address '(ADDRESS=(PROTOCOL=TCP)(HOST=OpenSuse)(PORT=1521))'

      Create controlfile reuse set database "XE"

      *

      ERROR at line 1:

      ORA-01034: ORACLE not available

      Process ID: 0

      Session ID: 0 Serial number: 0

       

       

      alter system enable restricted session

      *

      ERROR at line 1:

      ORA-01034: ORACLE not available

      Process ID: 0

      Session ID: 0 Serial number: 0

       

       

      alter database "XE" open resetlogs

      *

      ERROR at line 1:

      ORA-01034: ORACLE not available

      Process ID: 0

      Session ID: 0 Serial number: 0

       

       

      alter database rename global_name to "XE"

      *

      ERROR at line 1:

      ORA-01034: ORACLE not available

      Process ID: 0

      Session ID: 0 Serial number: 0

       

       

      alter system switch logfile

      *

      ERROR at line 1:

      ORA-01034: ORACLE not available

      Process ID: 0

      Session ID: 0 Serial number: 0

       

       

      alter system checkpoint

      *

      ERROR at line 1:

      ORA-01034: ORACLE not available

      Process ID: 0

      Session ID: 0 Serial number: 0

       

       

      alter database drop logfile group 3

      *

      ERROR at line 1:

      ORA-01034: ORACLE not available

      Process ID: 0

      Session ID: 0 Serial number: 0

       

       

      ALTER TABLESPACE TEMP ADD TEMPFILE '/u01/app/oracle/oradata/XE/temp.dbf' SIZE 20480K REUSE AUTOEXTEND ON NEXT 640K MAXSIZE UNLIMITED

      *

      ERROR at line 1:

      ORA-01034: ORACLE not available

      Process ID: 0

      Session ID: 0 Serial number: 0

       

       

      select tablespace_name from dba_tablespaces where tablespace_name='USERS'

      *

      ERROR at line 1:

      ORA-01034: ORACLE not available

      Process ID: 0

      Session ID: 0 Serial number: 0

       

       

      select sid, program, serial#, username from v$session

      *

      ERROR at line 1:

      ORA-01034: ORACLE not available

      Process ID: 0

      Session ID: 0 Serial number: 0

       

       

      alter user sys identified by "oracle"

      *

      ERROR at line 1:

      ORA-01034: ORACLE not available

      Process ID: 0

      Session ID: 0 Serial number: 0

       

       

      alter user system identified by "oracle"

      *

      ERROR at line 1:

      ORA-01034: ORACLE not available

      Process ID: 0

      Session ID: 0 Serial number: 0

       

       

      alter system disable restricted session

      *

      ERROR at line 1:

      ORA-01034: ORACLE not available

      Process ID: 0

      Session ID: 0 Serial number: 0

       

       

       

      CloneRmanRestore.log

       

      ORA-00119: invalid specification for system parameter LOCAL_LISTENER

      ORA-00130: invalid listener address '(ADDRESS=(PROTOCOL=TCP)(HOST=OpenSuse)(PORT=1521))'

      select TO_CHAR(systimestamp,'YYYYMMDD HH:MI:SS') from dual

      *

      ERROR at line 1:

      ORA-01034: ORACLE not available

      Process ID: 0

      Session ID: 0 Serial number: 0

       

       

      declare

      *

      ERROR at line 1:

      ORA-01034: ORACLE not available

      Process ID: 0

      Session ID: 0 Serial number: 0

       

       

      select TO_CHAR(systimestamp,'YYYYMMDD HH:MI:SS') from dual

      *

      ERROR at line 1:

      ORA-01034: ORACLE not available

      Process ID: 0

      Session ID: 0 Serial number: 0

       

       


      postDBCreation.log

      begin

      *

      ERROR at line 1:

      ORA-01034: ORACLE not available

      Process ID: 0

      Session ID: 0 Serial number: 0

       

       

       

      File created.

       

      ORA-01034: ORACLE not available

      ORA-27101: shared memory realm does not exist

      Linux-x86_64 Error: 2: No such file or directory

      ORA-00119: invalid specification for system parameter LOCAL_LISTENER

      ORA-00130: invalid listener address '(ADDRESS=(PROTOCOL=TCP)(HOST=OpenSuse)(PORT=1521))'

      select 'utl_recomp_begin: ' || to_char(sysdate, 'HH:MI:SS') from dual

      *

      ERROR at line 1:

      ORA-01034: ORACLE not available

      Process ID: 0

      Session ID: 0 Serial number: 0

       

       

      BEGIN utl_recomp.recomp_serial(); END;

       

      *

      ERROR at line 1:

      ORA-01034: ORACLE not available

      Process ID: 0

      Session ID: 0 Serial number: 0

       

       

      select 'utl_recomp_end: ' || to_char(sysdate, 'HH:MI:SS') from dual

      *

      ERROR at line 1:

      ORA-01034: ORACLE not available

      Process ID: 0

      Session ID: 0 Serial number: 0

       

       

       

      postScripts.log

      CREATE OR REPLACE LIBRARY dbms_sumadv_lib AS '/u01/app/oracle/product/11.2.0/xe/lib/libqsmashr.so';

      *

      ERROR at line 1:

      ORA-01034: ORACLE not available

      Process ID: 0

      Session ID: 0 Serial number: 0

       

       

      BEGIN dbms_datapump_utl.replace_default_dir; END;

       

      *

      ERROR at line 1:

      ORA-01034: ORACLE not available

      Process ID: 0

      Session ID: 0 Serial number: 0

       

       

      commit

      *

      ERROR at line 1:

      ORA-01034: ORACLE not available

      Process ID: 0

      Session ID: 0 Serial number: 0

       

       

      create or replace directory XMLDIR as '/u01/app/oracle/product/11.2.0/xe/rdbms/xml'

      *

      ERROR at line 1:

      ORA-01034: ORACLE not available

      Process ID: 0

      Session ID: 0 Serial number: 0

       

       

      DROP DIRECTORY ORACLE_OCM_CONFIG_DIR

      *

      ERROR at line 1:

      ORA-01034: ORACLE not available

      Process ID: 0

      Session ID: 0 Serial number: 0

       

       

      DROP DIRECTORY ADMIN_DIR

      *

      ERROR at line 1:

      ORA-01034: ORACLE not available

      Process ID: 0

      Session ID: 0 Serial number: 0

       

       

      DROP DIRECTORY WORK_DIR

      *

      ERROR at line 1:

      ORA-01034: ORACLE not available

      Process ID: 0

      Session ID: 0 Serial number: 0

       

       

      BEGIN dbms_swrf_internal.cleanup_database(cleanup_local => FALSE); END;

       

      *

      ERROR at line 1:

      ORA-01034: ORACLE not available

      Process ID: 0

      Session ID: 0 Serial number: 0

       

       

      commit

      *

      ERROR at line 1:

      ORA-01034: ORACLE not available

      Process ID: 0

      Session ID: 0 Serial number: 0

       

      /etc/HOSTNAME

      OpenSuse

       

      /etc/hosts

      #

      # hosts         This file describes a number of hostname-to-address

      #               mappings for the TCP/IP subsystem.  It is mostly

      #               used at boot time, when no name servers are running.

      #               On small systems, this file can be used instead of a

      #               "named" name server.

      # Syntax:

      #   

      # IP-Address  Full-Qualified-Hostname  Short-Hostname

      #

       

      127.0.0.1    localhost

       

      # special IPv6 addresses

      ::1             localhost ipv6-localhost ipv6-loopback

       

      fe00::0         ipv6-localnet

       

      ff00::0         ipv6-mcastprefix

      ff02::1         ipv6-allnodes

      ff02::2         ipv6-allrouters

      ff02::3         ipv6-allhosts

        • 1. Re: Oracle 11g XE on Open Suse 13.1
          Srini Chavali-Oracle

          openSUSE is not the same as SUSE, which is a supported OS (doc link you posted), so expect issues with the install and or the use of the software. Is there a reason you cannot use one of the supported OS versions ?

          • 2. Re: Oracle 11g XE on Open Suse 13.1
            oelk0

            Hello,

             

            i did that.

            Please take care of the following:

             

            1. disable apparmor:

            systemctl disable apparmor.service

            systemctl stop apparmor.service

             

            2. create the user manually:

            mkdir -p /u01/app/oracle > /dev/null 2>&1

            groupadd dba

            useradd  -d /u01/app/oracle -g dba oracle > /dev/null 2>&1

            chown -R oracle:dba /u01/app/oracle

             

            3. create the subsys directory:

            if ! test -d /var/lock/subsys; then

                mkdir /var/lock/subsys

                echo "mkdir /var/lock/subsys" >> /etc/init.d/boot.local

            fi

             

            4.create the sysconf settings in /etc/sysctl.conf:

            # Controls the default maximum size of a message queue

            kernel.msgmnb = 65536

             

            # Controls the maximum size of a message, in bytes

            kernel.msgmax = 65536

             

            # Controls the maximum shared segment size, in bytes

            kernel.shmmax = 68719476736

             

            # Controls the maximum number of shared memory segments, in pages

            kernel.shmall = 4294967296

             

            sysctl -p

             

            5. install the rpm:
            rpm -ivh oracle-xe-10.2.0.1-1.0.i386.rpm >> /var/log/XEsilentinstall.log

             

            6. make links for the oracle libs:

            ln -s /u01/app/oracle/product/11.2.0/xe/lib/libagtsh.so.1.0 /usr/lib64/libagtsh.so.1.0

            ln -s /u01/app/oracle/product/11.2.0/xe/lib/libcell11.so /usr/lib64/libcell11.so

            ln -s /u01/app/oracle/product/11.2.0/xe/lib/libclntsh.so.11.1 /usr/lib64/libclntsh.so.11.1

            ln -s /u01/app/oracle/product/11.2.0/xe/lib/libclsra11.so /usr/lib64/libclsra11.so

            ln -s /u01/app/oracle/product/11.2.0/xe/lib/libcorejava.so /usr/lib64/libcorejava.so

            ln -s /u01/app/oracle/product/11.2.0/xe/lib/libdbcfg11.so /usr/lib64/libdbcfg11.so

            ln -s /u01/app/oracle/product/11.2.0/xe/lib/libemmas11.so /usr/lib64/libemmas11.so

            ln -s /u01/app/oracle/product/11.2.0/xe/lib/libhasgen11.so /usr/lib64/libhasgen11.so

            ln -s /u01/app/oracle/product/11.2.0/xe/lib/libheteroxa11.so /usr/lib64/libheteroxa11.so

            ln -s /u01/app/oracle/product/11.2.0/xe/lib/libhgotrace11.so /usr/lib64/libhgotrace11.so

            ln -s /u01/app/oracle/product/11.2.0/xe/lib/libldapjclnt11.so /usr/lib64/libldapjclnt11.so

            ln -s /u01/app/oracle/product/11.2.0/xe/lib/libnjni11.so /usr/lib64/libnjni11.so

            ln -s /u01/app/oracle/product/11.2.0/xe/lib/libnnz11.so /usr/lib64/libnnz11.so

            ln -s /u01/app/oracle/product/11.2.0/xe/lib/libnque11.so /usr/lib64/libnque11.so

            ln -s /u01/app/oracle/product/11.2.0/xe/lib/libntcpaio11.so /usr/lib64/libntcpaio11.so

            ln -s /u01/app/oracle/product/11.2.0/xe/lib/libocci.so.11.1 /usr/lib64/libocci.so.11.1

            ln -s /u01/app/oracle/product/11.2.0/xe/lib/libocijdbc11.so /usr/lib64/libocijdbc11.so

            ln -s /u01/app/oracle/product/11.2.0/xe/lib/libocr11.so /usr/lib64/libocr11.so

            ln -s /u01/app/oracle/product/11.2.0/xe/lib/libocrb11.so /usr/lib64/libocrb11.so

            ln -s /u01/app/oracle/product/11.2.0/xe/lib/libocrutl11.so /usr/lib64/libocrutl11.so

            ln -s /u01/app/oracle/product/11.2.0/xe/lib/libodm11.so /usr/lib64/libodm11.so

            ln -s /u01/app/oracle/product/11.2.0/xe/lib/libodmd11.so /usr/lib64/libodmd11.so

            ln -s /u01/app/oracle/product/11.2.0/xe/lib/libons.so /usr/lib64/libons.so

            ln -s /u01/app/oracle/product/11.2.0/xe/lib/libqsmashr.so /usr/lib64/libqsmashr.so

            ln -s /u01/app/oracle/product/11.2.0/xe/lib/libskgxn2.so /usr/lib64/libskgxn2.so

            ln -s /u01/app/oracle/product/11.2.0/xe/lib/libskgxns.so /usr/lib64/libskgxns.so

            ln -s /u01/app/oracle/product/11.2.0/xe/lib/libskgxp11.so /usr/lib64/libskgxp11.so

            ln -s /u01/app/oracle/product/11.2.0/xe/lib/libsqlplus.so /usr/lib64/libsqlplus.so

            ln -s /u01/app/oracle/product/11.2.0/xe/lib/libsqora.so.11.1 /usr/lib64/libsqora.so.11.1

            ln -s /u01/app/oracle/product/11.2.0/xe/lib/libuini11.so /usr/lib64/libuini11.so

            ln -s /u01/app/oracle/product/11.2.0/xe/lib/libxdb.so /usr/lib64/libxdb.so

             

            ldconfig -X

             

             

            7. confgigure your database:

            /etc/init.d/./oracle-xe configure

             

            We have this running in production.

             

            Best regards

            1 person found this helpful
            • 3. Re: Oracle 11g XE on Open Suse 13.1
              Srini Chavali-Oracle

              i did that.

              Pl clarify what "that" refers to.

               

              You are running XE on an uncertified OS platform, so the install may or may not work as advertised, and/or the software (XE) may or may not work as advertised.

               

              We have this running in production.

              Not a very good idea IMHO

               

              HTH
              Srini

              • 4. Re: Oracle 11g XE on Open Suse 13.1
                bd3ad179-1f8c-4dc0-986e-7add44a0a967

                Hello everyone,

                 

                thanks so far for the support.

                 

                @

                I was hoping that Suse and Suse Enterprise (I think that is SLES / SLED?) are in a ways similar, but I seem to be wrong (and I learned something out of it). As it is not to be used for productive activities, but for testing and learning/studying, I was looking for a free Suse environment.

                 

                @

                • 5. Re: Oracle 11g XE on Open Suse 13.1
                  oelk0

                  Hello,

                  i forgot to mention:

                  set a vaild hostfile like this with a fixed ip-address.

                  127.0.0.2 linux133.workgroup linux133

                  192.168.0.100 linux133.workgroup linux133

                   

                  I agree with Srini Chavali, openSUSE is not supported, but as i said,

                  we have it running  in production.

                  You can choose Oracle Linux via download, it's free. So you're on the safe side.


                  Best regards

                   

                  1 person found this helpful
                  • 6. Re: Oracle 11g XE on Open Suse 13.1
                    bd3ad179-1f8c-4dc0-986e-7add44a0a967

                    Hello

                     

                    thanks for your reply!

                     

                    I tried to set everything up as recommended in your first post. The configuration command did not execute until the end. I will retry the procedure this evening and take a look for your recommendations of your second post (and post some log entries). In general, the same error codes as last time have been logged so far.

                     

                    Please find below my /etc/hosts

                     

                    suse@OpenSuse:~> cat /etc/hosts

                    #

                    # hosts         This file describes a number of hostname-to-address

                    #               mappings for the TCP/IP subsystem.  It is mostly

                    #               used at boot time, when no name servers are running.

                    #               On small systems, this file can be used instead of a

                    #               "named" name server.

                    # Syntax:

                    # IP-Address  Full-Qualified-Hostname  Short-Hostname

                    #

                     

                    127.0.0.1    localhost

                     

                    # special IPv6 addresses

                    ::1             localhost ipv6-localhost ipv6-loopback

                     

                    fe00::0         ipv6-localnet

                     

                    ff00::0         ipv6-mcastprefix

                    ff02::1         ipv6-allnodes

                    ff02::2         ipv6-allrouters

                    ff02::3         ipv6-allhosts

                     

                     

                    I assume I should add your recommended lines in there?

                     

                    This should be my hostname (set in /etc/HOSTNAME)

                    suse@OpenSuse:~> hostname

                    OpenSuse

                     

                     

                    Based on your recommendation I add the following lines (as there is no workgroup):

                     

                    127.0.0.1                 localhost.localdomain        localhost
                    192.168.85.133       localhost.localdomain        opensuse

                     

                     

                     

                    Is this enough, or do I need to add some workgroup (I did not set anything up)?

                     

                    Thanks a lot in advance!

                    • 7. Re: Oracle 11g XE on Open Suse 13.1
                      bd3ad179-1f8c-4dc0-986e-7add44a0a967

                      Hello everyone,

                       

                      thanks to I was able to start install Oracle 11g XE (after adjusting /etc/hosts, as described in my post above):

                       

                      suse@OpenSuse:~> sudo /etc/init.d/oracle-xe configure

                       

                      Oracle Database 11g Express Edition Configuration

                      -------------------------------------------------

                      This will configure on-boot properties of Oracle Database 11g Express

                      Edition.  The following questions will determine whether the database should

                      be starting upon system boot, the ports it will use, and the passwords that

                      will be used for database accounts.  Press <Enter> to accept the defaults.

                      Ctrl-C will abort.

                       

                      Specify the HTTP port that will be used for Oracle Application Express [8080]:

                       

                      Specify a port that will be used for the database listener [1521]:

                       

                      Specify a password to be used for database accounts.  Note that the same

                      password will be used for SYS and SYSTEM.  Oracle recommends the use of

                      different passwords for each database account.  This can be done after

                      initial configuration:

                      Confirm the password:

                       

                      Do you want Oracle Database 11g Express Edition to be started on boot (y/n) [y]:

                       

                      Starting Oracle Net Listener...Done

                      Configuring database...Done

                      Starting Oracle Database 11g Express Edition instance...Done

                      Installation completed successfully.

                       

                      Afterwards I executed the script for setting the environment variables:

                       

                      suse@OpenSuse:~> . /u01/app/oracle/product/11.2.0/xe/bin/oracle_env.sh

                       

                      However - I cannot log in (as described in oracles installation guidelines), due to an incorrect password:

                       

                      suse@OpenSuse:~> sqlplus system

                       

                      SQL*Plus: Release 11.2.0.2.0 Production on Mon May 26 17:10:15 2014

                       

                      Copyright (c) 1982, 2011, Oracle.  All rights reserved.

                       

                      Enter password:

                      ERROR:

                      ORA-01017: invalid username/password; logon denied

                       

                       

                       

                      I assumed, that the password for the system user should be identically to the one specified in the configuration. Am I wrong here? Any suggestions / hints?

                       

                      Thanks a lot in advance!

                      • 8. Re: Oracle 11g XE on Open Suse 13.1
                        oelk0

                        Hello,

                         

                        1.

                        please set your FQDN in /etc/hosts

                        https://en.wikipedia.org/wiki/Fully_qualified_domain_name

                        http://kb.iu.edu/data/aiuv.html

                        yours is looking to me like from CentOS or Oracle Linux.

                         

                        Or have a look at NOVELLs site:

                        http://www.novell.com/documentation/suse91/suselinux-adminguide/html/ch14s03.html

                         

                        127.0.0.1 localhost

                        192.168.85.133 OpenSuse.???  OpenSuse

                         

                        2.

                        To log in:

                        sqlplus sys/<password> as sysdba

                        or

                        sqlplus system/<password>

                         

                        Note: the password is case sensitive!

                        or disable this as SYSDBA (sqlplus sys/<password> as sysdba):

                        ALTER SYSTEM SET SEC_CASE_SENSITIVE_LOGON = FALSE SCOPE=BOTH;

                         

                        3.

                        set the password age:

                        ALTER PROFILE DEFAULT LIMIT PASSWORD_LIFE_TIME UNLIMITED;

                        and restart

                        shutdown immediate;

                        startup;

                         

                         

                        4.

                        I created a file /ect/profile.local with:

                        . /u01/app/oracle/product/11.2.0/xe/bin/oracle_env.sh

                        So at every boot it will set the environment.

                        this is my /etc/profile.local:

                        . /u01/app/oracle/product/11.2.0/xe/bin/oracle_env.sh

                        ORACLE_HOME=/u01/app/oracle/product/11.2.0/xe

                        ORACLE_OWNER=oracle

                        ORACLE_SID=XE

                        LSNR=$ORACLE_HOME/bin/lsnrctl

                        SQLPLUS=$ORACLE_HOME/bin/sqlplus

                        export ORACLE_HOME

                        export ORACLE_SID

                        export ORACLE_BASE=/u01/app/oracle

                        export PATH=$ORACLE_HOME/bin:$PATH

                        NLS_LANG=`$ORACLE_HOME/bin/nls_lang.sh`

                        ORACLE_ADMIN=/u01/app/oracle/admin/$ORACLE_SID

                        export ORACLE_ADMIN

                        ORACLE_FLASH=/u01/app/oracle/fast_recovery_area/$ORACLE_SID

                        export ORACLE_FLASH

                        ORACLE_ALERT=/u01/app/oracle/diag/rdbms/xe/XE/trace

                        export ORACLE_ALERT

                        ORACLE_DATA_PUMP_DIR=/u01/app/oracle/admin/XE/dpdump

                        export ORACLE_DATA_PUMP_DIR

                        DIAGNOSTIC_DEST=$ORACLE_HOME/log

                        export DIAGNOSTIC_DEST

                        TNS_ADMIN=$ORACLE_HOME/network/admin

                        export TNS_ADMIN

                         

                        5.

                        Recreate the DBSNMP user in the database as SYSDBA (sqlplus sys/<password> as sysdba):

                        @/u01/app/oracle/product/11.2.0/xe/rdbms/admin/catnsnmp.sql

                        @/u01/app/oracle/product/11.2.0/xe/rdbms/admin/catsnmp.sql

                         

                        Best regards.

                        • 9. Re: Oracle 11g XE on Open Suse 13.1
                          bd3ad179-1f8c-4dc0-986e-7add44a0a967

                          Hi

                          suse@localhost:~> sudo su oracle

                          root's password:

                          oracle@localhost:/home/suse> sqlplus system/dbadmin as sysdba

                           

                          SQL*Plus: Release 11.2.0.2.0 Production on Tue May 27 11:23:13 2014

                           

                          Copyright (c) 1982, 2011, Oracle.  All rights reserved.

                           

                           

                          Connected to:

                          Oracle Database 11g Express Edition Release 11.2.0.2.0 - 64bit Production

                           

                          SQL>

                           

                          Now Oracle XE is starting as intended to.

                           

                          Thanks again for your support!