1 Reply Latest reply: Jun 4, 2014 9:49 AM by clcarter RSS

    problem disabling Space Management Coordinator (SMCO)

    1046920

      Hi All,

       

      I have recently installed 11.2.0.2 XE on Linux x86_64. After database startup i noticed about 30 background processes and 10 of them are (W000 - W009).

       

      I looked into some support documents and found that the below sql would turn off this feature. In my case i still see the 10 background processes after changing the parameter to 0 followed by a db bounce.

       

      ALTER SYSTEM SET "_ENABLE_SPACE_PREALLOCATION" = 0;

       

      Please guide me if anyone knows how to disable this feature in xe.

       

      Thanks in Advance.

        • 1. Re: problem disabling Space Management Coordinator (SMCO)
          clcarter

          What's the problem?

           

          There are a couple MOS notes on a bug related to SMCO, some indicate trouble when a tablespace is trying to autogrow.

           

          Are there any datafiles with .... AUTOEXTEND ON NEXT ... ?

           

          There are also a few mentions of troubles with tables or indexes having a very small .... NEXT .... parameter.

           

          select OWNER, INDEX_NAME, NEXT_EXTENT from  dba_indexes order by NEXT_EXTENT desc
          -- and

            select OWNER, table_NAME, NEXT_EXTENT from  dba_tables order by NEXT_EXTENT desc

           

           

          One must know the problem before trying to fix it.