7 Replies Latest reply on Jun 11, 2014 4:23 PM by alwu-Oracle

    Protege ontology on Oracle NoSQL

    joguerra

      Hi,

      I've created an ontology on Protege 4.3 that it seems okay. I added the NoSQL plugin to Protege and I saved the model and the inference into the database. Everything worked quite smooth so far and the database doesn't complain with the ontology. Now, I am using the Joseki endpoint to query the database. Joseki is running on Tomcat 7.0.X and the application seems okay.

      If I run the query below on Protege against my ontology, it works. But when I go back to the Joseki, it doesn't work

       

      PREFIX rdf:   <http://www.w3.org/1999/02/22-rdf-syntax-ns#>

      PREFIX rdfs:  <http://www.w3.org/2000/01/rdf-schema#>

      PREFIX xsd:   <http://www.w3.org/2001/XMLSchema#>

      PREFIX owl:   <http://www.w3.org/2002/07/owl#>

      PREFIX fn:    <http://www.w3.org/2005/xpath-functions#>

      PREFIX ouext: <http://oracle.com/semtech/jena-adaptor/ext/user-def-function#>

      PREFIX oext:  <http://oracle.com/semtech/jena-adaptor/ext/function#>

       

       

      PREFIX ORACLE_SEM_FS_NS: <http://oracle.com/semtech#timeout=100,qid=123>

      SELECT * WHERE  { ?x ?y ?z}

      LIMIT 100

       

      On Joseki, I updated the joseki-config.ttl file with the configuration of my store, I restarted the tomcat however nothing happens. The same query, seems not working but nothing complains against it.

       

      <#oracle> rdf:type oracle-nosql:Dataset;

          joseki:poolSize     2 ;         ## Number of concurrent connections allowed to this dataset.

          oracle-nosql:connection         ## NoSQL connection

          [

             rdf:type oracle-nosql:NoSQLConnection;

             oracle-nosql:hostName "myhost";

             oracle-nosql:storeName "test";

             oracle-nosql:hostPort "5000";

          ];

       

       

          ##oracle-nosql:allGraphs [];         ## Graph descriptions

          oracle-nosql:defaultGraph ];

          ##oracle-nosql:namedGraph [ oracle-nosql:graphName <http://g1>];

       

          .

       

      I am not fully sure where the problem is, The database is running, though I think the question is whether the query is well formatted and the configuration is okay. Can anyone around help me out to find out where the problem is?

       

      Thank you and I'd appreciate any clue