3 Replies Latest reply: Jun 17, 2014 1:20 AM by T.F.-Oracle RSS

    install SUN Cluster 4.1 on solaris 11.1 error dependency

    user13474062


      Hello,

       

      I tried to install the packages for solaris cluster 4.1 on solaris 11.1. But I always the message (Plan Creation: dependency error(s) in proposed packages:)

       

      Any Idea on wich version of Solaris 11.1 I can Install SUN Cluster 4.1 and following release 4.1_7_2.......

       

      Thanks for your help

       

      Wilfrid

       

      pkg install ha-cluster-full
      Creating Plan (Running solver): -
      pkg install: No solution was found to satisfy constraints

      maintained incorporations:

        pkg://solaris/consolidation/ldoms/ldoms-incorporation@0.5.11,5.11-0.175.1.17.0.3.0:20140221T230401Z
        pkg://solaris/consolidation/gfx/gfx-incorporation@0.5.11,5.11-0.175.1.0.0.5.0:20111212T232623Z
        pkg://solaris/consolidation/admin/admin-incorporation@0.5.11,5.11-0.175.1.0.0.5.0:20111212T232623Z
        pkg://solaris/consolidation/SunVTS/SunVTS-incorporation@0.5.11,5.11-0.175.1.19.0.2.18:20140411T190428Z
        pkg://solaris/consolidation/solaris_re/solaris_re-incorporation@0.5.11,5.11-0.175.1.14.0.1.0:20131111T172135Z
        pkg://solaris/consolidation/cacao/cacao-incorporation@0.5.11,5.11-0.175.1.19.0.4.0:20140425T195743Z
        pkg://solaris/consolidation/jdmk/jdmk-incorporation@0.5.11,5.11-0.175.1.12.0.1.0:20130909T211651Z
        pkg://solaris/consolidation/dbtg/dbtg-incorporation@0.5.11,5.11-0.175.1.0.0.15.0:20120501T214422Z
        pkg://solaris/consolidation/ips/ips-incorporation@0.5.11,5.11-0.175.1.16.0.1.0:20140113T191500Z
        pkg://solaris/consolidation/cde/cde-incorporation@0.5.11,5.11-0.175.0.0.0.0.0:20110927T191905Z
        pkg://solaris/consolidation/smcc/smcc-incorporation@0.5.11,5.11-0.175.1.0.0.5.0:20111212T232623Z
        pkg://solaris/consolidation/osnet/osnet-incorporation@0.5.11,5.11-0.175.1.19.0.5.2:20140505T164952Z
        pkg://solaris/consolidation/man/man-incorporation@0.5.11,5.11-0.175.1.0.0.21.0:20120723T163455Z
        pkg://solaris/consolidation/desktop/desktop-incorporation@0.5.11,5.11-0.175.1.19.0.4.0:20140425T195757Z
        pkg://solaris/consolidation/l10n/l10n-incorporation@0.5.11,5.11-0.175.1.16.0.2.2:20140121T214357Z
        pkg://solaris/consolidation/X/X-incorporation@0.5.11,5.11-0.175.1.18.0.2.1355:20140317T180850Z
        pkg://solaris/consolidation/sic_team/sic_team-incorporation@0.5.11,5.11-0.175.1.0.0.5.0:20111212T230120Z
        pkg://solaris/consolidation/sunpro/sunpro-incorporation@0.5.11,5.11-0.175.1.19.0.4.0:20140425T195909Z
        pkg://solaris/entire@0.5.11,5.11-0.175.1.19.0.6.0:20140508T221351Z
        pkg://solaris/consolidation/cns/cns-incorporation@0.5.11,5.11-0.175.1.6.0.3.0:20130322T213329Z
        pkg://solaris/consolidation/nspg/nspg-incorporation@0.5.11,5.11-0.175.1.0.0.5.0:20111212T232623Z
        pkg://solaris/consolidation/install/install-incorporation@0.5.11,5.11-0.175.1.18.0.5.1736:20140411T220750Z
        pkg://solaris/consolidation/userland/userland-incorporation@0.5.11,5.11-0.175.1.19.0.6.0:20140508T220721Z
        pkg://solaris/consolidation/desktop/gnome-incorporation@0.5.11,5.11-0.175.1.16.0.2.0:20140121T214111Z
        pkg://solaris/consolidation/sfw/sfw-incorporation@0.5.11,5.11-0.175.1.0.0.5.0:20111212T232623Z

      Plan Creation: dependency error(s) in proposed packages:

       

      pkg info entire

                Name: entire

             Summary: entire incorporation including Support Repository Update (Oracle Solaris 11.1.19.6.0).

         Description: This package constrains system package versions to the same

                      build.  WARNING: Proper system update and correct package

                      selection depend on the presence of this incorporation.

                      Removing this package will result in an unsupported system.  For

                      more information see https://support.oracle.com/CSP/main/article

                      ?cmd=show&type=NOT&doctype=REFERENCE&id=1501435.1.

            Category: Meta Packages/Incorporations

               State: Installed

           Publisher: solaris

             Version: 0.5.11 (Oracle Solaris 11.1.19.6.0)

      Build Release: 5.11

              Branch: 0.175.1.19.0.6.0

      Packaging Date: Thu May 08 22:13:51 2014

                Size: 5.46 kB

                FMRI: pkg://solaris/entire@0.5.11,5.11-0.175.1.19.0.6.0:20140508T221351Z

       

       

       

      pkg publisher

      PUBLISHER                   TYPE     STATUS P LOCATION

      solaris                     origin   online F http://xx.xx.xx.xx/

      ha-cluster                  origin   online F http://xx.xx.xx.xx/

        • 1. Re: install SUN Cluster 4.1 on solaris 11.1 error dependency
          T.F.-Oracle

          Unfortunately you truncated the pkg install output too early - the details shown after

           

          "Plan Creation: dependency error(s) in proposed packages:"

           

          would have been relevant. You can also try "pkg install -v ha-cluster-full".

           

          You also did xx-out the information on the specific publisher URL.

           

          You need to ensure that both, the solaris and ha-cluster publisher are accessible and the repos reflect the version you intent to install.

           

          Solaris Cluster 4.1 should install on S11.1 FCS and any newer SRU level - but installing ha-cluster-full will also likely need some additional Solaris packages as dependencies - that is why the repo really needs to match the version installed.

           

          Regards

                       Thorsten

          • 2. Re: install SUN Cluster 4.1 on solaris 11.1 error dependency
            user13474062

            Hello,

             

            Here is the following output message duing install.

             

            Thank's  for your help

             

            Wilfrid

             

            No suitable version of required package pkg://ha-cluster/ha-cluster/geo/replication/availability-suite@4.1,5.11-0.18:20121001T203909Z found:

                Reject:  pkg://ha-cluster/ha-cluster/geo/replication/availability-suite@4.1,5.11-0.18:20121001T203909Z

                Reason:  All versions matching 'require' dependency pkg:/ha-cluster/system/core are rejected

                  Reject:  pkg://ha-cluster/ha-cluster/system/core@4.1,5.11-0.18.2:20121001T203939Z

                  Reason:  A version for 'require' dependency on pkg:/text/locale cannot be found

              No suitable version of required package pkg://ha-cluster/ha-cluster/group-package/ha-cluster-data-services-full@4.1,5.11-0.18:20121001T203913Z found:

                Reject:  pkg://ha-cluster/ha-cluster/group-package/ha-cluster-data-services-full@4.1,5.11-0.18:20121001T203913Z

                Reason:  All versions matching 'require' dependency pkg:/ha-cluster/data-service/nfs are rejected

                  Reject:  pkg://ha-cluster/ha-cluster/data-service/nfs@4.1,5.11-0.18:20121001T203850Z

                  Reason:  A version for 'require' dependency on pkg:/text/locale cannot be found

              No suitable version of required package pkg://ha-cluster/ha-cluster/group-package/ha-cluster-geo-incorporation@4.1,5.11-0.18:20121001T203919Z found:

                Reject:  pkg://ha-cluster/ha-cluster/group-package/ha-cluster-geo-incorporation@4.1,5.11-0.18:20121001T203919Z

                Reason:  All versions matching 'require' dependency pkg:/ha-cluster/system/core@4.0,5.11 are rejected

                  Reject:  pkg://ha-cluster/ha-cluster/system/core@4.1,5.11-0.18.2:20121001T203939Z

                  Reason:  A version for 'require' dependency on pkg:/text/locale cannot be found

              No suitable version of required package pkg://ha-cluster/ha-cluster/group-package/ha-cluster-framework-full@4.1,5.11-0.18.2:20121001T203914Z found:

                Reject:  pkg://ha-cluster/ha-cluster/group-package/ha-cluster-framework-full@4.1,5.11-0.18.2:20121001T203914Z

                Reason:  All versions matching 'require' dependency pkg:/ha-cluster/group-package/ha-cluster-framework-slm are rejected

                  Reject:  pkg://ha-cluster/ha-cluster/group-package/ha-cluster-framework-slm@4.1,5.11-0.18.2:20121001T203917Z

                  Reason:  All versions matching 'require' dependency pkg:/ha-cluster/service/management are rejected

                    Reject:  pkg://ha-cluster/ha-cluster/service/management@4.1,5.11-0.18.2:20121001T203933Z

                    Reason:  A version for 'require' dependency on pkg:/text/locale cannot be found

              No suitable version of required package pkg://ha-cluster/ha-cluster/geo/replication/data-guard@4.1,5.11-0.18:20121001T203910Z found:

                Reject:  pkg://ha-cluster/ha-cluster/geo/replication/data-guard@4.1,5.11-0.18:20121001T203910Z

                Reason:  All versions matching 'require' dependency pkg:/ha-cluster/group-package/ha-cluster-geo-incorporation are rejected

                  Reject:  pkg://ha-cluster/ha-cluster/group-package/ha-cluster-geo-incorporation@4.1,5.11-0.18:20121001T203919Z

                  Reason:  All versions matching 'require' dependency pkg:/ha-cluster/system/core@4.0,5.11 are rejected

                    Reject:  pkg://ha-cluster/ha-cluster/system/core@4.1,5.11-0.18.2:20121001T203939Z

                    Reason:  A version for 'require' dependency on pkg:/text/locale cannot be found

              No suitable version of required package pkg://ha-cluster/ha-cluster/geo/geo-framework@4.1,5.11-0.18:20121001T203907Z found:

                Reject:  pkg://ha-cluster/ha-cluster/geo/geo-framework@4.1,5.11-0.18:20121001T203907Z

                Reason:  All versions matching 'require' dependency pkg:/ha-cluster/group-package/ha-cluster-geo-incorporation are rejected

                  Reject:  pkg://ha-cluster/ha-cluster/group-package/ha-cluster-geo-incorporation@4.1,5.11-0.18:20121001T203919Z

                  Reason:  All versions matching 'require' dependency pkg:/ha-cluster/system/core@4.0,5.11 are rejected

                    Reject:  pkg://ha-cluster/ha-cluster/system/core@4.1,5.11-0.18.2:20121001T203939Z

                    Reason:  A version for 'require' dependency on pkg:/text/locale cannot be found

              No suitable version of required package pkg://ha-cluster/ha-cluster/data-service/ha-zones@4.1,5.11-0.18:20121001T203848Z found:

                Reject:  pkg://ha-cluster/ha-cluster/data-service/ha-zones@4.1,5.11-0.18:20121001T203848Z

                Reason:  All versions matching 'require' dependency pkg:/ha-cluster/ha-service/gds are rejected

                  Reject:  pkg://ha-cluster/ha-cluster/ha-service/gds@4.1,5.11-0.18.2:20121001T203923Z

                  Reason:  All versions matching 'require' dependency pkg:/ha-cluster/system/core are rejected

                    Reject:  pkg://ha-cluster/ha-cluster/system/core@4.1,5.11-0.18.2:20121001T203939Z

                    Reason:  A version for 'require' dependency on pkg:/text/locale cannot be found

              No suitable version of required package pkg://ha-cluster/ha-cluster/group-package/ha-cluster-framework-l10n@4.1,5.11-0.18.2:20121001T203914Z found:

                Reject:  pkg://ha-cluster/ha-cluster/group-package/ha-cluster-framework-l10n@4.1,5.11-0.18.2:20121001T203914Z

                Reason:  All versions matching 'require' dependency pkg:/ha-cluster/locale are rejected

                  Reject:  pkg://ha-cluster/ha-cluster/locale@4.1,5.11-0.18:20121001T203930Z

                  Reason:  All versions matching 'require' dependency pkg:/ha-cluster/system/core are rejected

                    Reject:  pkg://ha-cluster/ha-cluster/system/core@4.1,5.11-0.18.2:20121001T203939Z

                    Reason:  A version for 'require' dependency on pkg:/text/locale cannot be found

              No suitable version of required package pkg://ha-cluster/ha-cluster/data-service/dhcp@4.1,5.11-0.18:20121001T203845Z found:

                Reject:  pkg://ha-cluster/ha-cluster/data-service/dhcp@4.1,5.11-0.18:20121001T203845Z

                Reason:  All versions matching 'require' dependency pkg:/service/network/dhcp are rejected

                  Reject:  pkg://solaris/service/network/dhcp@0.5.11,5.11-0.175.1.17.0.4.2:20140228T002727Z

                  Reason:  A version for 'require' dependency on pkg:/network/dhcp/dhcpmgr cannot be found

              No suitable version of required package pkg://ha-cluster/ha-cluster/ha-service/telemetry@4.1,5.11-0.18.2:20121001T203926Z found:

                Reject:  pkg://ha-cluster/ha-cluster/ha-service/telemetry@4.1,5.11-0.18.2:20121001T203926Z

                Reason:  All versions matching 'require' dependency pkg:/ha-cluster/library/cacao are rejected

                  Reject:  pkg://ha-cluster/ha-cluster/library/cacao@4.1,5.11-0.18.2:20121001T203927Z

                  Reason:  All versions matching 'require' dependency pkg:/ha-cluster/system/core are rejected

                    Reject:  pkg://ha-cluster/ha-cluster/system/core@4.1,5.11-0.18.2:20121001T203939Z

                    Reason:  A version for 'require' dependency on pkg:/text/locale cannot be found

              No suitable version of required package pkg://ha-cluster/ha-cluster/data-service/oracle-ebs@4.1,5.11-0.18:20121001T203854Z found:

                Reject:  pkg://ha-cluster/ha-cluster/data-service/oracle-ebs@4.1,5.11-0.18:20121001T203854Z

                Reason:  All versions matching 'require' dependency pkg:/ha-cluster/ha-service/gds are rejected

                  Reject:  pkg://ha-cluster/ha-cluster/ha-service/gds@4.1,5.11-0.18.2:20121001T203923Z

                  Reason:  All versions matching 'require' dependency pkg:/ha-cluster/system/core are rejected

                    Reject:  pkg://ha-cluster/ha-cluster/system/core@4.1,5.11-0.18.2:20121001T203939Z

                    Reason:  A version for 'require' dependency on pkg:/text/locale cannot be found

              No suitable version of required package pkg://ha-cluster/ha-cluster/group-package/ha-cluster-framework-scm@4.1,5.11-0.18.2:20121001T203916Z found:

                Reject:  pkg://ha-cluster/ha-cluster/group-package/ha-cluster-framework-scm@4.1,5.11-0.18.2:20121001T203916Z

                Reason:  All versions matching 'require' dependency pkg:/ha-cluster/system/dsconfig-wizard are rejected

                  Reject:  pkg://ha-cluster/ha-cluster/system/dsconfig-wizard@4.1,5.11-0.18.2:20121001T204032Z

                  Reason:  All versions matching 'require' dependency pkg:/ha-cluster/service/management are rejected

                    Reject:  pkg://ha-cluster/ha-cluster/service/management@4.1,5.11-0.18.2:20121001T203933Z

                    Reason:  A version for 'require' dependency on pkg:/text/locale cannot be found

              No suitable version of required package pkg://ha-cluster/ha-cluster/geo/replication/srdf@4.1,5.11-0.18:20121001T203911Z found:

                Reject:  pkg://ha-cluster/ha-cluster/geo/replication/srdf@4.1,5.11-0.18:20121001T203911Z

                Reason:  All versions matching 'require' dependency pkg:/ha-cluster/group-package/ha-cluster-geo-incorporation are rejected

                  Reject:  pkg://ha-cluster/ha-cluster/group-package/ha-cluster-geo-incorporation@4.1,5.11-0.18:20121001T203919Z

                  Reason:  All versions matching 'require' dependency pkg:/ha-cluster/system/core@4.0,5.11 are rejected

                    Reject:  pkg://ha-cluster/ha-cluster/system/core@4.1,5.11-0.18.2:20121001T203939Z

                    Reason:  A version for 'require' dependency on pkg:/text/locale cannot be found

              No suitable version of required package pkg://ha-cluster/ha-cluster/ha-service/smf-proxy@4.1,5.11-0.18.2:20121001T203925Z found:

                Reject:  pkg://ha-cluster/ha-cluster/ha-service/smf-proxy@4.1,5.11-0.18.2:20121001T203925Z

                Reason:  All versions matching 'require' dependency pkg:/ha-cluster/system/core are rejected

                  Reject:  pkg://ha-cluster/ha-cluster/system/core@4.1,5.11-0.18.2:20121001T203939Z

                  Reason:  A version for 'require' dependency on pkg:/text/locale cannot be found

              No suitable version of required package pkg://ha-cluster/ha-cluster/ha-service/derby@4.1,5.11-0.18.2:20121001T203923Z found:

                Reject:  pkg://ha-cluster/ha-cluster/ha-service/derby@4.1,5.11-0.18.2:20121001T203923Z

                Reason:  A version for 'require' dependency on pkg:/library/java/javadb cannot be found

              No suitable version of required package pkg://ha-cluster/ha-cluster/developer/api@4.1,5.11-0.18.2:20121001T203901Z found:

                Reject:  pkg://ha-cluster/ha-cluster/developer/api@4.1,5.11-0.18.2:20121001T203901Z

                Reason:  All versions matching 'require' dependency pkg:/ha-cluster/system/core are rejected

                  Reject:  pkg://ha-cluster/ha-cluster/system/core@4.1,5.11-0.18.2:20121001T203939Z

                  Reason:  A version for 'require' dependency on pkg:/text/locale cannot be found

              No suitable version of required package pkg://ha-cluster/ha-cluster/geo/replication/sbp@4.1,5.11-0.18:20121001T203911Z found:

                Reject:  pkg://ha-cluster/ha-cluster/geo/replication/sbp@4.1,5.11-0.18:20121001T203911Z

                Reason:  All versions matching 'require' dependency pkg:/ha-cluster/group-package/ha-cluster-geo-incorporation are rejected

                  Reject:  pkg://ha-cluster/ha-cluster/group-package/ha-cluster-geo-incorporation@4.1,5.11-0.18:20121001T203919Z

                  Reason:  All versions matching 'require' dependency pkg:/ha-cluster/system/core@4.0,5.11 are rejected

                    Reject:  pkg://ha-cluster/ha-cluster/system/core@4.1,5.11-0.18.2:20121001T203939Z

                    Reason:  A version for 'require' dependency on pkg:/text/locale cannot be found

              No suitable version of required package pkg://solaris/web/server/apache-22/module/apache-php53@5.3.28,5.11-0.175.1.19.0.4.0:20140425T205121Z found:

                Reject:  pkg://solaris/web/server/apache-22/module/apache-php53@5.3.28,5.11-0.175.1.19.0.4.0:20140425T205121Z

                Reason:  All versions matching 'require' dependency pkg:/web/php-53@5.3.28,5.11 are rejected

                  Reject:  pkg://solaris/web/php-53@5.3.28,5.11-0.175.1.19.0.4.0:20140425T205025Z

                  Reason:  A version for 'require' dependency on pkg:/system/library/security/libmcrypt@2.5.8,5.11-0.175.1.0.0.24.0 cannot be found

              No suitable version of required package pkg://solaris/web/server/apache-22/module/apache-php52@5.2.17,5.11-0.175.1.19.0.4.0:20140425T205112Z found:

                Reject:  pkg://solaris/web/server/apache-22/module/apache-php52@5.2.17,5.11-0.175.1.19.0.4.0:20140425T205112Z

                Reason:  All versions matching 'require' dependency pkg:/web/php-52@5.2.17,5.11 are rejected

                  Reject:  pkg://solaris/web/php-52@5.2.17,5.11-0.175.1.19.0.4.0:20140425T204620Z

                  Reason:  A version for 'require' dependency on pkg:/system/library/security/libmcrypt@2.5.8,5.11-0.175.1.0.0.24.0 cannot be found

              No suitable version of required package pkg://solaris/x11/server/xvfb@1.12.2,5.11-0.175.1.17.0.3.1348:20140221T230343Z found:

                Reject:  pkg://solaris/x11/server/xvfb@1.12.2,5.11-0.175.1.17.0.3.1348:20140221T230343Z

                Reason:  A version for 'require' dependency on pkg:/x11/server/xserver-common@1.11.99,5.11 cannot be found

              No suitable version of required package pkg://solaris/x11/server/xephyr@1.12.2,5.11-0.175.1.17.0.3.1348:20140221T230331Z found:

                Reject:  pkg://solaris/x11/server/xephyr@1.12.2,5.11-0.175.1.17.0.3.1348:20140221T230331Z

                Reason:  A version for 'require' dependency on pkg:/x11/server/xserver-common@1.11.99,5.11 cannot be found

              No suitable version of required package pkg://solaris/x11/trusted/trusted-xorg@1.12.2,5.11-0.175.1.16.0.4.1345:20140131T235243Z found:

                Reject:  pkg://solaris/x11/trusted/trusted-xorg@1.12.2,5.11-0.175.1.16.0.4.1345:20140131T235243Z

                Reason:  A version for 'require' dependency on pkg:/x11/server/xserver-common@1.11.99,5.11 cannot be found

              No suitable version of required package pkg://ha-cluster/ha-cluster/geo/replication/zfs-sa@4.1,5.11-0.18:20121001T203912Z found:

                Reject:  pkg://ha-cluster/ha-cluster/geo/replication/zfs-sa@4.1,5.11-0.18:20121001T203912Z

                Reason:  All versions matching 'require' dependency pkg:/ha-cluster/group-package/ha-cluster-geo-incorporation are rejected

                  Reject:  pkg://ha-cluster/ha-cluster/group-package/ha-cluster-geo-incorporation@4.1,5.11-0.18:20121001T203919Z

                  Reason:  All versions matching 'require' dependency pkg:/ha-cluster/system/core@4.0,5.11 are rejected

                    Reject:  pkg://ha-cluster/ha-cluster/system/core@4.1,5.11-0.18.2:20121001T203939Z

                    Reason:  A version for 'require' dependency on pkg:/text/locale cannot be found

              No suitable version of required package pkg://solaris/x11/library/mesa@7.11.2,5.11-0.175.1.8.0.3.1332:20130528T204811Z found:

                Reject:  pkg://solaris/x11/library/mesa@7.11.2,5.11-0.175.1.8.0.3.1332:20130528T204811Z

                Reason:  A version for 'require' dependency on pkg:/x11/library/libdrm@2.4.32,5.11-0.175.1.0.0.24.1317 cannot be found

              No suitable version of required package pkg://solaris/developer/java/jdk-6@1.6.0.75,5.11:20140331T214535Z found:

                Reject:  pkg://solaris/developer/java/jdk-6@1.6.0.75,5.11:20140331T214535Z

                Reason:  A version for 'require' dependency on pkg:/SUNWcs@0.5.11,5.11-0.164 cannot be found

              No suitable version of required package pkg://ha-cluster/ha-cluster/group-package/ha-cluster-framework-minimal@4.1,5.11-0.18.2:20121001T203915Z found:

                Reject:  pkg://ha-cluster/ha-cluster/group-package/ha-cluster-framework-minimal@4.1,5.11-0.18.2:20121001T203915Z

                Reason:  All versions matching 'require' dependency pkg:/ha-cluster/system/cfgchk are rejected

                  Reject:  pkg://ha-cluster/ha-cluster/system/cfgchk@4.1,5.11-0.18.2:20121001T203938Z

                  Reason:  A version for 'require' dependency on pkg:/text/locale cannot be found

              No suitable version of required package pkg://solaris/x11/server/xorg/driver/xorg-video-mga@1.5.0,5.11-0.175.1.9.0.2.1338:20130614T231023Z found:

                Reject:  pkg://solaris/x11/server/xorg/driver/xorg-video-mga@1.5.0,5.11-0.175.1.9.0.2.1338:20130614T231023Z

                Reason:  A version for 'require' dependency on pkg:/library/graphics/pixman@0.24.4,5.11-0.175.1.0.0.24.1317 cannot be found

              No suitable version of required package pkg://solaris/system/trusted/trusted-global-zone@0.5.11,5.11-0.175.1.1.0.3.2:20121030T214830Z found:

                Reject:  pkg://solaris/system/trusted/trusted-global-zone@0.5.11,5.11-0.175.1.1.0.3.2:20121030T214830Z

                Reason:  A version for 'require' dependency on pkg:/system/device-allocation cannot be found

              No suitable version of required package pkg://solaris/x11/server/xvnc@1.1.0,5.11-0.175.1.17.0.3.1348:20140221T230347Z found:

                Reject:  pkg://solaris/x11/server/xvnc@1.1.0,5.11-0.175.1.17.0.3.1348:20140221T230347Z

                Reason:  A version for 'require' dependency on pkg:/x11/keyboard/xkbcomp cannot be found

              No suitable version of required package pkg://solaris/system/trusted@0.5.11,5.11-0.175.1.1.0.3.2:20121030T214831Z found:

                Reject:  pkg://solaris/system/trusted@0.5.11,5.11-0.175.1.1.0.3.2:20121030T214831Z

                Reason:  A version for 'require' dependency on pkg:/system/device-allocation cannot be found

              No suitable version of required package pkg://solaris/desktop/pdf-viewer/evince@2.30.3,5.11-0.175.1.19.0.2.0:20140411T190336Z found:

                Reject:  pkg://solaris/desktop/pdf-viewer/evince@2.30.3,5.11-0.175.1.19.0.2.0:20140411T190336Z

                Reason:  A version for 'require' dependency on pkg:/library/desktop/atk@1.30.0,5.11-0.175.1.0.0.20.0 cannot be found

              No suitable version of required package pkg://solaris/system/management/ovm-guest-additions@0.5.11,5.11-0.175.1.19.0.2.2:20140411T190042Z found:

                Reject:  pkg://solaris/system/management/ovm-guest-additions@0.5.11,5.11-0.175.1.19.0.2.2:20140411T190042Z

                Reason:  A version for 'require' dependency on pkg:/library/json-c@0.9,5.11-0.175.1 cannot be found

              No suitable version of required package pkg://solaris/x11/server/xorg@1.12.2,5.11-0.175.1.18.0.2.1355:20140317T180851Z found:

                Reject:  pkg://solaris/x11/server/xorg@1.12.2,5.11-0.175.1.18.0.2.1355:20140317T180851Z

                Reason:  A version for 'require' dependency on pkg:/x11/library/libdrm@2.4.32,5.11-0.175.1.0.0.24.1317 cannot be found

              No suitable version of required package pkg://solaris/SUNWj6dev@1.6.0.75,5.11:20140331T214533Z found:

                Reject:  pkg://solaris/SUNWj6dev@1.6.0.75,5.11:20140331T214533Z

                Reason:  All versions matching 'require' dependency pkg:/developer/java/jdk-6@1.6.0.75,5.11 are rejected

                  Reject:  pkg://solaris/developer/java/jdk-6@1.6.0.75,5.11:20140331T214535Z

                  Reason:  A version for 'require' dependency on pkg:/SUNWcs@0.5.11,5.11-0.164 cannot be found

              No suitable version of required package pkg://solaris/image/library/gegl@0.1.2,5.11-0.175.1.10.0.4.0:20130729T144039Z found:

                Reject:  pkg://solaris/image/library/gegl@0.1.2,5.11-0.175.1.10.0.4.0:20130729T144039Z

                Reason:  A version for 'require' dependency on pkg:/library/sdl@1.2.14,5.11-0.175.0.0.0.0.0 cannot be found

              No suitable version of required package pkg://solaris/system/input-method/iiim@0.5.11,5.11-0.175.1.13.0.3.1:20131018T211143Z found:

                Reject:  pkg://solaris/system/input-method/iiim@0.5.11,5.11-0.175.1.13.0.3.1:20131018T211143Z

                Reason:  A version for 'require' dependency on pkg:/gnome/config/gconf@2.31.1,5.11-0.175.1.0.0.20.0 cannot be found

              No suitable version of required package pkg://solaris/desktop/torrent/transmission@1.93,5.11-0.175.1.19.0.1.0:20140404T191125Z found:

                Reject:  pkg://solaris/desktop/torrent/transmission@1.93,5.11-0.175.1.19.0.1.0:20140404T191125Z

                Reason:  A version for 'require' dependency on pkg:/library/libnotify@0.4.5,5.11-0.175.0.0.0.0.0 cannot be found

              No suitable version of required package pkg://solaris/library/gnutls@2.8.6,5.11-0.175.1.18.0.4.0:20140401T170523Z found:

                Reject:  pkg://solaris/library/gnutls@2.8.6,5.11-0.175.1.18.0.4.0:20140401T170523Z

                Reason:  A version for 'require' dependency on pkg:/library/libtasn1@2.8,5.11-0.175.1.0.0.15.0 cannot be found

              No suitable version of required package pkg://solaris/install/distribution-constructor@0.5.11,5.11-0.175.1.14.0.1.1736:20131111T172123Z found:

                Reject:  pkg://solaris/install/distribution-constructor@0.5.11,5.11-0.175.1.14.0.1.1736:20131111T172123Z

                Reason:  A version for 'require' dependency on pkg:/system/extended-system-utilities cannot be found

              No suitable version of required package pkg://solaris/communication/conferencing/ekiga@3.2.7,5.11-0.175.1.9.0.2.0:20130614T230916Z found:

                Reject:  pkg://solaris/communication/conferencing/ekiga@3.2.7,5.11-0.175.1.9.0.2.0:20130614T230916Z

                Reason:  A version for 'require' dependency on pkg:/library/medialib@0.5.11,5.11-0.175.1.0.0.19.0 cannot be found

              No suitable version of required package pkg://solaris/mail/thunderbird@17,5.11-0.175.1.10.0.4.0:20130729T144229Z found:

                Reject:  pkg://solaris/mail/thunderbird@17,5.11-0.175.1.10.0.4.0:20130729T144229Z

                Reason:  A version for 'require' dependency on pkg:/codec/libtheora@1.1.1,5.11-0.175.1.0.0.15.0 cannot be found

              No suitable version of required package pkg://solaris/library/libproxy/libproxy-gnome@0.3.1,5.11-0.175.1.15.0.4.0:20131227T182134Z found:

                Reject:  pkg://solaris/library/libproxy/libproxy-gnome@0.3.1,5.11-0.175.1.15.0.4.0:20131227T182134Z

                Reason:  A version for 'require' dependency on pkg:/gnome/config/gconf@2.31.1,5.11-0.175.1.0.0.20.0 cannot be found

              No suitable version of required package pkg://solaris/gnome/help-viewer/yelp@2.30.2,5.11-0.175.1.10.0.4.0:20130729T143811Z found:

                Reject:  pkg://solaris/gnome/help-viewer/yelp@2.30.2,5.11-0.175.1.10.0.4.0:20130729T143811Z

                Reason:  A version for 'require' dependency on pkg:/library/desktop/gtk2@2.20.1,5.11-0.175.1.0.0.19.0 cannot be found

              No suitable version of required package pkg://solaris/system/input-method/iiim/wnn@8,5.11-0.175.1.13.0.3.1:20131018T211126Z found:

                Reject:  pkg://solaris/system/input-method/iiim/wnn@8,5.11-0.175.1.13.0.3.1:20131018T211126Z

                Reason:  A version for 'require' dependency on pkg:/library/desktop/atk@1.30.0,5.11-0.175.1.0.0.20.0 cannot be found

              No suitable version of required package pkg://solaris/gnome/preferences/control-center@2.30.0,5.11-0.175.1.6.0.1.2:20130312T222706Z found:

                Reject:  pkg://solaris/gnome/preferences/control-center@2.30.0,5.11-0.175.1.6.0.1.2:20130312T222706Z

                Reason:  A version for 'require' dependency on pkg:/gnome/gnome-audio@2.30.0,5.11-0.175.0.0.0.0.0 cannot be found

              No suitable version of required package pkg://solaris/web/browser/firefox@17,5.11-0.175.1.16.0.2.0:20140121T214153Z found:

                Reject:  pkg://solaris/web/browser/firefox@17,5.11-0.175.1.16.0.2.0:20140121T214153Z

                Reason:  A version for 'require' dependency on pkg:/library/desktop/atk@1.30.0,5.11-0.175.1.0.0.20.0 cannot be found

              No suitable version of required package pkg://solaris/mail/thunderbird/plugin/thunderbird-lightning@17,5.11-0.175.1.10.0.4.0:20130729T144212Z found:

                Reject:  pkg://solaris/mail/thunderbird/plugin/thunderbird-lightning@17,5.11-0.175.1.10.0.4.0:20130729T144212Z

                Reason:  All versions matching 'require' dependency pkg:/mail/thunderbird are rejected

                  Reject:  pkg://solaris/mail/thunderbird@17,5.11-0.175.1.10.0.4.0:20130729T144229Z

                  Reason:  A version for 'require' dependency on pkg:/codec/libtheora@1.1.1,5.11-0.175.1.0.0.15.0 cannot be found

              No suitable version of required package pkg://solaris/system/input-method/ibus@1.3.9,5.11-0.175.1.13.0.3.1:20131018T211114Z found:

                Reject:  pkg://solaris/system/input-method/ibus@1.3.9,5.11-0.175.1.13.0.3.1:20131018T211114Z

                Reason:  A version for 'require' dependency on pkg:/library/desktop/gobject/gobject-introspection@0.9.12,5.11-0.175.1.0.0.11.0 cannot be found

              No suitable version of required package pkg://solaris/gnome/gnome-remote-desktop@2.32.2,5.11-0.175.1.16.0.2.0:20140121T214114Z found:

                Reject:  pkg://solaris/gnome/gnome-remote-desktop@2.32.2,5.11-0.175.1.16.0.2.0:20140121T214114Z

                Reason:  A version for 'require' dependency on pkg:/library/gnome/gnome-keyring@2.30.1,5.11-0.175.1.0.0.12.0 cannot be found

              No suitable version of required package pkg://solaris/gnome/trusted/xagent@0.6.8,5.11-0.175.1.10.0.4.0:20130729T143829Z found:

                Reject:  pkg://solaris/gnome/trusted/xagent@0.6.8,5.11-0.175.1.10.0.4.0:20130729T143829Z

                Reason:  A version for 'require' dependency on pkg:/library/desktop/pango@1.28.3,5.11-0.175.0.0.0.0.0 cannot be found

              No suitable version of required package pkg://solaris/library/libproxy/libproxy-mozjs@0.3.1,5.11-0.175.1.15.0.4.0:20131227T182135Z found:

                Reject:  pkg://solaris/library/libproxy/libproxy-mozjs@0.3.1,5.11-0.175.1.15.0.4.0:20131227T182135Z

                Reason:  All versions matching 'require' dependency pkg:/web/browser/firefox@17,5.11-0.175.1.10.0.4.0 are rejected

                  Reject:  pkg://solaris/web/browser/firefox@17,5.11-0.175.1.16.0.2.0:20140121T214153Z

                  Reason:  A version for 'require' dependency on pkg:/library/desktop/atk@1.30.0,5.11-0.175.1.0.0.20.0 cannot be found

              No suitable version of required package pkg://solaris/terminal/gnome-terminal@2.30.2,5.11-0.175.1.9.0.2.0:20130614T231004Z found:

                Reject:  pkg://solaris/terminal/gnome-terminal@2.30.2,5.11-0.175.1.9.0.2.0:20130614T231004Z

                Reason:  A version for 'require' dependency on pkg:/library/desktop/atk@1.30.0,5.11-0.175.1.0.0.20.0 cannot be found

              No suitable version of required package pkg://solaris/desktop/time-slider@0.2.102,5.11-0.175.1.10.0.4.0:20130729T143730Z found:

                Reject:  pkg://solaris/desktop/time-slider@0.2.102,5.11-0.175.1.10.0.4.0:20130729T143730Z

                Reason:  A version for 'require' dependency on pkg:/gnome/zenity@2.30.0,5.11-0.175.1.0.0.20.0 cannot be found

              No suitable version of required package pkg://solaris/developer/gnome/devhelp@0.21,5.11-0.175.1.10.0.4.0:20130729T143740Z found:

                Reject:  pkg://solaris/developer/gnome/devhelp@0.21,5.11-0.175.1.10.0.4.0:20130729T143740Z

                Reason:  All versions matching 'require' dependency pkg:/web/browser/firefox@17,5.11-0.175.1.10.0.2.0 are rejected

                  Reject:  pkg://solaris/web/browser/firefox@17,5.11-0.175.1.16.0.2.0:20140121T214153Z

                  Reason:  A version for 'require' dependency on pkg:/library/desktop/atk@1.30.0,5.11-0.175.1.0.0.20.0 cannot be found

              No suitable version of required package pkg://solaris/library/audio/pulseaudio@1.1,5.11-0.175.1.10.0.4.0:20130729T144059Z found:

                Reject:  pkg://solaris/library/audio/pulseaudio@1.1,5.11-0.175.1.10.0.4.0:20130729T144059Z

                Reason:  A version for 'require' dependency on pkg:/codec/speex@1.2,5.11-0.175.1.0.0.15.0 cannot be found

              No suitable version of required package pkg://solaris/system/display-manager/gdm@2.30.7,5.11-0.175.1.19.0.4.0:20140425T195758Z found:

                Reject:  pkg://solaris/system/display-manager/gdm@2.30.7,5.11-0.175.1.19.0.4.0:20140425T195758Z

                Reason:  A version for 'require' dependency on pkg:/gnome/window-manager/metacity@2.30.1,5.11-0.175.0.0.0.0.0 cannot be found

              No suitable version of required package pkg://solaris/image/editor/gimp@2.6.10,5.11-0.175.1.10.0.4.0:20130729T143830Z found:

                Reject:  pkg://solaris/image/editor/gimp@2.6.10,5.11-0.175.1.10.0.4.0:20130729T143830Z

                Reason:  A version for 'require' dependency on pkg:/library/desktop/atk@1.30.0,5.11-0.175.1.0.0.20.0 cannot be found

              No suitable version of required package pkg://solaris/gnome/trusted/device-manager@0.6.4,5.11-0.175.1.10.0.4.0:20130729T143827Z found:

                Reject:  pkg://solaris/gnome/trusted/device-manager@0.6.4,5.11-0.175.1.10.0.4.0:20130729T143827Z

                Reason:  A version for 'require' dependency on pkg:/library/popt@1.7,5.11-0.175.0.0.0.0.0 cannot be found

              No suitable version of required package pkg://solaris/gnome/gnome-session@2.30.2,5.11-0.175.1.10.0.4.0:20130729T143750Z found:

                Reject:  pkg://solaris/gnome/gnome-session@2.30.2,5.11-0.175.1.10.0.4.0:20130729T143750Z

                Reason:  A version for 'require' dependency on pkg:/library/gnome/gnome-libs@2.30.0,5.11-0.175.1.0.0.20.0 cannot be found

              No suitable version of required package pkg://solaris/group/system/solaris-desktop@0.5.11,5.11-0.175.1.14.0.1.0:20131111T172136Z found:

                Reject:  pkg://solaris/group/system/solaris-desktop@0.5.11,5.11-0.175.1.14.0.1.0:20131111T172136Z

                Reason:  A version for 'group' dependency on pkg:/audio/audio-utilities cannot be found

              No suitable version of required package pkg://solaris/developer/java/jdk-7@1.7.0.55.13,5.11:20140331T214750Z found:

                Reject:  pkg://solaris/developer/java/jdk-7@1.7.0.55.13,5.11:20140331T214750Z

                Reason:  A version for 'require' dependency on pkg:/SUNWcs@0.5.11,5.11-0.164 cannot be found

            • 3. Re: install SUN Cluster 4.1 on solaris 11.1 error dependency
              T.F.-Oracle

              I think the output you provided confirms that you need to verify if your solaris publisher is accessible, and if the repo you configured really matches the Solaris version you installed.

               

              It tries to install e.g.: pkg:/text/locale (since that is listed as dependency for various ha-cluster/* packages), but it can't find a version in the repo that matches. So the install fails.

              Same is true for other Solaris packages that it requires, but can't find a matching version from the configured solaris publisher.

               

              Regards

                           Thorsten