12 Replies Latest reply: Jun 20, 2014 4:27 PM by marc1842fr RSS

    Strange compilation error

    ONEEYEMAN

      Hi, ALL,

      I'm getting strange compilation error and I need help resolving it.

       

      [code]

      igor@solaris:~/wxWidgets/buildMotif$ make

      /home/igor/wxWidgets/buildMotif/bk-deps CC -c -o coredll_sizer.o  -D__WXMOTIF__        -DWXBUILDING        -I../src/regex  -DWXUSINGDLL -DWXMAKINGDLL_CORE  -DwxUSE_BASE=0 -KPIC -DPIC  -D_FILE_OFFSET_BITS=64 -I/home/igor/wxWidgets/buildMotif/lib/wx/include/motif-unicode-3.1 -I../include -I/usr/dt/include -I/usr/openwin/include -mt -D_REENTRANT -g -features=tmplife ../src/common/sizer.cpp

      Front end: Not enough space

      Fork for exec of /opt/solarisstudio12.3/prod/bin/fbe failed

      Failure in /opt/solarisstudio12.3/prod/bin/fbe, status = 0xfe66fd5c

      Fatal Error exec'ing /opt/solarisstudio12.3/prod/bin/fbe

      *** Error code 2

      make: Fatal error: Command failed for target `coredll_sizer.o'

       

      igor@solaris:~/wxWidgets/buildMotif$ df -k

      Filesystem           1024-blocks        Used   Available Capacity  Mounted on

      rpool/ROOT/solaris     227082240     5966704   217293772     3%    /

      /devices                       0           0           0     0%    /devices

      /dev                           0           0           0     0%    /dev

      ctfs                           0           0           0     0%    /system/contract

      proc                           0           0           0     0%    /proc

      mnttab                         0           0           0     0%    /etc/mnttab

      swap                      865116        1508      863608     1%    /system/volatile

      objfs                          0           0           0     0%    /system/object

      sharefs                        0           0           0     0%    /etc/dfs/sharetab

      /usr/lib/libc/libc_hwcap1.so.1

                             223260476     5966704   217293772     3%    /lib/libc.so.1

      fd                             0           0           0     0%    /dev/fd

      rpool/ROOT/solaris/var

                             227082240      292088   217293772     1%    /var

      swap                      994772      131164      863608    14%    /tmp

      rpool/VARSHARE         227082240         224   217293772     1%    /var/share

      rpool/export           227082240         152   217293772     1%    /export

      rpool/export/home      227082240         160   217293772     1%    /export/home

      rpool/export/home/admin

                             227082240         164   217293772     1%    /export/home/admin

      rpool/export/home/igor

                             227082240     1246628   217293772     1%    /export/home/igor

      rpool                  227082240        5652   217293772     1%    /rpool

      /export/home/igor      218540400     1246628   217293772     1%    /home/igor

      [/code]

       

      It looks like I used 1% of the disk space, but the compilation stops with the error "not enough space".

       

      Can someone please help resolve the issue?

       

      Thank you.

        • 1. Re: Strange compilation error
          ONEEYEMAN

          Anyone? Should I supply an additional flag to configure/make? If yes - which one?

           

          I'm trying to build it with Solaris Studio 12.3.

           

          Thank you.

          • 2. Re: Strange compilation error
            ONEEYEMAN

            And now I got the same error compiling wxWidgets-3.0.1 for GTK+ with Solaris CC.

             

            [code]

            /home/igorwxWidgets/buildGTK/bk-deps CC -c -o coredll_sizer.o -D__WXGTK__ -DWXBUILDINGDLL -I../src/regex -DWXUSINGDLL -DWXMAKINGDLL_CORE -DwxUSE_BASE=0 -KPIC -DPIC -D_FILE_OFFSET_BITS=64 -I/home/igor/wxWidgets/buildGTK/lib/wx/include/gtk2-unicode-3.1 -I../include -D_REENTRANT -D_POSIX_PTHREAD_SEMANTICS -D_PTHREADS -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/gio-unix-2.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12 -D_REENTRANT -D_PTHREADS -I/usr/include/gstreamer-0.10 -I/usr/include/glib-2.0 -I/usr/lib/include/glib-2.0/include -I/usr/include/libxml2 -I/user/openwin/include -mt -D_REENTRANT -g -D_REENTRANT -D_POSIX_PTHREAD_SEMANTICS -D_PTHREADS -I/usr/include/gtk-2.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/dbus-1.0 -I/usr/include/dbus-1.0/include -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/gio-unix-2.0/ -I/usr/include/pixman-1 -I/usr/include/freetype2-I/usr/include/libpng12 -D_REENTRANT -D_POSIX_PTHREAD_SEMANTICS -D_PTHREADS -I/usr/inlude/gtk-unix-print-2.0 -I/usr/include/gtk-2.0 -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/lib/gtk-2.0/include -I/usr/include/gio-unix-2.0/ -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12 -features=tmplife ../src/common/sizer.cpp

            Front end: Not enough space

            Fork for exec of opt/solarisstudio12.3/prod/bin/fbe failed

            Failure in /opt/solarisstudio12.3/prod/bin/fbe, status=0xfe66fd5c

            Fatal Error exec'ing /opt/solarisstudio12.3/prod/bin/fbe

            ** Error code 2

            make: Fatal error: Command failed for target `coredll_sizer.o'

            [/code]

             

             

            Thank you.

            • 3. Re: Strange compilation error
              marc1842fr

              Not enough space means there isn't enough memory, it isn't about disk space. How much RAM do you have and is there any swap space configured on your machine?

              • 4. Re: Strange compilation error
                ONEEYEMAN

                Hi, marc1842fr,

                This machine has 2GB of RAM and no I didn't make any swap partition during the install.

                However, I can change /etc/fstab file to make a swap partition as this machine was made for Linux + Solaris and it already has Linux swap partition. I just need to fix the fstab file...

                 

                However, I think that 2GB is enough to finish compilation....

                 

                This is on the fresh new install of the Solaris 11.1 with fresh new Solaris Studio 12.3.

                 

                I didn't play with the system as I'm not familiar with the internals. Should I configure a swap stuff?

                 

                Thank you.

                 

                [EDIT]

                Also, what is the requirement for Sol Studio 12.2 on the RAM? Maybe I should simply downgrade?

                [/EDIT]

                • 5. Re: Strange compilation error
                  Steve.Clamage-Oracle

                  A large fraction of the 2Gb of RAM will be taken up by Solaris (depending on what features you are using, particularly ZFS), leaving not much for Studio to use.


                  You definitely need to create some swap space, say 20Gb.  But with only 2Gb of RAM, the machine will just thrash (spend all its time swapping memory to and from disk) when compiling. You should add more RAM. Personally, I would not even try with less than 4Gb, with 8Gb being a more realistic minimum. (I know the Release Notes say 1.5Gb minimum, 3Gb recommended, but I don't think those numbers are realistic.)

                  • 6. Re: Strange compilation error
                    ONEEYEMAN

                    Hi, Steve_Clamage,

                    That is OK. I can live with long time compilation. I'm more worried about errors like this...

                     

                    Now what I actually forgot to mention is that I'm not using IDE - I'm compiling thru the command line. What I noticed is that compilation of the wxMotif takes much longer than wxGTK.

                    Don't know why.

                     

                    What is memory requirements on the previous Studio version? In the mean time I will look at how to set up swap space...

                     

                    Thank you.

                     

                    [EDIT]

                    In the meantime I tried to configure the additional swap space as described here: http://docs.oracle.com/cd/E24457_01/html/E21988/gipoj.html. But issuing swap -a I received this:

                     

                    [code]

                    /home/igor/swapfile: Invalid operation for this filesystem type

                    [/code]

                     

                    I tried to make it on the /tmp, but there is not enough space left there unfortunately.

                     

                    [/EDIT]

                    • 7. Re: Strange compilation error
                      Fedor-Oracle

                      > Invalid operation for this filesystem type

                       

                      Most likely your home is NFS-mounted.

                      swap can work with local filesystem only.

                       

                      > I tried to make it on the /tmp

                       

                      Again, most likely /tmp is swap by itself.

                       

                      See what "swap -l" tells you. You should try to make the file similar to what it shows.

                       

                      regards,

                        Fedor.

                      • 8. Re: Strange compilation error
                        ONEEYEMAN

                        Hi, Fedor,

                        [code]

                        root@solaris: # mount -v

                        rppol/ROOT/solaris on / type zfs read/write/setuid/devices/rstchown/dev=4750002

                        /devices on /devices type devfsread/write/setuid/devices/rstchown/dev=8800000

                        /dev on /dev type dev read/write/setuid/devices/rstchown/dev=8840000

                        ctfs on /system/contract type ctfs read/write/setuid/devices/rstchown/dev=89000001

                        proc on /proc type proc read/write/setuid/devices/rstchown/dev=8880000

                        mnttab on /etc/mnttab type mntfs read/write/setuid/devices/rstchown/dev=8940001

                        swap on /system/volatile type tmpfs read/write/setuid/devices/rstchown/xattr/dev=8980001

                        objfs on /system/object type objfs read/write/setuid/devices/rstchown/dev=89c0001

                        sharefs on /etc/dfs/sharetab type sharefs read/write/setuid/devices/rstchown/dev=8a00001

                        /usr/lib/libc/libc_hwcap1.so.1 on /lib/libc.so.1 type lofs read/write/setuid/devices/rstchown/dev=4750002

                        fd on /dev/fd type fd read/write/setuid/devices/rstchown/dev=8b00001

                        rpool/ROOT/solaris/var on /var type zfs read/write/setuid/devices/rstchown/nonbmand/exec/xattr/atime/dev=4750003

                        swap on /tmp type tmpfs read/write/setuid/devices/rstchown/xattr/dev=8980002

                        rpool/VARSHARE on /var/share type zfs read/write/setuid/devices/rstchown/nonbmand/exec/xattr/atime/dev=4750004

                        rpool/export on /export type zfs read/write/setuid/devices/rstchown/nonbmand/exec/xattr/atime/dev=4750005

                        rpool/export/home on /export/home type zfs read/write/setuid/devices/rstchown/nonbmand/exec/xattr/atime/dev=4750006

                        rpool/export/home/admin on /export/home/admin type zfs read/write/setuid/devices/rstchown/nonbmand/exec/xattr/atime/dev=4750007

                        rpool/export/home/igor on /export/home/igor type zfs read/write/setuid/devices/rstchown/nonbmand/exec/xattr/atime/dev=4750008

                        rpool on /rpool type zfs read/write/setuid/devices/rstchown/nonbmand/exec/xattr/atime/dev=4750009

                        /export/home/igor on /home/igor type lofs read/write/setuid/devices/rstchown/dev=4750008

                        [/code]

                         

                        I don't see any nfs in that output.

                         

                        [code]

                        swap -l

                        swapfile -> /dev/zvol/dsk/rpool/swap

                        dev -> 285,2

                        swaplo -> 8

                        blocks -> 2097144

                        free -> 1384920

                        [/code]

                         

                        OK, will try that.

                         

                        [EDIT]

                        That does not work:

                        [code]

                        mkfile 20000m /dev/zvol/dsk/rpool/myswap

                        Could not open /dev/zvol/dsk/rpool/myswap: Read-only file system

                        [/code]

                        [/EDIT]

                         

                        Thank you.

                        .

                        • 9. Re: Strange compilation error
                          user12615116

                          For Studio12.3, the Hardware minimum requirements are: 2GB RAM, 4GB Swap, 10GB Disk.

                           

                          If you have some local disk space, the following commands can help with swap space:

                           

                          >mkfile  <size> swap_filename

                          >swap -a swap_filename  // to add swap space

                          >swap -l                         // to check swap space

                          >swap -d swapname     // to delete swap file

                           

                          If after fixing the swap space problem,  fbe still gives you  "Not enough space" message,  please

                          check your code if there are big initialize data in compile time, if so,  change them initialized in runtime,

                          see if that help; If you have no such code, then file a bug against assembler with source code. Thanks.

                          • 10. Re: Strange compilation error
                            ONEEYEMAN

                            Hi,

                            My hardware is satisfied to the minimal requirements.

                            Now the question is: where to put the swap file?

                             

                            Thank you.

                            • 11. Re: Strange compilation error
                              user12615116

                              Use your local disk space and use mkfile command there to create a "swapfile" and

                              use swap -a to add that 'swapfile" file to be your swap space.  Use swap -l to check the result.

                              (your swapfile may need to contain the path name)

                              • 12. Re: Strange compilation error
                                marc1842fr

                                With ZFS the swap handling is a bit special, but Google has no problem finding all the relevant instructions. First hit: http://docs.oracle.com/cd/E26502_01/html/E29006/gizfl.html