1 2 Previous Next 24 Replies Latest reply: Jun 19, 2014 2:42 AM by Daniel.TD RSS

    Loading data to ASO

    Daniel.TD

      I have a problem while loading data to Aggregate Storage database from my relational database. I load the data via maxl script for executing the rule file.

       

      When I load from the server itself (sample login script : login admin password localhost;), the script was no problem. It execute very well and finish until my aggregation.

       

      When I load from other computer (sample login script : login admin password essbase-server;), the script comes to no end. I've checked the session and it is written as request none.

       

      At First, I think that the problem is the connection timeout limit (My Data Load time is around 2 hours) so I try to load smaller data and it success.

       

      The question is,

      1. What is the cause of the problem? Is there anything that I need to config to have this permission? Because I success when I do it locally but don't success when I try to load it from different computer
      2. Is there any maximum time connection or size limit to uploading to client? It is because I can load smaller data but not the big data.

       

      I use essbase 11.1.2.3 with no patch and SQL Server as my relational database.

       

      update finding:

       

      I found that the data is still on the buffer and I tried to commit it to database but not all the data is loaded. Is it because of the connection?

       

      Thanks

        • 1. Re: Loading data to ASO
          name_and_address_withheld

          Not sure of the cause, but I wonder, instead of running the maxl script, could you open up a maxl session (essmsh) and run the command interactively.  I wonder if that would pinpoint the problem?

          • 2. Re: Loading data to ASO
            Daniel.TD

            Hmm. I think the result will be same. When I running the maxl script via batch file, it will run the maxl command in essmsh.

             

            But. I'll try it. maybe there will be some clue about the error. I'll report after it finished.

            • 3. Re: Loading data to ASO
              name_and_address_withheld

              Yes, I do not expect the result to be different, but the way I see it, it will be in essence "stepping through the code",  Might point to where the problem is.

              • 4. Re: Loading data to ASO
                955124

                Are you sure Maxl client works in your local machine . Just check it in the command prompt , typing essmsh or startmaxl.bat . You will see MAXL > , else you will have to configure      Maxl in your machine.

                • 5. Re: Loading data to ASO
                  abroshan-Oracle

                  Hi ..

                   

                  When you make the connection from other computer .. what does essbase.log says .. I think that should have some info .. if no info then looks like Maxl is not doing anything or even contacted essbase.

                  Also you can check that the client and server are of same version  and of compatible chipset type.

                  • 6. Re: Loading data to ASO
                    Daniel.TD

                    My Maxl is working fine. Like I said before. when I load smaller amount of data, it works. It didn't work only when I tried to load big data (request time more than 2 hours)

                    • 7. Re: Loading data to ASO
                      Daniel.TD

                      Hmm. I have not check the connection log. I'll check it then. But I think it should be like usual connection log. As I see on the session list, my request for importing data is listed but when it's gone, the maxl script didn't stop. Just stuck.

                      • 8. Re: Loading data to ASO
                        Phulsebosch

                        Hello Daniel,

                        since the smaller amount of data works, and all other is the same (data source, relational database, essbase database, user etc.), then I assume that there is somewhere a limit (max rows) or some resource issue.

                         

                        A data load in ASO goes through the loadbuffer first. I did not read about that. What are your settings/configuration in this? You might want to check this out. Also, are you loading in parallel?

                        If possible, you might create a quick BSO database to check on the limiter first.

                        Regards,

                        Philip Hulsebosch

                        • 9. Re: Loading data to ASO
                          Daniel.TD

                          yup.. all others is same. The difference only amount of the data.

                           

                          my buffer is like

                           

                          alter database BIMV.BIMV initialize load_buffer with buffer_id 2 resource_usage 1;

                           

                          and I don't load it in parrarel.

                           

                          If the limitation from the source, I disagree. When I load locally like I said before, It success even with the large set of data but no when I tried it remotely.

                           

                          That's why I ask, Is there any limit from essbase while doing remotely on essmsh?

                          • 10. Re: Loading data to ASO
                            KKT

                            Are you using any encryption for MaxL if so can you try without encryption.

                             

                            Thanks,

                            ~KKT~

                            • 11. Re: Loading data to ASO
                              Daniel.TD

                              nope. I don't use any encryption.

                              • 12. Re: Loading data to ASO
                                Daniel.TD

                                After I tried, no different between maxl script and manually start maxl session.

                                • 13. Re: Loading data to ASO
                                  Daniel.TD

                                  Add some finding but still no clue to solve it.

                                  • 14. Re: Loading data to ASO
                                    Phulsebosch

                                    Hello Daniel,

                                    I joint the show a bit later and did not read the first part properly.

                                     

                                    To start with your last question: That's why I ask, Is there any limit from essbase while doing remotely on essmsh?

                                    No, never seen, never heard of.

                                     

                                    A given maxl script with a data load from a relational database into an ASO Essbase cube works when started on the Essbase server.

                                    This maxl script does not run from a local machine. It starts, but does not finish. There is a session visible on the server, which disappears after a while.

                                    This maxl script with a smaller query (less data) run from this local machine is working. So connection-technically there is no difference between the larger query (failing) and smaller query (works).

                                    That what is changing is the amount of data queried. True?

                                     

                                    Technically, if you run a MaxL script from a local machine, the execution is (at least partial) done on that local machine. I am not sure if the data is brought via the network to this machine and then transferred over to the rule file and loaded into ASO, or goes directly from server to server. 

                                     

                                    Have a check the connection log and maybe you can see who issues the request.

                                    Also, what is written in the Essbase.log and the Application.log. Since there is an connection made, there must be something there.

                                    I hope this gives some light to this case.

                                     

                                    Regards,

                                    Philip Hulsebosch

                                    1 2 Previous Next