2 Replies Latest reply: Jun 16, 2014 11:57 AM by 991278 RSS

    French character stored as '?' in DB

    991278

      Hi,

       

      DB details:-

       

      SELECT * FROM v$version;
      
      BANNER                                                                        
      --------------------------------------------------------------------------------
      Oracle Database 11g Enterprise Edition Release 11.2.0.3.0 - Production          
      PL/SQL Release 11.2.0.3.0 - Production                                          
      CORE 11.2.0.3.0 Production                                                        
      TNS for Linux: Version 11.2.0.3.0 - Production                                  
      NLSRTL Version 11.2.0.3.0 - Production   
      
      

       

      OS: Oracle Linux 5 (64-bit)

       

      Trying to insert some French characters into DB, but the French characters are getting stored as '?' in DB.

       

      CREATE TABLE Orders (OrderID NUMBER, OrderName VARCHAR2(20));
      
      INSERT INTO Orders VALUES (1,'Ùratàè');
      COMMIT;
      
      SELECT * FROM Orders;
      
      OrderID OrderName
      ----------- ----------------
      1 ?rat??
      
      

       

      Checked the NLS parameters also:-

       

      SELECT * FROM nls_database_parameters;
      
      PARAMETER                      VALUE                                 
      ------------------------------ ----------------------------------------
      NLS_LANGUAGE                   AMERICAN                                
      NLS_TERRITORY                  AMERICA                                 
      NLS_CURRENCY                   $                                       
      NLS_ISO_CURRENCY               AMERICA                                 
      NLS_NUMERIC_CHARACTERS         .,                                      
      NLS_CHARACTERSET               AL32UTF8                                
      NLS_CALENDAR                   GREGORIAN                               
      NLS_DATE_FORMAT                DD-MON-RR                               
      NLS_DATE_LANGUAGE              AMERICAN                                
      NLS_SORT                       BINARY                                  
      NLS_TIME_FORMAT                HH.MI.SSXFF AM                          
      NLS_TIMESTAMP_FORMAT           DD-MON-RR HH.MI.SSXFF AM                
      NLS_TIME_TZ_FORMAT             HH.MI.SSXFF AM TZR                      
      NLS_TIMESTAMP_TZ_FORMAT        DD-MON-RR HH.MI.SSXFF AM TZR            
      NLS_DUAL_CURRENCY              $                                       
      NLS_COMP                       BINARY                                  
      NLS_LENGTH_SEMANTICS           BYTE                                    
      NLS_NCHAR_CONV_EXCP            FALSE                                   
      NLS_NCHAR_CHARACTERSET         AL16UTF16                               
      NLS_RDBMS_VERSION              11.2.0.3.0    
      
      

       

      Could someone help me out here as to how I can fix this issue.

       

      Thanks in advance...