2 Replies Latest reply on Jun 20, 2014 7:29 AM by Savi17

    Failed Partial update




      I am trying to run partial update using command prompt. But I am getting an exception and if i look into "Forge" logs, below is the error message:


      FATALFORGE{config}: Could not open "C:\Endeca\Apps\APProductFinder\data\partials\processing\price_update_records.xml": No such file or directory
      ERRORFORGE{config}: Forge failed with 1 error and 0 warnings.


      My file name is same in the partial pipeline.epx, ..testdata/partial and also partial_data_ready_flag of load_partial_test_data files. unable to figure out what is the reason for this error. It was working fine till yesterday and all of a sudden started throwing exception today.


      Any help would be appreciated.




        • 1. Re: Failed Partial update

          Hi Savi17,


          I ran into the same problem yesterday. All of a sudden it didn't work anymore.

          The trick for us was to run a complete baseline_update. After that, the partial-update worked as expected again (???)



          • 2. Re: Failed Partial update

            But it did not work for me. I tried running baseline update many times. Even after that partial update ended with the same error message.

            Then I changed the name of the file in all the places. It worked then. But still unable to find out what is the reason for this error and where does endeca hold the old file names even though it does not exist any more.