2 Replies Latest reply: Jun 26, 2014 3:13 AM by Eze-Oracle RSS

    Solaris 11 IPS Server Setup

    Muthupandian S - OPN - CTC Global

      Dear Team,

       

      Am unable to update my newly installed client to latest SRU from IPS server using http

       

      IPS Server

       

      1. Full Repo image is copied to "/IPS/OS-Repo/repo/"
      2. SRU iso mounted temporarily and update this system to latest and rebooted
      3. Latest SRU (20.0.5) incremental rsync done to  "/IPS/OS-Repo/repo/"
      4. Path updated in SMF and enabled service

       

       

      root@T4-2:/patch_pkg# svccfg -s application/pkg/server listprop pkg/inst_root

      pkg/inst_root astring     /IPS/OS-Repo/repo/

      root@T4-2:/patch_pkg#

       

      root@T4-2:/patch_pkg# pkg publisher

      PUBLISHER                   TYPE     STATUS P LOCATION

      solaris                     origin   online F http://10.12.100.90/

      root@T4-2:/patch_pkg#

       

      Newly Installed System (IPS Client)

       

      root@sc-node1:~# pkg publisher

      PUBLISHER                   TYPE     STATUS P LOCATION

      solaris                     origin   online F http://10.12.100.90/

      root@sc-node1:~# pkg list -af entire

      NAME (PUBLISHER)                                  VERSION                    IFO

      entire                                            0.5.11-0.175.1.20.0.5.0    ---

      entire                                            0.5.11-0.175.1.0.0.24.2    i--

      root@sc-node1:~#

      root@sc-node1:~#

      root@sc-node1:~# telnet 10.12.100.90 80

      Trying 10.12.100.90...

      Connected to 10.12.100.90.

      Escape character is '^]'.

       

       

       

       

      telnet> quit

       

      ERROR while updating

       

      root@sc-node1:~# pkg update

      Creating Plan (Running solver): \

      pkg update: No solution was found to satisfy constraints

      Plan Creation: Package solver has not found a solution to update to latest available versions.

      This may indicate an overly constrained set of packages are installed.

       

       

      latest incorporations:

       

       

        pkg://solaris/consolidation/desktop/desktop-incorporation@0.5.11,5.11-0.175.1.19.0.4.0:20140425T195757Z

        pkg://solaris/consolidation/osnet/osnet-incorporation@0.5.11,5.11-0.175.1.20.0.5.2:20140613T161634Z

        pkg://solaris/entire@0.5.11,5.11-0.175.1.20.0.5.0:20140613T162323Z

        pkg://solaris/consolidation/sic_team/sic_team-incorporation@0.5.11,5.11-0.175.1.20.0.3.0:20140523T175653Z

        pkg://solaris/consolidation/SunVTS/SunVTS-incorporation@0.5.11,5.11-0.175.1.19.0.2.18:20140411T190428Z

        pkg://solaris/consolidation/X/X-incorporation@0.5.11,5.11-0.175.1.18.0.2.1355:20140317T180850Z

        pkg://solaris/consolidation/l10n/l10n-incorporation@0.5.11,5.11-0.175.1.16.0.2.2:20140121T214357Z

        pkg://solaris/consolidation/install/install-incorporation@0.5.11,5.11-0.175.1.18.0.5.1736:20140411T220750Z

        pkg://solaris/consolidation/userland/userland-incorporation@0.5.11,5.11-0.175.1.20.0.5.0:20140613T161730Z

        pkg://solaris/consolidation/cacao/cacao-incorporation@0.5.11,5.11-0.175.1.19.0.4.0:20140425T195743Z

        pkg://solaris/consolidation/ips/ips-incorporation@0.5.11,5.11-0.175.1.20.0.3.0:20140523T175547Z

        pkg://solaris/consolidation/ldoms/ldoms-incorporation@0.5.11,5.11-0.175.1.17.0.3.0:20140221T230401Z

        pkg://solaris/consolidation/solaris_re/solaris_re-incorporation@0.5.11,5.11-0.175.1.14.0.1.0:20131111T172135Z

        pkg://solaris/consolidation/desktop/gnome-incorporation@0.5.11,5.11-0.175.1.16.0.2.0:20140121T214111Z

        pkg://solaris/consolidation/cns/cns-incorporation@0.5.11,5.11-0.175.1.6.0.3.0:20130322T213329Z

        pkg://solaris/consolidation/sunpro/sunpro-incorporation@0.5.11,5.11-0.175.1.19.0.4.0:20140425T195909Z

        pkg://solaris/consolidation/jdmk/jdmk-incorporation@0.5.11,5.11-0.175.1.12.0.1.0:20130909T211651Z

       

       

      The following indicates why the system cannot update to the latest version:

       

       

        No suitable version of required package pkg://solaris/consolidation/userland/userland-incorporation@0.5.11,5.11-0.175.1.20.0.5.0:20140613T161730Z found:

          Reject:  pkg://solaris/consolidation/userland/userland-incorporation@0.5.11,5.11-0.175.1.20.0.5.0:20140613T161730Z

          Reason:  A version for 'incorporate' dependency on pkg:/service/network/ntp@4.2.7.381,5.11-0.175.1.13.0.4.0 cannot be found

        No suitable version of required package pkg://solaris/web/server/apache-22/module/apache-php53@5.3.28,5.11-0.175.1.19.0.4.0:20140425T205121Z found:

          Reject:  pkg://solaris/web/server/apache-22/module/apache-php53@5.3.28,5.11-0.175.1.19.0.4.0:20140425T205121Z

          Reason:  A version for 'require' dependency on pkg:/web/php-53@5.3.28,5.11 cannot be found

        No suitable version of required package pkg://solaris/web/server/apache-22/module/apache-php52@5.2.17,5.11-0.175.1.19.0.4.0:20140425T205112Z found:

          Reject:  pkg://solaris/web/server/apache-22/module/apache-php52@5.2.17,5.11-0.175.1.19.0.4.0:20140425T205112Z

          Reason:  A version for 'require' dependency on pkg:/web/php-52@5.2.17,5.11 cannot be found

      root@sc-node1:~#

        • 1. Re: Solaris 11 IPS Server Setup
          Filip Francis

          Hi,

           

          I think you also need to original solaris repository.

          normaly you also have the following repo

          PUBLISHER                   TYPE     STATUS P LOCATION

          solaris                     origin   online F  http://pkg.oracle.com/solaris/release/

           

           

          And its looking for software in that repo.

          So make sure you also have that repo localy you can download the repo iso images from the support site

          Hope this helps

          Filip

          • 2. Re: Solaris 11 IPS Server Setup
            Eze-Oracle

            Hello

             

            With this output we see you have access  to SRU 20.5, but as the installed is sol11.1 we can't be sure it is available.

             

            root@sc-node1:~# pkg list -af entire

            NAME (PUBLISHER)                                  VERSION                    IFO

            entire                                            0.5.11-0.175.1.20.0.5.0    ---

            entire                                            0.5.11-0.175.1.0.0.24.2    i--

             

            Could you run this command please? it doesn't work for https but in your case is http

             

            pkgrepo list  -s  http://10.12.100.90/  | grep entire

             

            // check if you have access to these pkgs that update complain about please

             

             

            Reason:  A version for 'incorporate' dependency on pkg:/service/network/ntp@4.2.7.381,5.11-0.175.1.13.0.4.0 cannot be found

            Reason:  A version for 'require' dependency on pkg:/web/php-53@5.3.28,5.11 cannot be found

             

            A version for 'require' dependency on pkg:/web/php-52@5.2.17,5.11 cannot be found

             

             

            pkgrepo list  -s    http://10.12.100.90/   | grep network/ntp

            pkgrepo list -s   http://10.12.100.90/  | grep web/php

             

            Regards

            Eze