2 Replies Latest reply on Jun 26, 2014 12:50 PM by coldrunner

    Windows 7 64 bit, Access 2010 32 bit, Oracle 10G client 32 bit, Oracle database 64 bit


      I am trying to connect to an Oracle database from Windows 7 OS - 64 bit using
      Access 2010 32 bit and Oracle 32 bit client version installed on PC.
      My user requires a 64 bit Windows 7 OS for other needs.

      Oracle ODBC driver is 32 bit from Oracle 32 bit client.


      In Windows 7 OS 64 bit, ODBC DSN setup software is located in:

      C:\Windows\system32\odbcad32.exe for 64 bit drivers - all DSN types setup and
      C:\Windows\syswow64\odbcad32.exe for 32 bit drivers - USER DSN setup


      When I run the ODBC Data Source Administrator, I see the Version number is 6.1.7601.17632

      I setup a User DSN using the 32 bit odbcad32.exe with a 32 bit ODBC driver.
      Our Oracle TNSnames.ora file has our standard entries which have worked for years
      (Windows 7 OS 32 bit and everything 32 bit has connected for years too)

      So when I configure an ODBC User DSN and leave all the default settings and press the TEST Connection button, it says it works.


      But when I open the existng Access 2010 database (which does connect to Oracle in a Windows 7 32 bit PC environment),

      1. I go to Access External Data ribbon tab / Link to the Data Source by creating a linked table / press OK
      2. I select the Machine Data source = to the USER DSN name / press OK
      3. The Oracle ODBC Driver Connect Window opens with Service Name = USER DSN and User Name and it wants a Password
      4. I enter the correct password and I get the following error message:

      ODBC call failed
      [Oracle][ODBC]{Ora]ORA-12154: TNS: could not resolve the connect identifier specified
      (#12154) [Microsoft][ODBC Driver manager] Driver's SQLSetConnectAttr failed IM006 0
               [Microsoft][ODBC Driver Manager] Driver's SQLSetConnectAttr failed (#0)


      I have tried a quite a number of fixes:

      I have gone into the PC registry and cleaned out most or all off the Oracle client keys and
      reinstalled the Oracle 32 bit 10g client. It didn't fix the error.


      I read about the Oracle instantclient-basic-win32- with ODBC modules but I have Windows 7 64 bit.


      Anyone experienced a problem like this and have a fix?