3 Replies Latest reply on Jul 2, 2014 5:43 PM by ebsappsgirl

    OCP Studies -Installing Grid Infrastructure for ASM -Pt 2 Please Help

    ebsappsgirl

      You all have been great so far, I've had this issue for a few days and have been trying to fix it with no success. I'm praying you all can help me. I am trying to install the Grid Infrastructure. In the installer there are two scripts that has to be run. The first one runs great, the second root.sh does not. This is the log from the root.sh script:

       

      [root@mytest grid]# ./root.sh

      Running Oracle 11g root script...

       

       

      The following environment variables are set as:

          ORACLE_OWNER= oracle

          ORACLE_HOME=  /home/mytestapp/oracle/grid

       

       

      Enter the full pathname of the local bin directory: [/usr/local/bin]:

         Copying dbhome to /usr/local/bin ...

         Copying oraenv to /usr/local/bin ...

         Copying coraenv to /usr/local/bin ...

       

       

       

       

      Creating /etc/oratab file...

      Entries will be added to the /etc/oratab file as needed by

      Database Configuration Assistant when a database is created

      Finished running generic part of root script.

      Now product-specific root actions will be performed.

      Using configuration parameter file: /home/mytestapp/oracle/grid/crs/install/crsconfig_params

      Creating trace directory

      LOCAL ADD MODE

      Creating OCR keys for user 'oracle', privgrp 'oinstall'..

      Operation successful.

      LOCAL ONLY MODE

      Successfully accumulated necessary OCR keys.

      Creating OCR keys for user 'root', privgrp 'root'..

      Operation successful.

      CRS-4664: Node mytest successfully pinned.

      Adding daemon to inittab

      ohasd failed to start

      Failed to start the Clusterware. Last 20 lines of the alert log follow:

      2014-06-29 13:46:27.533

      [client(6031)]CRS-2101:The OLR was formatted using version 3.

      2014-06-29 13:46:29.371

      [client(6055)]CRS-1001:The OCR was formatted using version 3.

      [client(6091)]CRS-10001:CRS-6021: No msg for has:crs-6021 [l][unlimited]

       

       

      ohasd failed to start at /home/mytestapp/oracle/grid/crs/install/roothas.pl line 325.

      /home/mytestapp/oracle/grid/perl/bin/perl -I/home/mytestapp/oracle/grid/perl/lib -I/home/mytestapp/oracle/grid/crs/install /home/mytestapp/oracle/grid/crs/install/roothas.pl execution failed

       

       

      When I get to Adding daemon to inittab, it hangs for about 2 to 3 mins and then it fails and im not sure why, can you all please help me

       

      THanks so much