10 Replies Latest reply on Jul 1, 2014 5:49 AM by Krish Kay-Oracle

    Adapter function [fconnect] failed..

    992405

      Dear All,

       

      I am facing the below error, request you to provide me with any solution

       

      Error: Adapter function [fConnect] failed.

      Detail: Stacktrace:

      upsWBlockProcessorDM.clsBlockProcessorClass.ActLoad(strLoc[String], strCat[String], strStartPer[String], strEndPer[String], strFile[String], objLoadParam[Object&], blnNoRaiseEvents[Boolean], lngMarshalType[Int32])

      Hyperion.FDM.Dialogs.TargetSystemLoadDialog.buttonOK_ServerClick(sender[Object], e[EventArgs])

       

      Thanks in Advance...

        • 1. Re: Adapter function [fconnect] failed..
          KKT

          This issue sounds like the credentials supplied to the adapter are not getting you logged into HFM or Essbase (Target). Go to the adapter and right click it, configure, and check the HFM connection.

           

          Thanks,

          ~KKT~

          • 2. Re: Adapter function [fconnect] failed..
            992405

            Hello KKT,

             

            When ever i am facing this error I am re configuring the adapter (right click on adapter, configure, provide user name & password) and it will work fine.

            But after few days I encounter the same error again...I dont know what is the issue.

             

            This keeps on repeating

             

            Thanks...

            • 3. Re: Adapter function [fconnect] failed..
              KKT

              Are you using clustering on Essbase or Target System and in case if it is there make sure to add machine profiles for both the servers.

               

              If not I will ask you to check the firewall settings on FDM server.

               

              Thanks,

              ~KKT~

              • 4. Re: Adapter function [fconnect] failed..
                992405

                Sure KKT, I will check the Machine Profiles.

                 

                But can you please suggest me what should I look in at Firewall Settings on FDM server.

                any document on this would be of great help...

                 

                Thanks..

                • 5. Re: Adapter function [fconnect] failed..
                  992405

                  Adding to my above comments:

                   

                  Both HFM & FDM applications are on same server. Data Base server is on a different server.

                  I have checked the Machine Profiles and they are good.

                  Tired excluding the folder from antivirus scan assuming that Antivirus Scan might be deleting some of the files but no luck.

                  Regarding Firewall Settings what should I check for.

                  Please let me know.

                   

                  Thanks..

                  • 6. Re: Adapter function [fconnect] failed..
                    KKT

                    Firewall/DCOM Settings as per Oracle

                     

                     

                     

                    Port 135 must be open on all application servers and Web servers to allow for two-way DCOM communication.

                     

                     

                     

                    Unlike most Internet applications which have fixed TCP and/or UDP ports, DCOM dynamically assigns—at run time—one TCP port and one UDP port to each executable process serving DCOM objects on a computer. Because DCOM (by default) is free to use any port between 1024 and 65535 when it dynamically selects a port for an application.

                     

                     

                     

                    Open DCOM port range may be restricted by changing the following registry key:

                     

                     

                    HKEY_LOCAL_MACHINE\Software\Microsoft\Rpc\Internet

                     

                     

                     

                    Thanks,

                    ~KKT~

                    • 7. Re: Adapter function [fconnect] failed..
                      992405

                      Thanks KKT,

                       

                      Will Firewall settings effect the configuration settings of adapter and deletes the login credentials many times.

                      In the meanwhile I will check with your suggestions.

                       

                      Thanks..

                      • 8. Re: Adapter function [fconnect] failed..
                        KKT

                        No Firewall settings will not apply any existing changes in your application.

                         

                        Thanks,

                        ~KKT~

                        • 9. Re: Adapter function [fconnect] failed..
                          Francisco Amores

                          Hi these kind of issues could be related to policies being applied to DCOM users.

                          Check with your IT if there is any policy impacting on fdm dcom user.

                           

                          Regards

                          • 10. Re: Adapter function [fconnect] failed..
                            Krish Kay-Oracle

                            Try:

                            ~ Just make sure that HFM application name is the same in Integration Settings as the target application.

                            ~ Make the following changes on all HFM/FDM Application servers (anywhere HFM Client exists):

                            1. Click Start > Run, type regedit, and click OK.
                            2. Locate and then click the following registry subkey: HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\Rpc
                            If the Rpc key doesn't exist, create it by right-clicking on "Windows NT" and click New: Key.
                            3. Right-click on "Rpc" and select New, and then click DWORD Value.
                            4. Type Server2003NegotiateDisable as the name of the new DWORD Value.
                            5. Right-click Server2003NegotiateDisable, and click Modify.
                            6. In the Value Data box, type 1 (Base is left Hexadecimal) , and then click OK.
                            This setting disables the bind time negotiation and multiple transfer syntax negotiation.
                            7. Quit the Registry Editor and re-boot the machine.