As suggested by Jari, I added this to the Apex feature requests.
It will really help yes.
Right now I have a filter like this in some IR:
nvl(AF,Y) = substr( AH,9,15)
If the aliases could be replaced, it would be:
nvl(SPI_TAG, SPI_TAG_NEW) = substr( MASTER_TAG,9,15)
In the current situation I'm forced to scroll to columns Y, AF and AH in the selectlist to make me understand what I'm filtering..