3 Replies Latest reply: Aug 20, 2014 3:39 AM by 2655429 RSS

    Unable to deploy a Requester ABCS

    Senthil Raja

      Hi All,

      I am trying to redeploy a requester ABCS service from the JDeveloper IDE.

      Even though the Build is successful it fails while deploying in the server.

      I was able to deploy the same interface earlier but not now.

       

      Please Help!!!

      Error Details:

      [11:47:19 AM] ----  Deployment started.  ----

      [11:47:19 AM] Target platform is  (Weblogic 10.3).

      [11:47:19 AM] Running dependency analysis...

      [11:47:19 AM] Building...

      [11:47:45 AM] Deploying profile...

      [11:47:45 AM] Updating revision id for the SOA Project 'SyncPartyMergeListBoltReqABCSImpl.jpr' to '1.0'..

      [11:47:46 AM] Wrote Archive Module to F:\JDeveloper\mywork\ARCustomerOutbound\SyncPartyMergeListBoltReqABCSImpl\deploy\sca_SyncPartyMergeListBoltReqABCSImpl_rev1.0.jar

      [11:47:46 AM] Deploying sca_SyncPartyMergeListBoltReqABCSImpl_rev1.0.jar to partition "default" on server soa_server1 [http://10.137.181.153:8001]

      [11:47:46 AM] Processing sar=/F:/JDeveloper/mywork/ARCustomerOutbound/SyncPartyMergeListBoltReqABCSImpl/deploy/sca_SyncPartyMergeListBoltReqABCSImpl_rev1.0.jar

      [11:47:46 AM] Adding sar file - F:\JDeveloper\mywork\ARCustomerOutbound\SyncPartyMergeListBoltReqABCSImpl\deploy\sca_SyncPartyMergeListBoltReqABCSImpl_rev1.0.jar

      [11:47:46 AM] Preparing to send HTTP request for deployment

      [11:47:46 AM] Creating HTTP connection to host:10.137.181.153, port:8001

      [11:47:46 AM] Sending internal deployment descriptor

      [11:47:46 AM] Sending archive - sca_SyncPartyMergeListBoltReqABCSImpl_rev1.0.jar

      [11:47:47 AM] Received HTTP response from the server, response code=500

      [11:47:47 AM] Error deploying archive sca_SyncPartyMergeListBoltReqABCSImpl_rev1.0.jar to partition "default" on server soa_server1 [http://10.137.181.153:8001]

      [11:47:47 AM] HTTP error code returned [500]

      [11:47:47 AM] Error message from server:

      There was an error deploying the composite on soa_server1: Deployment Failed: Error occurred during deployment of component: SyncPartyMergeListBoltReqABCSImplProcess to service engine: implementation.bpel, for composite: SyncPartyMergeListBoltReqABCSImpl: ORABPEL-05250

       

      Error deploying BPEL suitcase.

      error while attempting to deploy the BPEL component file "/u02/app/product/fmw/user_projects/domains/soa_domain/servers/soa_server1/dc/soa_117da798-1a4b-4db0-b4cd-542087c40f38"; the exception reported is: java.lang.Exception: BPEL 1.1 compilation failed

       

      This error contained an exception thrown by the underlying deployment module.

      Verify the exception trace in the log (with logging level set to debug mode).

      .

       

      [11:47:47 AM] Check server log for more details.

      [11:47:47 AM] Error deploying archive sca_SyncPartyMergeListBoltReqABCSImpl_rev1.0.jar to partition "default" on server soa_server1 [http://10.137.181.153:8001]

      [11:47:47 AM] ####  Deployment incomplete.  ####

      [11:47:47 AM] Error deploying archive file:/F:/JDeveloper/mywork/ARCustomerOutbound/SyncPartyMergeListBoltReqABCSImpl/deploy/sca_SyncPartyMergeListBoltReqABCSImpl_rev1.0.jar

      (oracle.tip.tools.ide.fabric.deploy.common.SOARemoteDeployer)

       

      Regards

      Senthil Raja

        • 1. Re: Unable to deploy a Requester ABCS
          1055944

          Your Code is deployed to jar file but was not deployed on server as HTTP connection to your server failed.

          Test the application server connection once.

          Also check SOA server log to find out the error during deployment, it may tell you why the connection was refused.

          Else try deploying jar file from EM.

          • 2. Re: Unable to deploy a Requester ABCS
            981213

            Hi Senthil,

             

            Are you able to solve the issue. Even i am facing the same issue. I have checked my sever connection. It is up and running. Bu when i try to eploy my requestor service it is throwing below mentioned error.

             

            [03:02:36 PM] Received HTTP response from the server, response code=500
            [03:02:36 PM] Error deploying archive sca_SyncDebriefCommonReqABCSImpl_rev1.0.jar to partition "Custom_ACN" on server soa_server1 [http://13.198.11.201:8001]
            [03:02:36 PM] HTTP error code returned [500]
            [03:02:36 PM] Error message from server:
            There was an error deploying the composite on soa_server1: Deployment Failed: Error occurred during deployment of component: SyncDebriefCommonReqABCSImplProcess to service engine: implementation.bpel, for composite: SyncDebriefCommonReqABCSImpl: ORABPEL-05250

            Error deploying BPEL suitcase.
            error while attempting to deploy the BPEL component file "/data2/oracle/Middleware/user_projects/domains/fxap_domain/servers/soa_server1/dc/soa_98195e59-9a68-4909-811f-9d619d3b7b87"; the exception reported is: java.lang.Exception: BPEL 1.1 compilation failed

            This error contained an exception thrown by the underlying deployment module.
            Verify the exception trace in the log (with logging level set to debug mode).
            .

            [03:02:36 PM] Check server log for more details.
            [03:02:36 PM] Error deploying archive sca_SyncDebriefCommonReqABCSImpl_rev1.0.jar to partition "Custom_ACN" on server soa_server1 [http://hostname:8001]
            [03:02:36 PM] ####  Deployment incomplete.  ####
            [03:02:36 PM] Error deploying archive file:/C:/JDeveloper/mywork/DevWS/SyncDebriefCommonReqABCSImpl/deploy/sca_SyncDebriefCommonReqABCSImpl_rev1.0.jar
            (oracle.tip.tools.ide.fabric.deploy.common.SOARemoteDeployer

             

             

            Request you to help me out. Thanks in advance.

             

            Regards,

            Sai Sirisha

            • 3. Re: Unable to deploy a Requester ABCS
              2655429

              Did you try to deploy the jar file directly from EM console?

              Try and see if it works.

              As an alternate, you may use MOS Note, How To Deploy Composite in AIA 11g (Doc ID 1457489.1)