3 Replies Latest reply: Jul 15, 2014 3:24 AM by Mr Oracle RSS

    Weblogic 12cR3 issues

    Mr Oracle

      I had a few moments this weekend to try to deploy Weblogic 12cR3 (and I emphasize TRY).  I have a Linux box running Ubuntu 14.04 x64 LTS.  I ran the fmw generic installer and Java 1.7.0_55 for the install.

      I can run the console, but there are no deployments in the domain of any type - except a memory.rar ile.  I then tried to install the ADF (infrastructure) - still nothing in the deployment other than the rar file.  I tried to deploy a .jar file. Nada!  Errors all over trying to find the libraries (normally there are 33 in the deployment directory (domain)).  I know Ubuntu is not supported, so I switched to Oracle Enterprise server 6 - same result!

      The base server seems OK, I can run the console just fine, create data sources, change security, etc... - just cannot run ADF (or even deploy it)


      I followed the instruction to the tee, several times, nothing seems to work.  I have the integrated server in Windows working just fine, so I have a benchmark to look at. (JDeveloper 12.1.3).


      I have been reading the Internet - almost everyone is using the zip file to get it working (I will try this tomorrow).

      Anyone have any better results? or can share a How To?


      I have a client that wants to upgrade from 11g to 12c Weblogic (and JDeveloper) and they use Linux boxes - right now, I have to use a caution flag on the WebLogic side.  The JDeveloper is working great.

        • 1. Re: Weblogic 12cR3 issues
          Luz Mestre-Oracle

          How are you installing ADF 12.1.3?

          Here is the procedure

          4 Deploying ADF Applications (12c (12.1.3))

          If the above is not working for you.

          1. Do you see the ADF libs in the weblogic <domain>/config/config.xml?

          2. What is the output of opatch lsinventory?

          Patching Oracle Fusion Middleware with Oracle OPatch

          Best Regards


          • 2. Re: Weblogic 12cR3 issues
            Mr Oracle


            Yes, 12.1.3 infrastructure.using the java -jar method.

            The libraries get installed into the oracle_common/modules correctly.


            The config.xml does not contain any of the applications and libraries.

            In 11g the option was to upgrade a domain - there is no option for that in 12c.

            I had to guess that it was the required files. (I did not try to do the em or anything else at this time.)

            I used my integrated server and manually entered the applications and libraries successfully and they appear in the domain/config.xml fine.

            At least this got me around the rcu issue.


            One of the major issues is the rcu (I am not in a clustered environment - yet I have to configure for it!)

            I had to guess at what was needed (there should have been an option for ADF Runtime).


            I have one remaining issue - the shared security does not seem to be working (I am using a SQLAuthenticator).

            It would have been nice to have a list of the items needed (I think there is a missing item - security is different in the integrated environment).

            • 3. Re: Weblogic 12cR3 issues
              Mr Oracle

              I finally found a solution for this on the web that works:

              Without the rcu - you cannot update a domain for adf - so you need to do the workaround.  Tha Oracle JRF is actually the ADF (LOL).


              (I cannot remember where I found this - but thanks to someone - I think it was an Oracle person)


              The Steps to Install Without Needing a Database


                  First of all install WebLogic (wls_121200.jar) and the ADF runtime (fmw_infra_121200.jar) into the same 12c Oracle Home using their respective installers. At the end of each of the WebLogic install make sure you uncheck the Configuration Wizard launch option as we'll be doing that manually later.

                  Start a shell / command prompt in $MW_HOME/wlserver/common/bin

                  Set the environment variable QS_TEMPLATES to point to $MW_HOME/wlserver/common/templates/wls/wls_jrf.jar

                  Run qs_config.sh and define the name of the domain that you want to create (e.g. add_domain) along with the usual WebLogic passwords and ports that you require. Finish the Quick Start wizard without starting the new domain.

                  Now run the conventional config.sh and on the first page choose "Update an Existing Domain" rather than "Create a new domain". The new domain (e.g. adf_domain) should now be listed for selection.

                  On the second screen choose the templates that you wish to apply, e.g. Oracle JRF, Oracle Enterprise Manager etc.  and move on through the wizard.

                  On the Database Configuration Type screen this time you will see an extra option where Embedded Database (JavaDB) is offered and pre-selected. Select that and continue with the domain setup as usual with whatever managed servers you need.