7 Replies Latest reply on Jul 18, 2014 5:35 PM by deepika walia

    Weblogic Server is not running

    Ibag

      Hi All,

       

      We have encountered a weired problem, we are unable to start Admin Server, but when we start BI services BI services showing status as Running, BI Node Manager is Down and Admin Server is Down.

       

      Any suggestions why we have error!!!

        • 1. Re: Weblogic Server is not running
          deepika walia

          Hi,

           

          Please share Admin Server logs to find out what the problem is.

           

           

          Thanks

          • 2. Re: Weblogic Server is not running
            Ibag

            Hi Deepika,

             

            Admin logs are huge to share. I couldn't find where to attach.

             

            tnx

            • 3. Re: Weblogic Server is not running
              Sasi  Nagireddy

              Do tail -100 in the admin server log and paste here.

               

              Thanks,

              Sasi Nagireddy..

              • 4. Re: Weblogic Server is not running
                PPavani

                Hi,

                 

                Did you try starting Node Manager first?

                You can check them in Services.

                Later try starting Admin Server.

                 

                Thanks,

                Pavani

                • 5. Re: Weblogic Server is not running
                  Ibag

                  Hi Sasi,

                   

                  Pl find the log below.

                   

                  Pavani,

                   

                  Yes...did it..No Luck!!!

                   

                   

                  <Jul 18, 2014 3:41:39 PM HKT> <Notice> <WebLogicServer> <RG1063> <AdminServer> <Thread-1> <<WLS Kernel>> <> <> <1405669299462> <BEA-000388> <JVM called WLS shutdown hook. The server will force shutdown now>

                  ####<Jul 18, 2014 3:41:39 PM HKT> <Alert> <WebLogicServer> <RG1063> <AdminServer> <Thread-1> <<WLS Kernel>> <> <> <1405669299472> <BEA-000396> <Server shutdown has been requested by <WLS Kernel>>

                  ####<Jul 18, 2014 3:41:39 PM HKT> <Notice> <WebLogicServer> <RG1063> <AdminServer> <Thread-1> <<WLS Kernel>> <> <> <1405669299595> <BEA-000365> <Server state changed to FORCE_SHUTTING_DOWN>

                  ####<Jul 18, 2014 3:41:39 PM HKT> <Info> <WebLogicServer> <RG1063> <AdminServer> <Thread-1> <<WLS Kernel>> <> <> <1405669299617> <BEA-000236> <Stopping execute threads.>

                  ####<Jul 18, 2014 3:44:19 PM HKT> <Info> <WebLogicServer> <RG1063> <> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <> <> <> <1405669459845> <BEA-000000> <WebLogic Server "AdminServer" version:

                  WebLogic Server 10.3.5.0  Fri Apr 1 20:20:06 PDT 2011 1398638  Copyright (c) 1995, 2009, Oracle and/or its affiliates. All rights reserved.>

                  ####<Jul 18, 2014 3:44:19 PM HKT> <Notice> <Log Management> <RG1063> <> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <> <> <> <1405669459979> <BEA-170019> <The server log file /prd/stream/obiee/MiddlewareHome/user_projects/domains/bifoundation_domain/servers/AdminServer/logs/AdminServer.log is opened. All server side log events will be written to this file.>

                  ####<Jul 18, 2014 3:44:19 PM HKT> <Info> <Log Management> <RG1063> <> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <> <> <> <1405669459990> <BEA-170023> <The Server Logging is initialized with Java Logging API implementation.>

                  ####<Jul 18, 2014 3:44:20 PM HKT> <Info> <Diagnostics> <RG1063> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1405669460075> <BEA-320001> <The ServerDebug service initialized successfully.>

                  ####<Jul 18, 2014 3:44:20 PM HKT> <Info> <Server> <RG1063> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1405669460158> <BEA-002622> <The protocol "t3" is now configured.>

                  ####<Jul 18, 2014 3:44:20 PM HKT> <Info> <Server> <RG1063> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1405669460158> <BEA-002622> <The protocol "t3s" is now configured.>

                  ####<Jul 18, 2014 3:44:20 PM HKT> <Info> <Server> <RG1063> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1405669460158> <BEA-002622> <The protocol "http" is now configured.>

                  ####<Jul 18, 2014 3:44:20 PM HKT> <Info> <Server> <RG1063> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1405669460158> <BEA-002622> <The protocol "https" is now configured.>

                  ####<Jul 18, 2014 3:44:20 PM HKT> <Info> <Server> <RG1063> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1405669460159> <BEA-002622> <The protocol "iiop" is now configured.>

                  ####<Jul 18, 2014 3:44:20 PM HKT> <Info> <Server> <RG1063> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1405669460160> <BEA-002622> <The protocol "iiops" is now configured.>

                  ####<Jul 18, 2014 3:44:20 PM HKT> <Info> <Server> <RG1063> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1405669460160> <BEA-002622> <The protocol "ldap" is now configured.>

                  ####<Jul 18, 2014 3:44:20 PM HKT> <Info> <Server> <RG1063> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1405669460161> <BEA-002622> <The protocol "ldaps" is now configured.>

                  ####<Jul 18, 2014 3:44:20 PM HKT> <Info> <Server> <RG1063> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1405669460163> <BEA-002622> <The protocol "cluster" is now configured.>

                  ####<Jul 18, 2014 3:44:20 PM HKT> <Info> <Server> <RG1063> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1405669460164> <BEA-002622> <The protocol "clusters" is now configured.>

                  ####<Jul 18, 2014 3:44:20 PM HKT> <Info> <Server> <RG1063> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1405669460169> <BEA-002622> <The protocol "snmp" is now configured.>

                  ####<Jul 18, 2014 3:44:20 PM HKT> <Info> <Server> <RG1063> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1405669460169> <BEA-002622> <The protocol "admin" is now configured.>

                  ####<Jul 18, 2014 3:44:20 PM HKT> <Info> <Server> <RG1063> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1405669460169> <BEA-002624> <The administration protocol is "t3s" and is now configured.>

                  ####<Jul 18, 2014 3:44:20 PM HKT> <Info> <RJVM> <RG1063> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1405669460199> <BEA-000570> <Network Configuration for Channel "AdminServer"

                  Listen Address :7002

                  Public Address N/A

                  Http Enabled true

                  Tunneling Enabled false

                  Outbound Enabled false

                  Admin Traffic Enabled true>

                  ####<Jul 18, 2014 3:44:20 PM HKT> <Info> <RJVM> <RG1063> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1405669460199> <BEA-000570> <Network Configuration for Channel "AdminServer"

                  Listen Address :7001 (SSL)

                  Public Address N/A

                  Http Enabled true

                  Tunneling Enabled false

                  Outbound Enabled false

                  Admin Traffic Enabled true>

                  ####<Jul 18, 2014 3:44:20 PM HKT> <Info> <Server> <RG1063> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1405669460273> <BEA-002609> <Channel Service initialized.>

                  ####<Jul 18, 2014 3:44:20 PM HKT> <Info> <Socket> <RG1063> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1405669460332> <BEA-000436> <Allocating 4 reader threads.>

                  ####<Jul 18, 2014 3:44:20 PM HKT> <Info> <Socket> <RG1063> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1405669460335> <BEA-000446> <Native IO Enabled.>

                  ####<Jul 18, 2014 3:44:20 PM HKT> <Info> <IIOP> <RG1063> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <>

                  • 6. Re: Weblogic Server is not running
                    Avinash Pentyala

                    Hi,

                     

                    Can you start the Web Logic & Node manager from command prompt.

                     

                    Br,

                    Avinash

                    • 7. Re: Weblogic Server is not running
                      deepika walia

                      Hi,

                       

                      Check if below steps can help you.

                       

                      In order to avoid this WLS hook we can add -Xrs or -Xnohup:

                      1. We can add -Xrs in JAVA_OPTIONS in setDomainEnv.sh if you are starting servers via command line

                      2. If you are starting servers remotely i.e. with help of Node manager via WLST or Console add -Xrs in startup arguments

                      3. We can add -Xhohup in case of Jrockit JDK but its not mandatory. Even -Xrs works with JRockit and HP JDK

                      4.  With this parameter we reduce number of signals sent by OS to the JVM. So after adding this parameter we will not be able to take thread dumps with command kill-3 <Weblogic PID>  but we can kill the JVM with kill -9 <Weblogic PID>

                       

                      Thanks